No USB Stuff Works On My C2D MBP!

Discussion in 'Parallels Desktop for Mac' started by czeluff, Nov 5, 2006.

  1. czeluff

    czeluff

    Messages:
    4
    Hello,

    I have a new C2D MBP, and the latest version of Parallels (1970). When I installed it, and tried to use either A) a USB pen drive B) Apple Wireless or C) IR Receiver, it says that the device is in use, and I should try waiting 5-10 seconds, or try shutting off whatever is currently using the pen drive. I can't find ANY way to fix this. I've tried:

    1. Wiping/reinstalling MAC OSX then installing Parallels FIRST before anything else.
    2. Formatting the partition in both FAT and NTFS
    3. Tried older version of Parallels (1940)
    4. tried other pen drives; like i said, it does the same thing when i try to add in the Apple Wireless of Infrared. (Note: iSight, gets added into Windows without error, except that no driver exists).

    So it seems like i've done EVERYTHING. Does the USB problems exist on any other C2D MBPs? If it's a widely known problem then i wont worry about it, but i'm thinking maybe its just my own.

    chad
     
  2. Jerry

    Jerry Bit Poster

    Messages:
    78
    Just do a search. You'll find a lot of threads with people having usb problems / success. The milage seems to vary from person to person.
    Regarding Apple Wireless, that won't work within Parallels, as MacOSX is using it, same with the IR Receiver. I know that it shows up in the USB device list, but unless you go & unload those drivers on the Mac side (using Terminal), the VM will not be able to make use of it.

    [This statement confused people - please read clarification further on]
     
    Last edited: Nov 9, 2006
  3. vrsteve

    vrsteve

    Messages:
    1
    Just to say that I loaded build 1970 on to my MacBook Pro Core 2 Duo on Saturday and wireless networking is working fine. Didn't do anything other than let Parallels install XP Pro for me, no configuration on my part needed, it just works!

    Have not tried any USB devices yet though.

    Regards,
    Steve
     
  4. Jerry

    Jerry Bit Poster

    Messages:
    78
    It would work fine if the Mac is setup for wireless. What I meant was that Parallels can't take control of the wireless device as MacOS X has got control over it. So 'wireless' works within Parallels because of the Shared/Bridged networking, not because Parallels is in control of the wifi card. Try and select 'Apple wireless' from your USB device list - you'll get the infamous 'wait 5-10 sec' prompt.
     
  5. Quickdraw

    Quickdraw

    Messages:
    24
    I'm sorry but.....

    I'm sorry but your statement about apple wireless above cannot be true, unless os x is unloading and loading the drivers on the fly. I say this because I presently have the airport card going and only the airport card going, while at the same time I have Parallels going (most updated version) and Internet Explorer running with a connection to the internet AND Firefox going with a connection to the internet at the same time. I'm not trying to argue or anything, just trying to get the facts straight for both me and the other users here on the forums. If I've misunderstood your post somehow, then please accept my apologies.

    Best regards

    Lonnie
     
  6. Jerry

    Jerry Bit Poster

    Messages:
    78
    No apologies needed! Did you read my post just before your post?
    Here's the test:
    - Start a VM, but in window mode
    - Once windows is up & running, or even at the login screen, select 'Apple Wireless' from the 'Devices/USB' menu, and see what you get...'wait 5-10 sec...'
    - That means that Parallels is not able to 'grab' the wireless card, because OS X controls it.
    - Yes, you can use IE or Firefox to connect to the net because of the NETWORKING BRIDGE that Parallels provides to your wireless card.
    In other words, you are using your wireless from within your VM VIA the networking option, and not because Parallels is controlling the wireless card. If Parallels was controlling the wireless card, you would NOT get the 'wait 5-10 sec' prompt that you get when selecting it from the device/usb menu option.
    Even if you switch your airport off on the mac side, you would still get that prompt, as the kernel is still used by the Mac OS.

    If my statement was wrong, you would be able to select 'Apple Wireless' from the Device/USB menu. Can you select it?

    Clarification: My post was not about whether the VM can make use of wireless (it does VIA networking), but that Parallels can not control the wireless card (and IR) because the Mac OS already controls it.
     
    Last edited: Nov 9, 2006
  7. joem

    joem

    Messages:
    1,247
    Let me try to state the "USB rules" clearly if I can:

    Parallels does not allow the VM to directly control the wireless card, ethernet port, keyboard, mouse, or screen and there is currently no way around this. You can use all those devices, because Parallels provides emulated hardware for them. You cannot use the IR receiver or the built in camera at all.

    You can use a maximum of two USB devices at a time, and usually, if you set autoconnect on, and plug in a USB flash drive, you will have access to it to read and write files. If you need to format it, use FAT32 and format it in OSX or on a Windows PC.
     
  8. Quickdraw

    Quickdraw

    Messages:
    24
    Yea, I saw that after the fact :) I don't remember there being a couple of hours between yours and my post though....(your other post you mentioned was not there when I started mine). I must have been more tired than what I thought that morning :) At any rate, I undertsand your post now. Thanks for clarifying.
     

Share This Page