Non Working Keyboard and Mouse

Discussion in 'Parallels Desktop for Mac' started by NotSoLucky, Feb 1, 2007.

  1. NotSoLucky

    NotSoLucky

    Messages:
    4
    The following report applies equally for RC1 and RC2. In the case of RC2, the Parallels Tools in the VM were updated to the RC2 versions before testing.

    I've been attempting for some time now to enable the keyboard and mouse functionality of a Windows XP VM under MacOS X 10.4.8 in a 17" Intel MacBook Pro. The VM in question is an image of a Dell laptop I own. I attempted for a long time to use several versions of Transporter to create the image with little success. Eventually I used VMware Converter to create a VMware disk image and the used Transporter in MacOS X to convert the VMware disk image to a Parallels VM. This worked the first time.

    I am using an Apple Wireless (Bluetooth) Keyboard and Mouse. I've tried the following both with the wireless devices on and with Bluetooth disabled. I've tried using both the laptop keyboard and trackpad, and the wireless keyboard and mouse, both with the same result.

    Upon booting the Windows XP VM I can use the F5/F8 keys to select boot options. In addition, after clicking on the VM to capture the keyboard and mouse I can use Ctrl-Alt to release the focus, so I know Parallels and at least the boot loader are receiving keyboard input.

    Upon the Windows XP, after capturing the keyboard and mouse input by clicking on the VM, the keyboard does not appear to work. The mouse mostly does not work. Moving the mouse over the VM changes the icon to that of Windows and moving out of the VM changes the icon back to that of MacOS, but trying to click or drag inside the VM produces no result. Neither does using the Actions -> Send Keys menu to send a Ctrl-Alt-Delete key combination to the guest OS.

    If I select from the Parallels USB menu to enable the wireless keyboard in the VM I can then use that keyboard to login into Windows XP, while the mouse still had problems. If I then go into the Windows XP Device Manager and disable the Parallels Mouse Synchronization Tool device (under Mice and other pointer devices), then the wireless mouse works within the VM (as long as its selected via the USB menu). The wireless keyboard and mouse are listed in the Parallels USB menu as "Apple Wireless" or "Apple - Composite". While the wireless keyboard and mouse are enabled in the VM, they cannot be used in MacOS X (like any other USB device enabled in the VM). While this is the case, I can use the laptop's keyboard and trackpad to work in MacOS X or attach an additional USB mouse.

    In the Windows XP Device Manager, under Keyboards, the PC/AT Enhanced PS/2 Keyboard (101/102-Key) displays an error. Opening its properties shows a message of "This device cannot find enough free resources that it can use. (Code 12)". The Resources tab of the properties shows the following conflicts "Input/Output Range 0060 - 0060 used by: PCI bus" and "Input/Output Range 0064 - 0064 used by PCI bus".

    The Standard floppy disk controller shows a similar error (Code 12) [although the VM configuration does not have a floppy device] of 03F0-03F5 and 03F7-03F7 used by PCI bus.

    The ISAPNP Read Data Port shows a different error of "This device cannot start. (Code 10)".

    There doesn't seem to be any other errors. Other functionality such as networking, changing resolution and folder sharing seems to work. I tried to use coherency but it crashed the system, so I won't test that until I get the keyboard and mouse working well.

    I've attempted removing all non-essential devices (DVD/CD, USB, Sound, Floppy, etc) from the VM hoping that it would remove whatever device is causing the conflict without any luck.

    Does anyone have some idea on how to solve this problems to get the keyboard and mouse sharing between guest and host OS without resorting to enabling USB devices?
     
    Last edited: Feb 1, 2007

Share This Page