Not sure why people want phones under Parallels

Discussion in 'Parallels Desktop for Mac' started by sgmiller, Aug 9, 2006.

  1. rossf

    rossf Junior Member

    My SE M600i is syncing perfectly afer applying the hack - could'nt be happier. Are you on XP?
  2. JohnFowles

    JohnFowles Bit poster

    Yes XP SP2. Problem is not syncing, it's just the USB connection which has not been cured. Havey you applied the hack through terminal or just removed the files ? Also, I am in 10.4.8, the dev. release, not yet public.
  3. jurg

    jurg Bit poster

    Why remove the files? You can use kextunload:
    sudo kextunload /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBCDC.kext
    Later you could load them again using kextload in a similar way.
  4. titto

    titto Bit poster


    pls can you help me about to work p990i with parallels:

    thanks in advance
  5. SteveDemy

    SteveDemy Member

    Excellent tip. Renaming the 8 USBCDC files worked for me for using Nokia's PC Suite for communication with an E61. It did however break the functionality of my Ovolab Phlink telephone answering machine software (OS X). That was no surprise, but I had to restore the original .kext names to the USBCDC files to get that working again. So I have one or the other working and am happy to have the option.

    One poster above was worried about the risk of breaking USB access to the machine: I use a VNC client for remote access not dependent on USB. It wasn't needed, but along with a backup, this reduced the risk of non-access. Any newbie (like me) with a touch of common sense should have no problem with this.

    I was not successful using the kextunload command. The terminal came back with a "failed" message. Probably because the files were in use?

    Now I wonder if there may be a subset of the USBCDC files that can be renamed to get the Nokia Suite working, but still keep other desired functionality working? Does anyone know of a source of information describing what these individual files do?

    Also FWIW, as I said in another thread, the Nokia suite doesn't seem to play nicely with other COM-using programs. Regardless of the USBCDC condition, I was unable to get my Elite Simulator software communicating with its external hardware as long as Nokia PC Suite was loaded in XP. Removing Nokia sofware restored communication for Elite.
    Last edited: Oct 15, 2006
  6. a_viol

    a_viol Bit poster

    Please Help!!!
    I followed the instructions of another thread. I removed the files from the IOUSBFamily.kext and backuped them on the desktop. After that I was able to connect to my Motorola V3 in Parallels without any problems, but some days later i recognised that my built in isight cam is not working anymore. When i open photobooth i always get the message that there is no cam connected to the mac or it is used by another program. And the cam isn't recognised by the system profiler.
    I already put the backuped files back to the folder and did a SMC & PRAM reset, without any result. Can anybody help me to find a solution for that problem? :(
  7. a_viol

    a_viol Bit poster

    I fixed the problem. I reinstalled the 10.4.8 Intel combo update and now it seems to work again.
  8. Firas

    Firas Bit poster

    I used jurg's suggestion and issued the following command:

    sudo kextunload /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBCDC*.kext

    (Note the asterisk to avoid retyping the command for each file separately)

    Even though, several of the files failed to unload, I could now use Nokia's Software Update program under Paralles (with Automatic USB Connect enabled) without having to delete or move any of those system files.

    Thanks to everyone for the great workaround!
  9. a_viol

    a_viol Bit poster

    Last time I started my macbook everything worked again, now the isight cam is gone again and i get
    the message that all those USBCDC files were not installed correctly. Can anyone tell me how to reinstall them without reinstalling the OS?
  10. joem

    joem Forum Maven

    If you just unloaded the extensions, restarting is all you need. If you moved them, you need to put them back. If you can't do that, you can get copies from a backup (you do backups, right?) or another installation. You can install OSX on an external disk, and copy files from that installation (be sure to apply all current updates to both copies first so the versions are in sync).

    If you don't have an external disk, buying one might save you a lot of hassle in the long run.
  11. rabati

    rabati Bit poster

    Using a Shell script tu Safetly load/unload Kernel Modules

    Following a suggestion from JURK (thankYou) I built a shell script to disable the modules (later I'll change to perform enable, disable via applescript) .

    This is absolutely safe. You have to run it as root or administrator via terminal.

    This is the script:

    kextunload /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBCDC.kext
    kextunload /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBCDCACMControl.kext
    kextunload /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBCDCACMData.kext
    kextunload /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBCDCDMM.kext
    kextunload /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBCDCECMControl.kext
    kextunload /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBCDCECMData.kext
    kextunload /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBCDCEEM.kext
    kextunload /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBCDCWCM.kext
  12. daphilip

    daphilip Bit poster

    Parallels should not charge for this product!!

    This is ridiculous!!! This product is not ready for prime time, and it should be freeware instead of charging $80. The primary reason I purchased this software was to enable me to use Dragon Naturally Speaking and connect my Nokia 9300 to the Mac. Now I find that neither works with this pitiful software, and Parallels Support does not even respond to queries. Not only that, but it says right on the software carton that I should be able to copy and paste between Windows XP and Mac OS X, which I now find is totally untrue going from XP to the Mac. I feel taken!!

    Although I appreciate the creative solutions voiced above, being able to access the USB ports for whatever purpose one wants should be provided as a matter of course by Parallels. I should not have to input some complicated hack that might disable the Mac side just to use my USB ports. That is like buying a car and finding the windshield wipers don’t work and the manufacturer telling you the only way to get them to work is to go under the hood and rewire the car – and by the way the electric windows won’t work after you do that.

    Doesn’t anyone at Parallels try the product before selling it?

    Parallels should give everyone their money back and go back to the drawing board until they work the majority of the kinks out of this.
    :mad: :confused:
  13. joem

    joem Forum Maven

    Well, people are posting that they have DNS working, so there's proof of concept.

    Parallels does a number of very useful things for me, allowing me to use windows software, even on the Internet. I think it's worth the money even though it doesn't do everything I'd like it to.

    I copy files between the Mac and Windows environments regularly, using a network connection, not the clipboard, and haven't had problem one.

    So while I'm sure you are having the problems you describe, and I'm sure you're frustrated not being able to get things done, it seems that it isn't Parallels per se that's the problem.

    No product does everything. Not OSX, Windows, or any other software product, nor can I find hardware that will give me 4 3GHZ cores, 16 gig of RAM, 1000 gig of fast disk, 10 hours of battery life, a 3000 x 2000 screen, weigh five pounds, and cost under $2000. I wish I could, but I couldn't, so I got an MBP, and I'm happy with it for now.

    For a product from a really small company, that's only been out for a few months, I think Parallels is a pretty good product, and I'm sure they'll improve it. I'm being patient.
  14. a_viol

    a_viol Bit poster

    I backuped the removed files by copying them to the desktop but when i put them back to the original folder the startup took a long time and i got the message that os wasn't able to load those files. Now the files are back in this folder but i don't know if they are used by the os.
  15. joem

    joem Forum Maven

    Repair permissions.
  16. MartinBear

    MartinBear Member


    My mileage definitely varies when I try to unload the AppleUSBCDC*.kext files. On my system (MacBook Pro, OX 10.4.8) i get a "failed" for each and every file. I'm doing this from the Root account.

    I did try renaming the files and then restarting. When I did that, I found that Parallels Desktop wouldn't even recognize that the phone (Nokia E60) was on the USB bus. (Neither did Apple System Profiler). OTOH, from the Root account I could load the files, and also unload (but I stopped playing before I loaded all of them)

    So ... I renamed everything back to *.kext, restarted, logged in as Root, and tried unloading each of the files. Again "fail" but I kept on until all the files had been unloaded (or, rather, until I had a fail message for each attempt).

    Now login as my normal self, start Parallels, insert the Nokia, and -- surprise -- now it is recognized by Parallels. I could mount it and work with it with Nokia PC Suite and made a backup.

    Then I pushed my luck: I tried the Nokia Software Updater. That worked, too, except the upload to the phone (49 MB !!) stopped about 2/3 of the way through. I could hear the USB "ding dong" sound from Windows as the connection dropped. Now the phone is brick until I can get Nokia service to bring it back from the dead. Good thing I have a) a spare phone and b) the aforementioned backup.

    This seems a rather uncertain and risky businss. The fix seems to lie more with Apple than with Parallels, but between them this has got to become more reliable.

    My thanks in advance for any comments and/or advice

    MacBook Pro, 2.13GHz Core Duo, 2GB RAM, 120GB disk
    Mac OS 10.4.8
    Parallels: WinXP SP2, 768MB RAM
    USB not set for autoconnect
    Last edited: Oct 27, 2006
  17. a_viol

    a_viol Bit poster

    this was one of the things i tried first, but unfortunately without success. It seems as reinstalling OSX is the only solution.

Share This Page