Ocassional zero-byte files checking out git repos into a shared folder.

Discussion in 'Linux Guest OS Discussion' started by CoreyC3, Nov 29, 2018.

  1. CoreyC3

    CoreyC3

    Messages:
    1
    On my mac, I created a case-sensitive partition for storing files accessible to both the Ubuntu VM and the Mac host. The partition is a APFS Volume (case-sensitive, encrypted) in the same APFS Container as my main mac hard drive. I shared a folder in that partition with my Ubuntu VM by adding it under Custom Folders in the VM configuration.

    In the shared folder on the Ubuntu VM, when I clone a large git repository (i.e. a custom linux-kernel), I get errors like "error: unable to create file arch/m68k/hp300/README.hp300: File exists" and the file ends up being zero-bytes. I can recreate the problem via "rm -rf *;git reset --hard", which forces a re-checkout from the local git repository. Each time, I get the error for different set of files (1-4 of them). When I perform the same operations on the Mac (in the same folder), none of the problems occur. When I perform the same operations on a non-shared folder in the Ubuntu VM , none of the problems occur. Also, this problem has not occurred with smaller git repositories. This leads me to suspect that there may be a problem with Parallel's shared filesystem (prlfs) driver when it is under heavy load. It seems like some sort of race condition between creating and populating the file.

    My Ubuntu VM was configured with 2 CPU cores. I tried with 1 CPU core and had the same result. It also has 3GB or RAM. I tried with 4GB and had the same result.

    Host OS is MacOS Mojave
    Parallels version is 14.1.0
    Ubuntu version is 18.04

    This is similar, but not the same, to https://forum.parallels.com/threads...-and-usb-driver-after-upgrade-to-pd14.345312/ and https://forum.parallels.com/threads..._release-returns-error-22.345289/#post-844233. I am not getting errors from prlfs, I am not having problem reading files in the shared folder, and the 14.1.0 update did not resolve it.
     

Share This Page