Older NIC emulation (before Gigabit)

Discussion in 'Other Virtual machines' started by sasdrq, Apr 27, 2011.

  1. sasdrq

    sasdrq Junior Member

    I tried to install an old release of FreeBSD (4.4) yesterday and the OS didn't recognize the NICs. My mac pro has two NICs and a more current release of FreeBSD (8.2) sees them as:

    em0: <Intel(R) PRO/1000 Legacy Network Connection 1.0.3>

    This driver was not available in FreeBSD 4.4 so I had no network. I tried using:

    Default Adapter
    Ethernet 2

    But 4.4 didn't recognize any of them.

    I ended up using VirtualBox to solve this problem. It allows you to emulate various NICs instead of giving you no choices. VirtualBox offers: PCnet-PCI II, PCnet-FAST III, as well as several Intel PRO (gigabit) NICs. The PCnet-PCI II worked for me (and FreeBSD 4.4).

    Has anyone else solved an issue such as this with an older OS with no drivers for the newer mac hardware?

    Will Parallels ever offer older hardware emulation?
  2. Elric

    Elric Parallels Team

    it is possible to switch to Realtek8029 emulation:
    Open virtual machine configuration, switch to Hardware tab and in Boot order section add the string "devices.net.force_adapter_type=rtl" under boot flags:


    I don't know whether this applies to BSD4.4, but when networking is in the rtl-mode, it is possible to install paravirtualized network driver (by Alexander Nedotsukov) which provides good networking performance in this mode: http://www.freebsd.org/cgi/cvsweb.cgi/ports/emulators/parallels-tools/
  3. sasdrq

    sasdrq Junior Member


    That works! FreeBSD 4.4 recognized the device as:

    ed0: <NE2000 PCI Ethernet (RealTek 8029)> port 0x8200-0x821f mem 0xee000000-0xee0fffff irq 7 at device 5.0 on pci0
    ed0: address 00:1c:42:0b:ef:c2, type NE2000 (16 bit)

    I defined it and now can communicate to the world:

    ed0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    inet6 fe80::21c:42ff:fe0b:efc2%ed0 prefixlen 64 scopeid 0x1
    inet netmask 0xffff0000 broadcast
    ether 00:1c:42:0b:ef:c2


    What other network adapter types are available? Is this documented anywhere?
  4. Elric

    Elric Parallels Team

    Glad to hear that problem is solved

    Unfortunately, afaik it is not documented anywhere (except in parallels knowledge base) for Parallels Desktop. So far there are only two network types available: rtl and e1000
  5. aphor

    aphor Bit poster

    FYI, in Parallels 6 you can switch from the newer emulated Intel Pro/1000 to the older emulated RealTek 8029 by making this change to this (for each) NIC setting in the config.pvs while the VM is turned off:

    - <AdapterType>2</AdapterType>
    + <AdapterType>1</AdapterType>
  6. George S

    George S Bit poster

    This ancient post got my even more ancient OS running! For anyone else that might be trying to find the right base I/O address or interrupt for NE2000 emulation on other OSes, use address 0x8200 and IRQ 7. (Your OS might say it's an invalid address since it's not s low number like 0x300, but try it anyway - it worked for me, finally showing the MAC address I have in Parallels instead of FF:FF:FF:FF:FF:FF.)

Share This Page