OLE difficulties with Parallels

Discussion in 'Windows Guest OS Discussion' started by WEthan, Dec 4, 2011.

  1. WEthan


    I run Parallels 6 on OsX Lion (MBP i7 dual core/ 4 GB RAM). Originally I ran Windows XP/Office 2007 and was unable to open Excel or Powerpoint files embedded in Word Documents (Office Mac doesn't open embedded PPT files). After multiple installs of Office with no resolution, I created an entirely new VM using Windows 7/Office 2010. I have the same problems with the new installation. Get the same problem -- the embedded object appears as "unknown object" although the icon for Excel or PPT is there and Windows says that the application cannot be located. Embedded word files within words or PDF open correctly. The relevant filetypes seem to be registered correctly. Is this a known issue with Parallels desktop or the desktop tools? Odd to get the exact same problem with two totally different VM's. Probably should have gone the bootcamp route, but there are many reasons why I don't want to do that. Any advice? Would upgrading to Parallels 7 help?
  2. AndrewWe


    Any Update

    I have also experiencing this issue. Was there any resolution?
  3. WEthan


    None that I'm aware of. I still have the problem. I had it with Windows XP running under Parallels 6 and still have it with Windows 7 running under Parallels 7.
  4. sjsherratt


    I am seeing the same thing. Windows 7, Office 2010, Parallels 7.0.15016. Embedded Excel files inside a Word doc do not open correctly. They show up as Unknown. Other file types (i.e. .txt .pdf) show up as Packager Shell Objects that have correct properties (right click on the object to see the properties). At first this seemed to be some sort of Windows policy issue, but after seeing that other Parallels users are having the same issue, this may be a Parallels problem ?
  5. judas_s

    judas_s Bit Poster

    I can confirm this in two completely independent Parallels 8 installations (Different computers, both Windows 8, one Office 365, the other office 2010).

    To recreate the problem:

    1. Create a new file in word
    2. Embed a MS Excel Table (Insert > Table > MS Excel Spreadsheet)
    3. Verify it's an excel object (Click away from embeded spreadsheet, then select the object, "Microsoft Excel Spreadsheet" appears in Word's status bar)
    4. Save the file as a .docx file
    5. Close Word
    6. Open the file in word.
    7. When selecting the object, UNKNOWN is shown.

    The file is fine, as it can be opened and the embedded spreadsheet edited in MS Office for mac & on a normal Windows PC.

    Please, can anyone else confirm this behaviour in order to file a Bug with the parallels team, as this is a serious issue.
  6. judas_s

    judas_s Bit Poster

    Ok so after investigating further, it definetly is an issue caused either by parallels or by parallels default configuration, which is either interfering with OLE or with some type of network policy that it chooses by default.

    I found a workaround for this:

    1. Open the "damaged" .docx file in Word for Mac
    2. Save the file as .doc
    3. Open the file in Word for Windows. As this is a binary file, the embedded documents do get recognized as Excel Spreadsheets.
    4. Caution: DO NOT upgrade the new document to .docx file, as the objects will turn to UNKNOWN again.

Share This Page