OneNote 2016 lag issue in non-Coherence mode

Discussion in 'Windows Guest OS Discussion' started by AlbertH2, Sep 20, 2018.

  1. AlbertH2

    AlbertH2 Bit Poster

    Messages:
    11
    I'm experiencing a keyboard input lag in OneNote 2016 except Coherence mode. One key stroke will take nearly half second to show up.
    Strange thing is, this only happens for OneNote, not any other windows or office applications like Outlook, Word, Powerpoint... etc.
    But in Coherence mode, there is no lag at all. In non-Coherence mode, no matter it is full screen mode or windows mode, both lags.
    And in non-Coherence mode, if I point cursor to OneNote first and then move my mouse pointer arrow to my secondary monitor and then start typing, there is no lag either!!

    This is really annoying. I have tried multiple combinations of restart/reinstall, nothing worked. Appreciated if anyone could hint any possible solution for this.

    The following are my environment information:
    Macbook Pro 2018 13 Touchbar 16GB 512GB SSD
    Windows 10 Home Edition version 10.0.17134.285
    VM resource allocation: 2 CPU and 8 GB RAM in VM
    OneNote 2016 build 1803 9126.2282
    Parallel Desktop 14.0.1 (45154)
    MacOS High Sierra 10.13.6​
    Thanks!
     
    Last edited: Sep 20, 2018
  2. AlbertH2

    AlbertH2 Bit Poster

    Messages:
    11
    I did a follow up test. I opened a task manager in Windows guest OS to monitor the CPU usage.
    1. When there is no lag, (in coherence mode or my mouse pointer is in another monitor), while I type really fast, the CPU usage of OneNote 2016 can be up to 20%.
    2. When there is lag, the CPU usage is only limited to 4%. At the same time , not other process is increasing it's CPU usage. And the total CPU usage is only 11% including OneNote. Not sure what is blocking OneNote.
     
  3. AlbertH2

    AlbertH2 Bit Poster

    Messages:
    11
    Did another test. If I move the mouse pointer away from the typing area in OneNote, the mouse pointer will changes from shape like an "I" to an arrow, the lag will also be gone.
     
  4. AlbertH2

    AlbertH2 Bit Poster

    Messages:
    11
    OK, after trying lots of different settings, finally found the solution. In PD's configuration: -> Hardware tab -> Mouse & Keyboard -> set Mouse to "Do NOT optimize for game". I thought I had set to it already but actually it was set to "Auto detect for games"(in Chinese the wording for these two options are very similar so lead to my oversight.) So the Keyboard lag is actually caused by a Mouse setting. Anyway, happy finally get it fixed.
     
    Last edited: Oct 10, 2018

Share This Page