Ongoing printer problems

Discussion in 'Parallels Desktop for Mac' started by wingmate, Nov 8, 2006.

  1. wingmate

    wingmate

    Messages:
    20
    I have an HP LaserJet 4000 that I have configured via Bonjour as a Generic/Postscript Printer in Parallels. It usually will print only one document before it seems to lose its connection although it will sometimes print several documents in a row without a problem. I am mostly using MS Works within Windows XP when I encounter this problem.

    When I go to System Preferences and open the printer dialog, I get a spinning blue and white "barber pole", a message saying "sending data", then "GenericClass: waiting for device" and nothing happens. Sometimes, if I go back to the Mac side of the world and try and print something, it will print everything in the Q. The printer is attached to my Intel iMac via the USB port to the printer via its parallel port. I have tried stopping the job and then restarting but this rarely works. Often it seems to just decide on its own that it is time to resume printing.

    This is becoming very, very annoying and has made me regret leaving the PC world and coming over to the Mac world.
     
  2. CJConline

    CJConline

    Messages:
    19
    Shared concern

    Yes I am afraid that due the the lack of proper USB support , Parallels is not currently a viable option to replace Windows.

    See this thread and my post at the end - http://forum.parallels.com/thread4183.html

    Bootcamp may be your only alternative for now if you require better USB device support.

    Chris
     
  3. H2oman

    H2oman

    Messages:
    1
    I have been having a printing (no printing) problem since I installed Parallels and put a VM with Windows XP on my Mac Book Pro. I have read all the advice on this Forum (onlly a small amount of which I can understand). No help from the Company -repeated attempts to get answers via email to tech's are unanswed. Mr.SA seems to know what he is talking about, but most of it is over my head.
    Anyone have suggestions - I hate to walk away from my investment in software etc. but this whole thhing "sucks"
     
  4. dkp

    dkp

    Messages:
    1,367
    You don't say what you've done so far so...

    Turn off Parallels. Completely off.

    Umount and disconnect any USB devices except keyboard/mouse, and printer.

    Verify you can print several pages from OS X without error. If it doesn't do this it certainly won't print right in Windows. If this test fails reboot OS X and cycle the printer power. Nothing like a fresh start to clear out the cobwebs.

    Make certain the printer is shared. Open the printer queue so you can watch print jobs come and go.

    Start Parallels and load but don't start Windows. We want to examine a setting before Windows starts. If Windows is set to autostart, disable the option.

    Make certain the VM is not configured to autoattach USB devices. You don't want Windows to grab the USB ports. Especially the printer port.

    Start Windows (in a window so you can also see the printer queue in OS X), log in, open Bonjour and verify your printer configuration is correct. Open the control panel and printer manager and make certain Windows has the correct printer definition installed for the printer type.

    Open a Windows app and see if you can print something. Preferrably something several pages long. While it's printing (hopefully it's printing), go to OS X and open the printer object and watch the printer queue. Because printers have large memory cache's now it may be idle. You have to be quick :)

    Let's be optimistic and assume printing worked perfectly. Open the Parallels Devices menu, go the the USB option, and in there select your printer. This will cause Windows to attach that USB port. All your printing should immediately stop working and will not work again until you unselect that printer. We did this just to show what happens when Windows and OS X fight over USB devices. Hopefully, as happens in my case, unselecting the printer in Parallels will return control to OS X. The point being, Windows can never grab that device without screwing up your printing.

    If this failed, please let us know. If it works, let us know that, too.
     

Share This Page