Open in IE Button

Discussion in 'Windows Guest OS Discussion' started by sabre86, Sep 1, 2012.

  1. sabre86

    sabre86 Bit Poster

    Messages:
    7
    HAs anyone else had a problem with getting the Open in IE button to come up in Safari? I can't get that to come up for me at all. Support suggested uninstalling Parallels Desktop and reinstalling, witch I did, but it did not work.
     
  2. juzci

    juzci Guest

    Hi,
    what do you mean: you have no button or you have one, but it doesn't work?

    Regards,
    Hanna
     
  3. sabre86

    sabre86 Bit Poster

    Messages:
    7
    No button at all.
     
  4. juzci

    juzci Guest

    O-oh. Could you please start PD, start Safari, send us Problem Report as described in http://kb.parallels.com/en/9058 and give me an ID?

    Thanks in advance,
    Hanna
     
  5. sabre86

    sabre86 Bit Poster

    Messages:
    7
    I finaly got it working The support group suggested I open Safari preferences and go to extensions, get extensions. That did not work because there was not Open in Internet Explorer extension available. What I had to do was relaunch the PD8 .dmg icon. It opens a folder with 7 items, one of which is called Parallels Desktop. Opening this to get to Contents/library/safari/Extensions yields a file called OpenIE.safariextz. Right clicking allows opening with Safari which installs the extension. It now works as advertised.
     
  6. alexg

    alexg Parallels Developers

    Messages:
    536
    To get the button in the Safari you need restart it after Parallels Desktop 8 installation. There is no way to install Safari extension without relaunching the application.
     
  7. AshanT

    AshanT

    Messages:
    5
    This is still not working for me, can you please tell me how to enable this?
     
  8. alexg

    alexg Parallels Developers

    Messages:
    536
    AshanT,

    Do you have Parallels Desktop 8 installed?

    Alex
     
  9. AshanT

    AshanT

    Messages:
    5
    Hi Alex,

    Yes i do have PD8 installed and registered in my computer.
     
  10. alexg

    alexg Parallels Developers

    Messages:
    536
    AshanT, please check if OpenIE.safariextz present in ~/Library/Safari/Extensions/ folder.
     
  11. AshanT

    AshanT

    Messages:
    5
    Alex,

    Yes it was, and it installed once i double clicked the icon.

    Tested it out, works like a charm!

    Thanks a lot
    Ashan
     
  12. NotoriousBIC

    NotoriousBIC

    Messages:
    3
    Same behaviour here, had to locate the extension in the Library manually.

    However the button still doesn't work. When I click it, I get a very brief Safari error stating "... because OS X doesn't recognize Internet addresses starting with "prli:" and then redirects to http://www.parallels.com/products/desktop/open-in-ie/

    Problem Report submitted: 17750652
     
  13. juzci

    juzci Guest

    NotoriousBIC,
    thank you for the feedback (and thank you twice for attaching Problem Report :)), we will investigate it.

    Regards,
    Hanna
     
  14. KirillBagrinovskiiy

    KirillBagrinovskiiy Parallels Developers

    Messages:
    50
    NotoriousBIC, please do this steps:
    - turn off firewall if you use it
    - quit from Safari
    - quit from Parallels Desktop
    - reboot your Mac
    - start Parallels Desktop
    - start Safari
    - try use Open in IE button
     
  15. RadekV

    RadekV Bit Poster

    Messages:
    18
    I got same problem. I have IE extension in Library, Safari folder. It works on my home PC but does not on work PC.
     
  16. NotoriousBIC

    NotoriousBIC

    Messages:
    3
    After the restart this does work for Windows XP Guest OS with IE8. However Windows 8 Guest OS with IE10 does not work. The behaviour is slightly different; when clicking the open in IE button, PD does take focus away from Safari, but doesn't open IE, even if it was already open.

    With XP guest OS it's opening in windowed, coherence mode and full screen (although it doesn't switch to the XP desktop).
     
  17. RadekV

    RadekV Bit Poster

    Messages:
    18
    My problem is I cant see "Open in IE" button in Safari....correct: Ive got NOT same problem like Notorious...
    Other extensions "translate and so on" work properly.
     
  18. KirillBagrinovskiiy

    KirillBagrinovskiiy Parallels Developers

    Messages:
    50
    RadekV, please restart Safari and check "Open In IE" extension exists in Safari (check it in Safari Preferences -> Extensions)
     
  19. KirillBagrinovskiiy

    KirillBagrinovskiiy Parallels Developers

    Messages:
    50
    NotoriousBIC, are you have updated Parallels Tools in Windows 8 guest?
    If Parallels Tools Updated please click on "Open In IE" button in Safari and generate Problem Report after PD take focus. Please write you report ID here

    Thanks for your answer!
     
  20. RadekV

    RadekV Bit Poster

    Messages:
    18
    There is no Open in IE extension in preferences. I have Google translate extension there only. But physically it is in Library/Safari on HDD.
     

Share This Page