"Open With" not sticking? (Numbers/Excel)

Discussion in 'Installation and Configuration of Parallels Desktop' started by Jay Levitt, Jul 14, 2008.

  1. Jay Levitt

    Jay Levitt Member

    Every few days, my Mac seems to forget that I've told .xlsx and .xls files to "Open With" Microsoft Excel 2007 on my Parallels guest. I'm not sure if it's happening after host reboots, guest reboots, or what...

    Anyone had this problem?

    Host: Leopard 10.5.4
    Guest: Windows XP SP3
  2. John@Parallels

    John@Parallels Forum Maven

    I suppose you are using undo disks:
    Check for them in
    Configuration Editor-Configuration-Options -Advanced
  3. Jay Levitt

    Jay Levitt Member

    Nope - Undo Disks is (and always has been) unchecked. Any other ideas?
  4. John@Parallels

    John@Parallels Forum Maven

    Ok, let see:
    in Windows
    Start Run regedit
    locate HKCR\.xls - export it to save
    delete it

    Copy lines bellow to notepad
    Save it as "1.reg" with quotes
    double click it

    "Content Type"="application/vnd.ms-excel"










    check for xls files accosiation
    if it succeeds I will give you another one for xlsx
  5. Jay Levitt

    Jay Levitt Member

    I'm talking about opening files in Finder (Mac host), not Windows Explorer (Windows guest).
  6. John@Parallels

    John@Parallels Forum Maven

    When Parallels Desktop is running
    Applications -Edit - Select Excel Documents and select desired Application
  7. Jay Levitt

    Jay Levitt Member

    I think I didn't state the problem clearly... Here are the steps to reproduce:

    1. In Finder, open a folder on the root Mac drive, containing an .xlsx document
    2. Select the .xlsx document
    3. Press Command-I to Get Info
    4. Under "Open With", select "Other"
    5. Navigate to the VM's copy of Excel (in my case, /Parallels/VMs/Slate/Windows Applications/Microsoft Office Excel)
    6. Check "Always Open With"
    7. Click "Add"
    8. Click "Change All..."
    9. Select "Continue"
    10. ...time passes...
    11. Get Info on the same document will now say it "Open With" Numbers, not Excel.

    Even when Finder says it opens with Numbers, Parallels SmartSelect > Edit > Excel Documents will still say Microsoft Office Excel.

    I'm not sure exactly what happens in step 10 to make the associations go away. It's not just a guest reboot or a Parallels quit-and-restart. It could be a host reboot, or an Apple software update...
  8. ziba

    ziba Member


    You can try the following:
    1. Reinstall Parallels tools in your Windows Vm
    2. Configure Smartselect as suggested in Parallels Desktop user Guide (chapter "Using smart select")
  9. John@Parallels

    John@Parallels Forum Maven

    Ok, i got it,
    You need to use Applications -Edit- Microsoft Excel and select from there
    or delete Microsoft Excel from Vm folder/Windows Applications
    and from inside Windows select for xslx file Numbers,
    Mac OS doesn't affect Parallels settings, you need to perform operations from Parallels to make Mac aware about changes
  10. Maccer

    Maccer Junior Member

    I'm running build 5608 and had kind of the same problem, but in the opposite direction:

    I have text files ending in .sql in Mac OS, and I want them to open in the Smultron text editor in Mac OS. But the files were always linked to the Notes app in (some other SQL-server app also appeared in the list) inside the WinXP virtual machine even though I had chosen Smultron and pressed "change all". The setting was reset to "Notes" and the Smultron app was gone from the "open with" list the list next time I selected "show info" for the same .sql file I had just changed. Everytime I double-clicked a .sql file the virtual machine started.

    I found this post and deleted the Notes and SQL applications from the Windows Applications folder in the VM folder. It solved the problem - the files now open in Smultron. But should it really be this way? Why can't the "Windows Applications" and my chosen MacOS apps co-exist in the "Open with" menu, and why doesn't my setting to open the files in MacOS stick if the Windows Applications are there?
  11. John@Parallels

    John@Parallels Forum Maven

    Try to CTRL-Click .sql file and select open with select Smultron and select Always Open With

Share This Page