OpenBSD+NetBSD: high key repeat rate, high CPU usage when idle

Discussion in 'Other Guest OS Types Discussion' started by MartinC27, Feb 11, 2022.

  1. MartinC27

    MartinC27 Bit Poster

    Messages:
    1
    Both NetBSD and OpenBSD cause me two problems in Parallels:
    - key repeat rate is so high that you can't really type anything correctly
    - high CPU usage when idle (measured by host as 6% each)

    Both are set to "Other" OS in Paralllels. FreeBSD shows neither of these problems (Parallels set to "FreeBSD").

    I found a recommendation to do `sysctl -w kern.timecounter.hardware=acpihpet0`. For me, this didn't fix it.

    Any recommendation? What to try next?

    Also, does anybody know what the actual difference is when setting OS to FreeBSD or Other in Parallels?
     
  2. CristianC3

    CristianC3 Bit Poster

    Messages:
    1
    I have the same problem, tried OpenBSD 7 and 7,1.
    I have Parallels Version 17.1.2 (51548), and using a MacBook Pro 16, 2,4 GHz 8-Core Intel Core i9, 64 GB 2667 MHz DDR4, MacOS Monterey versiion 12.3.1.
    In OpenBSD I cannot even install, from the start I have repeated keystrokes. There is no problem in VirtualBox or in VmwareFusion.
    The "sysctl -w kern.timecounter.hardware=acpihpet0" I cannot try as I do not have the system installed. I tried also at boot prompt: "set tty fb0", but this is for framebuffer on ARM machines, does not help.
    I would appreciate any insights.
     
  3. AlbertT3

    AlbertT3 Bit Poster

    Messages:
    1
    I'm having the same problem, OpenBSD 7.2.
    It is barely usable and impossible to set up a password.
    I tried both Keyboard optimized and not optimized for games.
    I also would appreciate any help.
    MacBook Pro Core i9 Ventura 13.0.1
     

Share This Page