OpenGL

Discussion in 'Windows Guest OS Discussion' started by tey, Sep 29, 2011.

  1. tey

    tey

    Messages:
    5
    First post here. I am using a 2011 MBP 13" 2.7GHz with parallels 7 and windows 7 sp1. I do a lot of CAD work, Solidworks 2012/11/10 in my Parallels vm. I realize this is a longshot, but anyone know how to... spoof the graphics card? The card is a HD3000, which supports OpenGL 3.0, but, of course, solidworks won't acknowledge this so it forces me to "Use Software OpenGL". They do support the P3000, which according to some searches, supports OpenGL 3.0 also, and if tom's hardware is believed, has no hardware difference compared to the HD3000.

    So...
    -Does Parallels not allow OpenGL, or
    -Is there a way to just tell Windows I'm using a P3000, or
    -Curse Solidworks for hard-coding in graphics card names and not just using the standard?

    Thanks
     
  2. tey

    tey

    Messages:
    5
    No idea?

    So after reading Ars Technica's review, which places Parallels 7 in the lead, I decided to try VMWare 4. Looks like it supports OpenGL. I downloaded the free trial, imported my Parallels machine, and Solidworks recognized that my graphics card could support OpenGL.

    Any ideas how to get Parallels to play nice with OpenGL?
     
  3. serv

    serv Parallels Developers

    Messages:
    777
    tey,

    SolidWorks may specifically disable OpenGL in Parallels. You need to tweak its registry settings to get 3D acceleration back.
    1. Open this registry branch
    HKEY_CURRENT_USER\Software\SolidWorks\SolidWorks 2010\Performance\Graphics\Hardware\
    and locate the key that match your graphics chip (ATI or NVIDIA), note "Workarounds" value.
    Example:
    [HKEY_CURRENT_USER\Software\SolidWorks\SolidWorks 2010\Performance\Graphics\Hardware\ATI Technologies Inc.]
    "Workarounds"=dword:XXXXXXXX
    2. Locate related key for Parallels and put Workarounds value from above in there:
    [HKEY_CURRENT_USER\Software\SolidWorks\SolidWorks 2010\Performance\Graphics\Hardware\Parallels and ATI Technologies Inc.]
    "Workarounds"=dword:XXXXXXXX

    Just realized you're running on Intel HD3000, so you'll need to edit Parallels and Intel key.
     
  4. tey

    tey

    Messages:
    5
    Thanks for the response.

    In that registry location I can find

    \HKEY_CURRENT_USER\Software\SolidWorks\SolidWorks 2011\Performance\Graphics\Hardware\Intel\Intel(R) HD Graphics\V001......

    In that location there is a Workarounds value that is not Hex:10.

    However, in the base Solidworks location:
    \HKEY_CURRENT_USER\Software\SolidWorks\SolidWorks 2011\Performance\Graphics\Hardware
    There is no folder for Parallels and/& Intel. There are only four folders for ATI/NVIDIA
    Parallels and ATI Technologies Inc.
    Parallels and NVIDIA Corporation
    Parallels Inc. & ATI Technologies Inc.
    Parallels Inc. & NVIDIA Corporation

    All of those had the Hex:10 Workarounds value. I tried changing all of those to my Intel value, but it didn't change the OpenGL setting in Solidworks.

    Attached is are screenshots from Parallels and VMWare showing the difference.

    Thanks again for the help

    Edit: I am using Solidworks 2010 and 2011. The above is from 2011. In my 2010 registry there are no sub folders in the Intel folder. The workarounds in the base Intel is Hex:10.
     

    Attached Files:

    Last edited: Oct 3, 2011
  5. serv

    serv Parallels Developers

    Messages:
    777
    You don't need to patch the registry then. Are you sure "Use Software OpenGL" is grayed out and can not be unchecked?
     
  6. tey

    tey

    Messages:
    5
    Yep. Those screenshots are exactly what it looks like. I just started using Parallels 6 about 8 months ago, and had resigned to the fact that it was solidworks not supporting the graphics card. I hoped Parallels 7 would help, but it didn't. I have also reinstalled Windows/Solidworks (new machine, clean start) and that didn't un-grey the option either.

    I'd rather use Parallels (better UI), so let me know if there is any info I can post to help resolve this. Using Software GL (Parallels) vs actually using (VMWare) is staggeringly slow.
     
  7. serv

    serv Parallels Developers

    Messages:
    777
    Can you try adding this key and putting XXXXXXXX from ATI or Intel
    [HKEY_CURRENT_USER\Software\SolidWorks\SolidWorks 2010\Performance\Graphics\Hardware\Parallels and Intel Inc.]
    "Workarounds"=dword:XXXXXXXX

    Edit: Make sure SolidWorks release year in the key matches what you're actually running.
     
    Last edited: Oct 3, 2011
  8. tey

    tey

    Messages:
    5
    And making a key with that name and putting a Workaround value from Intel or from Nvidia Quadro 4 both worked!

    Now do I gain anything from using a certain workaround value over another?
     
  9. serv

    serv Parallels Developers

    Messages:
    777
    Those values certainly depend on H/W capabilities, so I'd stick with Intel value, not Quadro. What exactly each bit means is beyond me. I suggest you contact SolidWorks support regarding that.
     
  10. CDavis_fx

    CDavis_fx

    Messages:
    1
    Just wanted to chime in and say thanks! I'm using a MBA 2011 11", with Parallels 7 and also with Boot Camp. I noticed this Solidworks/software OpenGL issue in Boot Camp first, and was able to edit the registry as suggested. Worked like a charm! Was able to also add key for Parallels - also worked! The checkbox in Solidworks options 'unchecked', and the orange highlighting became instant. Also improved shaded rendering (fixed some improper rendering I saw previously).

    For the record - I used a Workarounds value that I found from a desktop installation of SW2011 on another machine.

    I edited:
    \HKEY_CURRENT_USER\Software\SolidWorks\SolidWorks 2011\Performance\Graphics\Hardware\Intel
    and changed Workarounds value from Hex:10 to Hex:4000480.

    And created:
    \HKEY_CURRENT_USER\Software\SolidWorks\SolidWorks 2011\Performance\Graphics\Hardware\Parallels and Intel Inc.
    and created DWORD value "Workarounds" Hex:4000480
     
  11. ShervinJ

    ShervinJ

    Messages:
    3
    I tried this on my wife's 2011 13" MBA and it worked great, but when I try it on my 2011 MBP 13" the option for opengl will not change. I tried using 10 and 4000480 for the workarounds. The value under under Intel is 10. Is there something else I need to do?
     
  12. ShervinJ

    ShervinJ

    Messages:
    3
    Actually, I got it. Somehow graphics acceleration option was unchecked. SW runs great now.
     
  13. nallen

    nallen

    Messages:
    1
    Cdavis_fx,
    Thanks for your comment on this. I just bought a MBA 13 i7 with the intel3000. I would like to run Solidworks with real view graphics. In your system where you unlocked openGL are you able to run real view graphics? (does it let you select the little gold real view graphics sphere or is it grayed out?) I am just wanting to run real view graphics on my MBA.

    Thanks,
     
  14. rudigar

    rudigar

    Messages:
    1
    Hi, I am trying to do the same for my 2007 2.8 Extreme iMac, running an ATI Radeon HD2600. What codes do I need to input for this card?

    Thanks
     
  15. AndyL12

    AndyL12

    Messages:
    1
    2011 MBP 15" - Same issue, no solution found

    I'm running a 2011 MBP 15", 2.2 i7, 8GB with Solidworks 2012. Tried the fixes above but did not work. Any ideas on how to fix the workround?
     
  16. MatteoR

    MatteoR

    Messages:
    1
    Hi to all,

    I've done the mods as you suggested but I only managed to disable "Software OpenGL": the RealView sphere's still greyed out. I'm running Solidworks 2011 Academic Edition on the new MB Air with Ivy Bridge.

    Furthermore, I noticed that the [\HKEY_CURRENT_USER\Software\SolidWorks\SolidWorks 2011\Performance\Graphics\Hardware\Intel] is not a simple key, but it contains others: the actual path is [\HKEY_CURRENT_USER\Software\SolidWorks\SolidWorks 2011\Performance\Graphics\Hardware\Intel\Intel(R) HD Graphics\V001_FG_X614109157_V815109157] and there's a DVALUE for each:

    Intel => HEX 10
    Intel (R) HD Graphics => HEX 10
    V001_FG_X614109157_V815109157 => HEX 4000480


    I added "Parallels and Intel Inc." key but it didn't solve anything.

    Can anybody help me?

    Thx
     
  17. robotnik101

    robotnik101

    Messages:
    2
    Hi all wondering if anyone can give some pointers,

    I'm using a Mac Pro with Radeon 6870 graphics and attempting to get solidworks 2012 working under parallels 7 win7.

    I've been playing around with the registry setting as mentioned above but to no avail.

    Just to make clear, when I alter the registry value do i need to reboot the win7 virtual machine for it to take effect. Or just restart solidworks.

    I have tried changing:
    [HKEY_CURRENT_USER\Software\SolidWorks\SolidWorks 2010\Performance\Graphics\Hardware\Parallels and ATI Technologies Inc.]
    "Workarounds"=dword:XXXXXXXX
    and
    [HKEY_CURRENT_USER\Software\SolidWorks\SolidWorks 2010\Performance\Graphics\Hardware\Parallels Inc. & ATI Technologies Inc.]
    "Workarounds"=dword:XXXXXXXX

    to the values in

    [HKEY_CURRENT_USER\Software\SolidWorks\SolidWorks 2010\Performance\Graphics\Hardware\ATI Technologies Inc.]
    "Workarounds"=dword:XXXXXXXX

    As well as the subsequent Radeon etc. values in the ATI Technologies tree, nothing appears to work.

    As this is running under parallels and win7 itself doesn't get to see my actual hardware (just generic VGA adapter), is there a different registry value that i should change it to?


    cheers
     
  18. robotnik101

    robotnik101

    Messages:
    2
    No bother i fixed it.

    In case anyone else comes up against this with the same card (radeon 6870 HD) i changed all 4 of the "parallels and" values (both ati and nvidia) to the value of the AMD (Advanced Micro Devices) workaround value "0x52400c84" in my case. All works ok now.

    cheers.
     
  19. pixbroker

    pixbroker Bit Poster

    Messages:
    13
    SW 2013, Parallels 8 on MBP 17" Mid 2011 with GeForce 330M

    I wanted to post what i had to do to get this working for my case.

    First, i have a MacBook Pro (17-inch, Mid 2010) with a NVIDIA GeForce GT 330M 512 MB. Im using Parallels 8 with Windows 7 and Solidworks 2013.

    After reading thru this thread here, i tried everything that was suggested but nothing worked to get RealView to work. Then after some googleling i found this:

    http://www.grzsoftware.com/blog/how-to/fixing-solidworks-opengl-on-parallels/

    and subsequently this:

    http://www.hao007.net/bbs/viewthread.php?action=printable&tid=23111

    Then i installed process monitor on windows 7 and setup a filter to look at registry access by solid works. There i found out that i need to:

    1. GL2Shaders entry for my graphics card

    Key Name: HKEY_CURRENT_USER\Software\SolidWorks\SolidWorks 2013\Performance\Graphics\Hardware\Gl2Shaders\Other\Parallels using NVIDIA GeForce GT 330M OpenGL Engine
    Name: Workarounds
    Type: REG_DWORD
    Data: 0x40000

    2. Set the Workaround as per other users reports

    Key Name: HKEY_CURRENT_USER\Software\SolidWorks\SolidWorks 2013\Performance\Graphics\Hardware\Parallels and NVIDIA Corporation
    Name: Workarounds
    Type: REG_DWORD
    Data: 0x4000480


    Then RealView started to work.

    I hope this will help someone else at some point.
     

    Attached Files:

  20. minicdds

    minicdds

    Messages:
    1
    SW2013, Paralells 8 on iMac Intel Core7i Navidia GeForce GTX 675MX

    Hello
    I am trying to run SW2013 with OpenGL on Paralells 8 on an iMac Intel Core7i with Navidia GeForce GTX 675MX
    I tried to change some HEX Keys like here explained but the Opengl box is still grey.

    Thanks a lot for any help!
     

Share This Page