Discussion in 'Other Virtual machines' started by schwartz, Mar 9, 2009.

  1. schwartz

    schwartz Member

    Does anyone have the latest Opensolaris running under parallels? I've tried calling the vm linux, windows, solaris. No luck so far. Looking to find out the settings I need to pick to make it work.

  2. Sean Kelly

    Sean Kelly Bit poster

    I've run into the same problem. No matter what I do, after leaving the GRUB menu I get a ton of panic messages and the install process halts. Also, the instructions I've found for installing OpenSolaris on Parallels are either too old to be relevant, or for some reason the writer didn't encounter this problem. I've tried installing 2008.11 on the latest version of parallels desktop (4.x) on both a Macbook Pro and a Mac workstation, both with the same results. I'd love to know how to get this working if anyone has pointers.
  3. Deboh Dee

    Deboh Dee Bit poster

    Try -kv

    I added -kv to the end of the GRUB kernel parameters. reboot your VM then hit E then E again. enter -kv then hit the "b".

    be patient and the install completes. At least I get to a command prompt, but some of the OS is missing. It all seems a bit hoakie, this being my first attempt installing OpenSolaris, maybe it's pilot error.

    good luck,

  4. Deboh Dee

    Deboh Dee Bit poster

    Bummerz. I switched the VM to utilize both CPU's on my macbook pro and now OpenSolaris Panics. Oh well.
  5. beta_vanjab

    beta_vanjab Bit poster

    Does setting RAM to 512M helps with installation? I managed to install it by limiting the ram to 512M.
    (integration and polish are another story)
  6. mgl

    mgl Bit poster

    Set RAM to 512K works for install

    Well, setting RAM to 512K does get me past panics when booting installer, and then I'm able to install. Installed crashes Parallels after booting from GRUB menu, though.

Share This Page