OpenSTEP 4.2 Doesn't Run with 4 - VT-x may be the Problem?

Discussion in 'Other Virtual machines' started by spetznatz, Dec 5, 2008.

  1. John@Parallels

    John@Parallels Forum Maven

    Please put files on some shared hosting
    Create ticket in support and specify access information there
  2. osjunkie

    osjunkie Bit poster

    I also have an OPENSTEP 4.2 install that worked fine under Parallels 3, but will not boot in Parallels 4.

    I've tried the various custom settings suggested. This get me past the line in the boot log "Power management is enabled.". Then the booting fails with:

    "Load of /etc/mach_init, errno 14, trying /etc/init
    Load of /etc/init failed, errno 14"

    Has anyone found a way around this? Thanks.
  3. dhut

    dhut Bit poster

    I have been playing with this for some time. Let me describe what I have learned, even though it does not actually provide any solutions.

    I have a PD3 installation that when converted to PD4 fails at exactly the same place as osjunkie's.

    I followed the instructions by John (above) to create an installation in PD4. It boots with vtx enabled. I installed the developer package and upgraded to patch 4. It still boots with vtx enabled. BUT. When I switch to the Vesa 2 video driver, it stops at the beginning of the boot process (at the power management part) unless I disable vtx. But then it proceeds to exactly the same failure at loading mach_init. It appears that the failure is related to switching video drivers since I can reliably switch/fail, switch-back/succeed. But we also have Peter's post above with screenshots with that driver running. So what is different? Do those that run not have the developer package installed? I have switched this installation from the IDE driver to the EIDE driver and back again with success, even though I could not install with the EIDE driver directly.

    So I now have an installation that works with vtx on and fails with vtx off, but with a little screen in black&white. If I try to switch to a reasonable display, it dies exactly like my converted from PD3 installation dies, i.e. early with vtx on and later with vtx off.

    Another curious observation: I tried installing from CD with vtx disabled. That failed with the attempt to load mach_init ... from the CD! And I'm pretty sure it isn't trying to use the Vesa video driver. I also tried using the EIDE ATAPI driver for installing and that also fails.

    As an final note, I also observe that PD4 installations seem to run at less than half the speed of PD3 installations. It may be faster with vtx disabled but I haven't gotten far enough with that to say for sure. One would think that things would run faster, not slower, with vtx enabled.

    Any other information would be appreciated. I'd particularly like to know about video driver success with/without the developer package installed.

    - David
  4. salvomic

    salvomic Hunter

    in this manner I get always the "mode 357" error and then Openstep hangs. I imported a configuration working in Parallels 3.x, that now doesn't work.

    please, help
  5. salvomic

    salvomic Hunter

    Also with hvtsupport=0,acpi=0,apm.enable=0 I've still the "mode 357" error, and Openstep hangs. Please, help.
    I imported it from Parallels 3.x

  6. tmhackalot

    tmhackalot Bit poster

    Did anyone ever resolve this issue. I have the same problem with Parallels 4 build 3844. I can get my OpenStep 4.2 guest OS (built under P3) to run only if I disable the VESA Video driver, and also disable Vt-x. It is unusable in 640 * 480 so I too am stuck. I tried changing video memory size and selected resolutions, but nothing I have tried works. I would really hate to downgrade to P3.

    It locks at the pnp check. If I turn off pnp under OpenStep it gets past that, then locks at the IDE check.

    CPU 1 processor
    CPU flags: hvtsupport=0,acpi=0,apm.enable=0,kernel.real_mode_vtx=0
    Memory 256MB
    Video: 16MB
    CD Disabled
    Bridged Ethernet

    Video: VESA VBE 2.0 Display Driver (1024*768 RGB 256/8)
    Network: NE2000 Compatible PCI Ethernet Adaptor (0.91b)
    ISA/EISA Bus Support
    PCI Bus Support
    PCMCIA Bus Support
    PS/2 keyboard
    Floppy disk driver
    EIDE and ATAPI Device Controller
    Plug and Play Support Enabled
  7. Markus Wenzel

    Markus Wenzel Bit poster

    Sorry, I gave up

    Hi tmhackalot,

    I gave up on this because Parallels support members could show me my image running on their machine, however, it still failed on mine. I never figured out why and I gonna stick to P3 if I need my Openstep stuff.
  8. Markus Wenzel

    Markus Wenzel Bit poster

    Solved with 5.0 beta


    the Openstep problem does no longer occur with 5.0 beta. Hooray!

  9. CH-Fels

    CH-Fels Bit poster

    5.0 definitely not a panacea

    In light of Markus' last post here, I installed 5.0 beta and started from scratch. Now I can't get past the "power management enabled" stage of the initial boot-to-install, with any combination of drivers and CPU flags (I've tried about 11 different combos, including ones that I *know* worked to get farther than this under PD 4.0!)

    Has anybody successfully installed Openstep 4.2 from scratch under 5.0 beta? If so, what combination of settings and drivers worked??

    Should I think about downgrading to 3?

  10. spetznatz

    spetznatz Hunter

    Just installed 5.0. OpenSTEP 4.2 VM gets further, but stops at 'Preposterous time in real-time clock.' So no improvement really.

    Also 5 has BSOD'ed my XP installation and removed a working (but slow) 4.0 installation.

Share This Page