OS/2 Warp 4 Install Troubles

Discussion in 'Other Guest OS Types Discussion' started by mdlueck, Sep 29, 2008.

  1. mdlueck

    mdlueck Member

    I am having great success with both eCS 1.2R and also Warp 4.52, so I think it odd that Warp 4 is giving me a fight.

    My host OS is Ubuntu 8.04. I have been using the 2232 build.
    The specs can be found here:

    I found mention of a 2234 build, so I found a link to download that version and tried it as well. (Purged the old package, installed the new one, and tested booting my previously created VM.) Same crash, so here are the details when running 2234:

    1) Transfered the DSK files for the boot process to the Linux filesystem, renamed them from .DSK to .FDD, and they work beautifully as Parallels FDD images!
    2) I updated the IBM1S506.ADD and IBMIDECD.FLT to the version that eCS 1.2R installed, removed un-needed drivers from CONFIG.SYS, Added COPYFROMFLOPPY=1, and commented out the extra snoopers in the SNOOP.LST file. (I booted an eCS 1.2R VM session, mounted the FDD image, and found that I can make changes to the FDD images that are saved to the FDD file!)
    3) I created an ISO of the Warp 4 CD with the CD unmounted, dd if=/dev/scd1 of=Warp4.ISO bs=2048
    4) I make it through the text part of the install, reboot, and then when booting from the HDD it gets the attached trap 000d screen.

    I have attached our customized disk1_cd.fdd and also a screen shot of the trap 000d screen.

    Like I said, eCS 1.2R and Warp 4.52 are rock solid stable, so I find the fight that Warp 4 has put up most odd indeed.

    Suggestions? TIA!

    Attached Files:

  2. mdlueck

    mdlueck Member

  3. mdlueck

    mdlueck Member

    I discovered a method which does work to get Warp 4 GA to install:

    1) Do not modify the DSK images, just rename to FDD
    2) Create a 4GB virtual HDD

    The above succeeds at installing OS/2 Warp 4 GA.

    I am working through applying the updates to this image. My thought is to test updating the IDE drivers after the latest fix packs have been applied and see if it will behave normally. Then I might be able to back up the OS/2 image and transfer to a 30GB virtual HDD.
  4. mdlueck

    mdlueck Member

    The workaround indeed proved successful to get Warp 4 GA to install.

    Next I tried applying FP14. After the required reboots, the WPS is acting very strangely.

    Attached is a screen capture of trying to right-click the desktop and choose Shut Down. Once the right-click menu appears, the WPS becomes unresponsive. A few seconds after clicks, then the PC speaker makes a beep. The right-click menu never goes away, the "box" around the WPS as well. I have to use C-A-D to reboot the system.

    http://www.lueckdatasystems.com/pub...ion - Warp4-FP14-RightClickDesktopProblem.png

    Once I exit Parallels, the Linux desktop in general is behaving oddly.

    If I push the Alt, Ctrl, or Shift key then the Gnome desktop flashes all icons and windows away, then they reappear.

    In bash prompts I can no longer type CAP letters, and Caps Lock no longer works either.

    I must reboot Linux at this point.

    All of this seems related to installing FP14 on Warp 4 GA.

    I have made sure that all partitions have been formatted HPFS.

    I re-installed Warp 4 GA and left out the Multimedia as we do not need that.

    Suggestions? Anyone having success with Warp 4 and FP14?


Share This Page