P Tools crash, shutdown problem etc.

Discussion in 'Windows Guest OS Discussion' started by joge, Jan 21, 2008.

  1. HinckleyScott


    No Adobe software running when I hit the problem, so maybe a different issue
  2. bigmaninchina


    Parallels Support:

    I have been following this thread for the last couple months hoping that there is a resolution to this issue. This has become a huge problem for me as I work between Windows XP and Leopard full time and the silent crash of Parallels Tools is a great burden.

    - Parallels 3.0 (5584)
    - Leopard (10.5.2)
    - Mac Book Pro 15"
    - 3GB of RAM
    - Guest OS (Windows XP SP2)

    The symptoms are the same as previous posters. Parallels tools silently crashes and when I go to check it in the Sys-tray the icon disappears. After this crash I will lose the ability to use drag & drop, copy & paste, and SmartSelect from either Leapord or the Guest OS. I cannot kill the ParallelsTools.exe process from the TaskManager, and only a restart of the Guest OS will restore full functionality. At times after a Parallels Tools crash the Guest OS will hang on shutdown which will then require me to "reset" the Guest OS in order to get back to work. This happens at very least once a day. I've tried a full uninstall of Parallels as well as the Parallels Tools to no avail.

    Another interesting fact is that while using Parallels 2.5 with Tiger I experienced the same issues except under Parallels 2.5 I WAS able to kill the ParallelsTools.exe process and restart the Tools which allowed me to continue working

    Please help as this issues is driving me crazy.
  3. Olmy


    I have the same problem as other posters. It is very annoying. I cannot kill "parallelstoolscenter.exe" process even it has dissapeared from the tray. Crashes could be somehow related to suspend action, because I usually notice this problem after I wake up windows from the suspend-state.

    Does tools center maintain somekind of crash log?
  4. mateopucu


    Same issues here

    FYI Parallels, I have the same problems with Parallels tools and shutdown.
  5. joge


    Dear Parallels support team,

    more than 4 (!) months have passed since I first reported this issue. In this time several people (in this thread and in other threads) have reported the same problems. All of them with different system configurations and all of them with different situations in which the tools crash. So I think it's no longer acceptable that you blame it on third-party software developers (Adobe in my case), as long as you don't want to state "no guarantee of any third-party software integration" as a feature of Parallels Desktop. This problem has to be solved - ASAP. I paid for this software, as many others may have, and I expect it to run properly, with all the features you sell it with.

    I expect a statement from someone official on the solution to this issues.

  6. Ladelle


    One thing I have discovered is that if you use Apple/Adobe/Microsoft on the Mac side then you may need to check for updates using other Mac accounts. I had an Adobe update that did not want to install till I used a different user account. I had a MS Office 2004 update that did not present itself till I logged in as a differnt user, even though other machines had it.

    What I would do is;
    1 - Uninstall Parallels. They have a list of files to check are also removed.
    2 - Restart with safe boot. Check the Parallels files are gone. (Not you VM).
    3 - Restart normally and login as a user with administrative rights.
    4 - Run Software Update and install. May need a number of restarts and reruns till you are told no more updates.
    5 - Run Adobe updater and install updates.
    6 - If you have MS Office for Mac 2004 (or their new one) run MS Autoupdater.
    7 - Restart.
    8 - If you have more than one account with administrative rights, login with a different account and try steps 4 to 7 using that account.
    9 - Install Parallels using latest.
    10 - Start Parallels and login to XP with Administrator (Just to make sure the ParallelTools install OK). Restart XP when asked to.
    11 - Shutdown XP and close Parallels.

    I would say that this should point the finger somewhere if it works, or where you may look if it doesn't.
    If you had Apple updates for Quicktime, Safari or iTunes, then Parallels has a problem with one of the Kernel drivers installed in an earlier Quicktime/Safari/iTunes update.
    If you get an MS Office update, especially with using a second mac user to check, then the MS audaemon does something that Parallels does not like and is a MS sourced problem.
    If you get an Adobe update, it may fix a memory allocation issue that could cause interferance with Parallels.

    I had an issues that needed multiple accounts and softwrae installs to rectify. "Parallels crash causes 20 min boot"http://forums.parallels.com/showthread.php?t=20503

    Good luck
  7. misterjangles


    I would just like to bump this issue up - I have the same thing and I am running MacBook Pro OSX 10.5.3 with Vista as the Guest. However, I do not have any Adobe products installed - this is a fairly fresh install of both operating systems.

    I have not figured out any reliable way to reproduce this, however it *may* be happening when I switch in and out of coherence mode, or it may also have something to do with me shutting my laptop lid and OSX going to sleep. I am not positive about either of these, unfortunately.

    Basically I can go for some random length of time until parallels tools crashes and then copy/paste no longer work. The ParallelsTools.exe process becomes a zombie and is impossible to kill and also impossible to restart. Additionally it causes Windows to not shut down properly - it hangs and you have to shut it off.
  8. John@Parallels


    Can you try to disable power management in Vista and in XP (who uses ) and check
  9. Olmy


    Thank you John. Do you mean by "Power Management" the APM "Advanced Power Management" option in power options (XP)? It was OFF for me.

    I had "turn off monitor" option set to "20 min" in "Power schemes", but I now it is set to NEVER. Was these the power managament options that you ment?
  10. John@Parallels


    Yes, also Turn off Hard disk to never,
    Uncheck Hibernate
  11. Olmy


    Same problem occurss with disabled power management in XP. Any other ideas?
  12. rcherny


    So have there been any realizations here? I am using build 5608 and parallels tools continues to crash for me. same description as above. usually when i try to copy/paste something from Leopard. The tools disappears from the systray and then nothing's working correctly. this is a major inconvenience.

Share This Page