Paralells Tools on newest kali kernel 5.16.0-kali1.arm64

Discussion in 'Installation and Configuration of Parallels Desktop' started by SB_2, Feb 23, 2022.

  1. SB_2

    SB_2 Bit poster

    I bought Parallels 16 a few months ago. Yesterday I updated the Kali Linux VM on my MacBook Pro M1 2021 after a long time. Then I wanted to install Parallels Tools but an error message came up. Parallels Tools expects a kernel header with version 5.10.0-kali3. However, the latest version of Kali has kernel 5.16.0-kali1-arm64. Unfortunately, the installation of Parallels Tools doesn't work at all and just refers to the log file every time. I've spent several hours on it now, but found no working solution. For example, I tried to install the old 5.10 header afterwards, but it didn't work. I would be very happy for any help.
  2. Reda2

    Reda2 Bit poster

    I ran in to that same issue after initial installation of Kali 2022.1 arm (MBP M1) on Parallels 16. All though I was able to get passed the headers error by following these instructions (method 1 worked for me): Thereafter I got the problem of a unsupported version of an unsupported Xorg version.

    > sudo cp -r /media/cdrom0/* /tmp/parallel_tools
    > cd /tmp/parallel_tools/installer
    > sudo ./ -i --verbose
    Started installation of Parallels Guest Tools version ''

    Error: Xorg version 1.21 not supported​

Share This Page