Parallel Tools not installing in High Sierra Guest

Discussion in 'Mac OS X Guest OS Discussion' started by jred55, Jan 14, 2018.

  1. jred55

    jred55 Bit Poster

    Messages:
    11
    Hi, I've been trying to install parallel tools into my high sierra vm unsuccessfully. I created the vm from new rather than a sierra upgrade. The tools installation completes successfully but upon reboot I'm still getting the yellow triangle to install the tools. I've tried installing a number of times but still getting the same result. My high sierra host is 10.13.2 and the guest is the same. Any help/advice or tips? Thanks, Julian
     

    Attached Files:

  2. Shathish@Parallels

    Shathish@Parallels Kilo Poster

    Messages:
    344
  3. jred55

    jred55 Bit Poster

    Messages:
    11
    Hi, thanks for this. I checked out the guide and the instructions aren't relevant to my situation. When I start up the parallels tools are already mounted (as per the screenshot attached). Thus point 3 onwards of the guide can't be followed as they aren't an option! My situation is more in line with the next page - 'Updating Parallel Tools'. However, again, point 5 onwards of these instructions aren't relevant as double-clicking the install icon just proceeds to install the tools. I get the complete and reboot message but upon doing so, just takes me back to the tools not be installed.
    Any other ideas?
    Thanks, Julian
     

    Attached Files:

  4. jred55

    jred55 Bit Poster

    Messages:
    11
    Hi Parallels Support, any other advice or guidance? Thanks.
     
  5. JeroldA

    JeroldA Bit Poster

    Messages:
    14
    Here is the error message, in /var/log/system.log (from guest):

    Jan 22 11:40:08 macoshighvm prl_fsd[491]: cannot open TG
    Jan 22 11:40:08 macoshighvm com.apple.xpc.launchd[1] (com.parallels.vm.prl_fsd[491]): Service exited with abnormal code: 255
    Jan 22 11:40:08 macoshighvm com.apple.xpc.launchd[1] (com.parallels.vm.prl_fsd): Service only ran for 0 seconds. Pushing respawn out by 10 seconds.
     
  6. JeroldA

    JeroldA Bit Poster

    Messages:
    14
    I also tried to execute the LaunchDaemon manually, without any success (all as root, of course):
    • /Library/LaunchDaemon/com.parallels.vm.prl_fsd
    I also tried to execute the program that the Launch Daemon executes, without any success.

    I could find no '-debug' or '-v' switches to the prl_fsd command.
     
  7. jred55

    jred55 Bit Poster

    Messages:
    11
  8. JeroldA

    JeroldA Bit Poster

    Messages:
    14
  9. JeroldA

    JeroldA Bit Poster

    Messages:
    14
    I filed the following issue to track this, I will report on results:

    Parallels / #2481653: Parallels tools cannot be installed on High Sierra Guest OS
     
  10. jred55

    jred55 Bit Poster

    Messages:
    11
    Thanks.
     
  11. JeroldA

    JeroldA Bit Poster

    Messages:
    14
  12. jred55

    jred55 Bit Poster

    Messages:
    11
    Ok, thanks. I get no such message so my issue must be different. Going to try to create a new high sierra vm and see what happens.
     
  13. jred55

    jred55 Bit Poster

    Messages:
    11
    Having built a new vm, parallels tools seems to have installed ok. I did get the 'system extension blocked' message and followed the guide to fix. So, seems to be all ok now. Thanks.
     

Share This Page