Paralleld Desktop Update RC - Mac Pro, Leopard, and Vista compatible!

Discussion in 'Announcements' started by Ben @ Parallels, Sep 7, 2006.

  1. Ben @ Parallels

    Ben @ Parallels

    Messages:
    56
    The Update Release Candidate for Parallels Destkop for Mac is here, and its loaded with great new features!

    The big three are:
    - Support for Mac Pro towers with up to 4GB of RAM
    - Compatibility with developer builds of OS X "Leopard"
    - Experimental guest OS support for Windows Vista Beta

    For a full run-down of new features, functions and improvements, check out the Parallels Update RC main page.

    Upgrade your copy of Parallels Desktop for Mac, or start using it for the first time, by visiting our download center.

    NOTES ON INSTALLING THE UPDATE RC:
    • If you’re new to Parallels Desktop for Mac: you can start using improved Parallels Desktop for Mac by downloading and installing the RC on a «clean» machine.
    • If you already have Parallels Desktop for Mac: Updating your build is easy. Just download the Update RC file and install it over your existing version.
      • You will NOT need to reinstall any guest OS or any applications when you update your Parallels Desktop for Mac.
      • Don't forget to update Parallels Tools after installing Update RC!
     
  2. prock

    prock

    Messages:
    23
    Parallels support for Merom-based iMacs with Core 2 Duo

    Ben-

    Can you please clarify? Does this new release work with the iMacs just released (Merom-based iMacs with Core 2 Duo)?

    Thanks
     
  3. tecwerks

    tecwerks

    Messages:
    10
    No Cigar

    I have a Mac Pro 2 x 3ghz Xeon core duo w 4gb of Ram and have encountered problem after problem. Latest one is a show stopper. I start installing a new VM WIndows XP. Part way into the install procedure I get the dreaded dimming screen on my system and need to hold my power button in to force a reboot. I even followed the procedure to set the Max RAM size to 3GB upos startup of the system. I also completely uninstalled Parallels with the utility and made sure all preferences and references were deleted.
     
  4. noel

    noel

    Messages:
    3
    Me too.

    Me too. I've got 5 gigs actually and went through setting the boot-args like it told me too. Still crashes occasionally and the like... Too bad I paid for it based on the reviews of others (yes, it was compulsive of me.)
     
  5. FikseGTS

    FikseGTS

    Messages:
    16
    same here, constant kernel panics, can't get winxp to boot..... Mac Pro Quad 3.0GHz with 3GB RAM......
     
  6. NutKracker

    NutKracker

    Messages:
    17
    Mac Pro Quad 2.66GHz with 1GB ram runs OK following RC upgrade - WinXP installed fine.
    Just need more physical memory installed now to give it some room to breath! :)
     
  7. TopShelf

    TopShelf

    Messages:
    5
    I'm up and running on a similar config, NutKracker.

    Thanks, parallels guys, for getting this running.

    NutKracker, I'm interested to hear how your web browsing works in your XP VM. I have spotty internet access through Internet Explorer and Firefox.

    Virtually all Google sites (e.g. News, Mac Google, Maps, etc) will load and load quickly. Almost no other web site will.

    My internet access through OSX on Safari and Camino works perfectly. All other internet connected apps in OSX are also working properly.

    I'm speculating that there is something wrong with the network driver for Parallels.

    How's internet stuff working for you?
     
  8. Roaster

    Roaster

    Messages:
    74
    Perfect!

    May I ask when this support is available for the Windows version of Parallels Workstation?

    BTW
    Did you mean Parallel Desktop in the subject :)
     
  9. mqandil

    mqandil

    Messages:
    23
    Hi Ben
    Please make available the previous version. We have lost access to shared folders with this version. We need to go back to the previous one unless there is a quick fix to this problem. Please advise.
    Mark Qandil
    mqandil@centexfp.com
     
  10. pderby

    pderby

    Messages:
    37
    I just upgraded and Windows shared folders are working fine for me. So whatever the problem is for those that lost shared folders isn't something that happened to everyone...which doesn't make it any less frustrating for those that did lose their shared folder access.

    Just putting this out for information.

    I'm on a MacBook Pro, OS X 10.4.7
     
  11. NutKracker

    NutKracker

    Messages:
    17

    To be honest, only installed it very late last night - the few websites that I visited worked fine - no problems. Will check it out further over the weekend.
     
  12. mvk

    mvk

    Messages:
    28
    Mac Pro

    Although I can get bridged networking to work on a Mac Pro (after the usual limting the RAM to 2000 from the actual 6 GB, etc), I found that depsite toggling the MTU, I had the best performance when the MAC ID used by Paralles matched the real MAC ID of the Mac Pro - which means that the Mac Pro canot access the internet from a browser at the same time due to the conflict. BUT - the Mac Pro has TWO ethernet ports. In the Mac System Config, I made sure that the normal ethernet ports is listed first (by dragging). I attached a new ethernet cable to the otherwise unused port and attached it the my router. I then duplicated the settings and configured Parallels to use this ehternet port, rather than the original one. Still need to toggle the MTU, etc., but now no conflict. Was able to go to several otherwise unavailable webs ites using complex ActiveX, JAVA and secure tunnels without a problem - at least for a while.

    I am not sure if this is all really necessary. Any suggestions?

    By the way, GoToMyPC remote software within Parallels works from an offsite PC and lets you control the Parallels VM, but it actually crashes the Mac system when you log off GotToMyPC!

    Major bugs:

    1. Memory limitation unaccepatble - spent too much on 6 GB of RAM to turn if off. Will use Bootcamp if I have to reboot.

    2. Toggling MTU is an old problem with Parallels predating the Mac Pro. Again, too many hoops to make this all worthwhile.

    3. VTx issues persist. Less frequent when I turn off sleep for the Mac. But I still occassionaly get. One more performance hit.
     
  13. gordyf

    gordyf

    Messages:
    2
    Vista STOP error

    Trying to install Vista RC1 on a 1.8ghz MacBook Pro with 1.5gb RAM. The installer does the progress bar across the screen, and then:

    *** STOP: 0x000000A5 (0x0001000B, 0x50443146, 0xFFD01050, 0x00000000)

    I tried disabling every unnecesary resource, reduced/disabled acceleration, toggled VT-x support, and nothing changed.

    I realize this is experimental and Vista's not even out yet, but maybe my data point can be useful to the Parallels team...
     
  14. pjmann

    pjmann

    Messages:
    8
    Parallels still not working after updating

    I have a standard Mac Pro (1 GB ram (2*512), 250 GB HDD).

    I have installed parallels (from the install disc), upgraded it with Parallels-Desktop-1884-Mac.dmg, rebooted, and still get the "Unable to communicate with hypervisor!" error.

    I have put the Mac Pro to sleep...same error, rebooted...same error.
    Re-installed the original version, upgraded again, rebooted...and still the hypervisor error.

    Then I completely uninstalled this mess (including deleting all the VM files from the Library), and repeated the rebooting process...same error. What is going on? Can someone please give me a step-by-step proceedure to get this working....could I have a MacLemon ??? :confused:

    Thank you in advance. :D
     
  15. Luke

    Luke

    Messages:
    1
    Vista Stop Error

    Same error as GordyF. STOP: 0x000000A5 on MACBOOK Pro 1GB RAM w/ Vista RC1
     
  16. xylone

    xylone

    Messages:
    2
    Same problem here! Google is available, but forum.parallels.com is not. Almost no site is available. But some are.... Even tried to bridge the network card and setting the MTU the same as in OSX...

    System: MacPro 2.66 2GB
    Installed OS: WindowsXP MCE
     
  17. jonsimmons

    jonsimmons

    Messages:
    2
    Vista Success!

    I think we're all trying to be too cutting edge here.

    I have just got Vista Beta 2 working in Parallels, after getting the errors with RC1. It's not ideal, but it's Vista on my Macbook, and that's got to be kinda cool...

    [Edit]
    To satisfy the techie side of things, and to give my feedback (so people can help me get more working!), here's how the first 30 minutes have gone:

    Start up time is alright - about 40 to 50 seconds.
    Graphics are basic with a capital B! No Aero (due to default VGA drivers), no Windows Media, no Media Center, and very stilted audio playback.
    The only Parallels tools that seem to install are the Clipboard and Time Sync tools. No enhanced video, no network drivers, and no mouse sync (which is the most annoying).
    No internet access, since bridged networking isn't working.

    Other than that, it runs well (as well it bloody should with a gig of RAM dedicated to it!), and like I said, a virtual VistaBook has to give me huge kudos :)
     
    Last edited: Sep 9, 2006
  18. y3k

    y3k

    Messages:
    14
    To get some better result, follow the steps as described here:

    http://forum.parallels.com/post20588-28.html

    This would let you install parallels tools and the only 2 things missing would be FX and PCI bridge. Network, Internet, seemless mouse etc - everything works.
     
  19. Cameron Champion

    Cameron Champion

    Messages:
    2
    Still having kernel panics from the new RC. Please help!

    Everytime Windows boots I get a kernel panic. Upon restarting the following error is presented by os x:


    panic(cpu 2 caller 0x003A2287): getPhysicalSegment() out of 32b range
    0x100000000, len 0xa4000, class IOGeneralMemoryDescriptor
    Backtrace, Format - Frame : Return Address (4 potential args on stack)
    0x37223938 : 0x128cdb (0x3c99c4 0x3722395c 0x131cdf 0x0)
    0x37223978 : 0x3a2287 (0x3edad8 0x0 0x1 0xa4000)
    0x37223a48 : 0x3a41e5 (0x6578600 0x25c000 0x0 0x57e6ea0)
    0x37223a68 : 0xc7e67f (0x5cadd00 0x25c000 0x0 0x5cadd00)
    0x37223aa8 : 0xc7e0db (0x5cadd40 0x400000 0x5cadd40 0x6d616769)
    0x37223ae8 : 0xc7fd72 (0x52052000 0x400 0x0 0x683fd5)
    0x37223b38 : 0xc7f0a7 (0x583e404 0x18 0x400000 0x199103)
    0x37223bf8 : 0xc7f383 (0x583e404 0x37223ec8 0x18 0x6221e10)
    0x37223d58 : 0xc7d5c5 (0x583e404 0xc0185401 0x37223ec8 0x10)
    0x37223d78 : 0x1f00f7 (0xb000000 0xc0185401 0x37223ec8 0x81)
    0x37223db8 : 0x1e7045 (0x37223de0 0x297 0x37223e18 0x1d09ee)
    0x37223e18 : 0x1deee9 (0x644ed68 0xc0185401 0x37223ec8 0x81)
    0x37223e68 : 0x3305b4 (0x62ecf70 0xc0185401 0x37223ec8 0x5de0000)
    0x37223e98 : 0x34e881 (0x62ecf70 0xc0185401 0x37223ec8 0x5de0000)
    0x37223f68 : 0x378f9c (0x5de0000 0x6221e10 0x6221e54 0x0)
    0x37223fc8 : 0x19b0ee (0x6133620 0x0 0x19e0b5 0x6133620) Backtrace
    continues...
    Kernel loadable modules in backtrace (with dependencies):
    com.parallels.kext.vmmain(2.2)@0xc7c000

    Kernel version:
    Darwin Kernel Version 8.7.2: Tue Jul 25 23:09:54 PDT 2006;
    root:xnu-792.10.96.obj~3/RELEASE_I386

    Model: MacPro1,1, BootROM MP11.005C.B00, 4 processors, Dual-Core Intel Xeon,
    2.66 GHz, 3 GB
    Graphics: NVIDIA GeForce 7300 GT, NVIDIA GeForce 7300 GT, PCIe, 256 MB
    Memory Module: DIMM Riser A/DIMM 1, 512 MB, DDR2 FB-DIMM, 667 MHz
    Memory Module: DIMM Riser A/DIMM 2, 512 MB, DDR2 FB-DIMM, 667 MHz
    Memory Module: DIMM Riser B/DIMM 1, 1 GB, DDR2 FB-DIMM, 667 MHz
    Memory Module: DIMM Riser B/DIMM 2, 1 GB, DDR2 FB-DIMM, 667 MHz
    Bluetooth: Version 1.7.9f10, 2 service, 1 devices, 1 incoming serial ports
    Network Service: Built-in Ethernet 2, Ethernet, en1
    PCI Card: NVIDIA GeForce 7300 GT, Display, Slot-1
    Serial ATA Device: ST3250824AS P, 232.89 GB
    Serial ATA Device: Maxtor 6Y250M0, 233.76 GB
    Parallel ATA Device: SONY DVD RW DW-D150A, 5.73 MB
    USB Device: Hub, Up to 480 Mb/sec, 500 mA
    USB Device: Microsoft Wireless Optical Mouse® 1.00, Microsoft, Up to 1.5
    Mb/sec, 500 mA
    USB Device: Apple Cinema HD Display, Apple Computer, Inc., Up to 12 Mb/sec,
    500 mA
    USB Device: Hub, Up to 480 Mb/sec, 500 mA
    USB Device: Bluetooth HCI, Up to 12 Mb/sec, 500 mA
    USB Device: Apple Cinema HD Display, Apple Computer, Inc., Up to 12 Mb/sec,
    500 mA
    USB Device: Generic RNDIS, HP, Up to 12 Mb/sec, 500 mA
    FireWire Device: built-in_hub, unknown_value, Unknown
    FireWire Device: unknown_device, unknown_value, Unknown



    Does anyone have any suggestions on how to fix this!?

    Thanks in advance!

    -=-=-=-=-=-=-=-=-
    Cameron
     
  20. Matt Stevens

    Matt Stevens

    Messages:
    7
    Had this same problem, toggling the MTU setting between Jumbo and Standard as described in this post fixes it for me every time. Note that the guest OS needs to be running while you reset the MTU setting for it to take effect.
     

Share This Page