Parallels 10 running slow on Yosemite

Discussion in 'Installation and Configuration' started by Housedoctor, Oct 17, 2014.

  1. Ensoniq

    Ensoniq Bit Poster

    Messages:
    21
    Can someone explain:
    1 - What exactly does this command do, and why does it help?
    2 - What command will UNDO this when/if Parallels provides a fix?

    I am NOT suffering from the interrupt storm issue, NOR does moving my mouse around speed up my virtual machine.
    But I DO, however, have a mid-2011 iMac 21.5" that is slugging with Yosemite in general, and worse with Parallels.

    Thanks!

    -- Matt Ryan
     
  2. hackmodford

    hackmodford Bit Poster

    Messages:
    10
    Since the text you posted doesn't have "boot-args" in it I'm assuming you'll be fine ;)
     
  3. Music_Director

    Music_Director Bit Poster

    Messages:
    3
    I purchased Parallels 10 and the performance was slow. Then I upgraded to Yosemite and now it's molasses slow. My VM is Windows 8, my iMac is a mid 2011. I tried sudo nvram boot-args="debug=0xd4e" and it had no effect. Please help!
     
  4. hackmodford

    hackmodford Bit Poster

    Messages:
    10
    Did you reboot? if you run "nvram -p" do you see the boot argument you added?
     
  5. Music_Director

    Music_Director Bit Poster

    Messages:
    3
    I guess third time is a charm. Thanks
     
  6. Music_Director

    Music_Director Bit Poster

    Messages:
    3
    Ok it's back to it's old ways after a couple days. I checked nvram and it still is set at 0xd4e. What's the next fix I can try?
    Thanks
     
  7. Stephen Van Dellen

    Stephen Van Dellen Bit Poster

    Messages:
    27
    The slowdown seems to be intermittent so it's hard to tell whether the suggested fixed actually worked. I have two iMacs. I upgraded both to Parallels 10 right after I upgraded them to Yosemite. Windows on the first came up and ran with no problem. On the second, it took minutes just to start Windows and tens of seconds to start Windows programs. So I uninstalled/reinstalled Parallels. Seemed to fix that machine but then a week or two later, the first machine bogged down. I found the nvram patch here and installed it on both machines. All was well for a week or so but after I woke the first machine up this morning, the Windows programs I left running last night were so bogged down, I thought the whole Windows side of the machine was locked up. The Windows programs did eventually close, then Windows, then Parallels. So I just restarted Quicken. It took tens of seconds for Windows to boot and Excel still isn't up. Guess I'll try to back up to Parallels 9 and watch Parallels' web site for awhile to see if they admit there's a problem and fix it. If not, guess I'll have to find another solution. Too bad. I've been using Parallels for several year and have liked it a lot.
     
  8. Steve_Hess

    Steve_Hess Bit Poster

    Messages:
    1
    I am having the same issue inside my Windows 8.1 VM. I tried both entries for the NVRAM (sudo nvram boot-args="debug=0xd4e" and sudo nvram boot-args="debug=0x10") and it initially seemed to boot up faster but I come in this morning and it is sluggish as ever. When I look at the CPU usage on the mac activity monitor, it shows Windows 8 using anywhere from 115% to 125% of the CPU even though I am not doing anything on it, just booted and sitting there. I have 12gb of memory in the Mac and it nothing running on the Mac except Parallels and it shows that 11.98gb are used. 781.2mb are used by kernal_task, 273 by Windows 8, and 172.1 by Parallels Desktop.

    Any other suggestions to try?
     
  9. Matt_Wallace

    Matt_Wallace Bit Poster

    Messages:
    1
    Same issue here with 8.1 and Yosemite. The Terminal command fix worked for a couple days, but today Windows was back to being unusable. Reapplied the Terminal command and it worked, but we need a permanent fix versus having to run terminal commands every couple days.
     
  10. Mohamed_El-samman

    Mohamed_El-samman Bit Poster

    Messages:
    1
    sudo nvram boot-args="debug=0xd4e" This solved the issue for me. iMac mid 2011 21"
    I had a very slow response in parallels and now its very fast and the VMs load fast. thank you really appreciate your help.
     
  11. Manoj@Parallels

    Manoj@Parallels Parallels Support Parallels Support

    Messages:
    491
    Hello Mohamed_El-samman,
    Glad that your issue is fixed now! Feel free to reach us, if you need any further help with Parallels. We're happy to help you.
     
  12. scott_curfman

    scott_curfman Bit Poster

    Messages:
    1
    Has Parallels released a notice to people who have upgraded to version 10? It would have been a BIG help if they had. When I initially upgraded things worked okay for a while, then got really slow. Foolish me did not come here first. Instead I reloaded software, restored from backups.

    When they KNOW so many people are having problems, wouldn't it just be good customer service to let people know that the product is not fully compatible, and then provide the fix? Best case scenario would be to tell people this upfront and let buyers decide if they want to buy an unstable version, or wait until something stable is released.

    I am an old MS DOS person who grew tired of Windows but knew the operating systems well. I have a lot to learn about Apple OS, but the whole reason I switched over was because things were supposed to be less complicated and more stable on a Mac.

    Is Parallels a subsidiary of Microsoft? This last release is frighteningly similar to Microsoft's practice of having their paying customers unknowingly serve as Beta testers.
     
  13. FredUntu

    FredUntu Bit Poster

    Messages:
    26
    Hi everybody,

    Cool, so the trick posted here works. Well, from what I can read almost all over the Parallels website, they claim it's fully compatible with MacOSX 10.10 don't they ?
    So it HAS TO BE. And without tricks implying you tweak something using CLI in Terminal.
    Their claim is simply DECEPTIVE and can be considered as a fraud.
    I will send them a mail asking for a refund... I don't see the point in paying for software that does not worked as advertised.
    Besides : since that did not work, I decided to see what I had as an alternative solution. Guess what ? There is an alternative. Works like a charm on both Mavericks and Yosemite. Has all the major features of Parallels. You can install Windows, Linux or Mac as a guest OS. Oh... and one more thing : it's totally free. It's called Virtual Box and you can find it on Oracle's website.
    Try it... I think you can even import you PD8 or PD9 or PD10 images into it.

    Why do we have to pay for crappy software when we can have better one free of charge ? I wonder...
     
  14. proud_smile

    proud_smile Bit Poster

    Messages:
    1
    Hi there, I used that command sudo nvram boot-args="debug=0xd4e" and it worked great to speed up Parallels but now I'm having problems with the whole screen crashing and freezing, is anyone having the same problem? is there anything I can do for that?
     
  15. AshotP

    AshotP Bit Poster

    Messages:
    12
    sudo nvram boot-args="debug=0xd4e fixed the problem BUT today I had update and my iMac 2011 is dead at the boot, only full reinstall fix my mac but issue again with CPU load.
     
  16. Michael Aronis

    Michael Aronis Bit Poster

    Messages:
    11
    I just got my mac back from a repair (10 days before the warrantee ended LOL). I had updated to Yosemite a few weeks before it died, no causal relationship I am sure, but I did notice that my guest OS was running very slow....The fix worked great for me.

    And I learned the command to force my other mac to use the external superdrive as my internal CD died on my Mac Mini....LOL...kill two birds with one search.

    Have a great day.

    (PS, all you mac users with two or three year old iMac's DO NOT GO TO THE MAC STORE....DO NOT LOOK AT THE iMAC 27 with Retina Display! Don't Do it! I was able to walk away without buying one twice.....at drop off and at pick up.....Bring an anti mac Windows friend with you to keep you away from your credit card or bring your wife....LOL)
     
  17. กมล_ก่อมานะ

    กมล_ก่อมานะ Bit Poster

    Messages:
    1
    hi
    i'm a new one @here
    thank for any good answer for this forum
    thank you
    nisit24
     
  18. GreenLantern

    GreenLantern Bit Poster

    Messages:
    17

    I would like to thank you VERY much for this solution. It TOTALLY solved my problem. Just for the record, I am using PD9 but had the same problems described by the other users; excruciatingly slow Windows with stuttering. The problem started after I upgraded to OSX 10.10.1. I assume there is a connection but I can't be sure. Again, thank you for posting! GL
     
  19. Boyd Petersen

    Boyd Petersen Bit Poster

    Messages:
    7
    This is freaking unreal. I have been dealing with this for almost 2 months. I type one little terminal command and problem is solved.

    I have re-installed parallels about 20 times, even tried vmware-still not work, I went and bought a new windows disk-2 of them actually-one for my virtual drive and when that didn't work had to use bootcamp. I then did a complete fresh install of yosemite. Still nothing. So I went and bought 4 new memory sticks for my iMac. Still no work.

    I type one little terminal command and problem is solved. Unreal. Makes me so mad. All I had to do the whole time. Windows just booted right up no problem. Before it took about 4 minutes. Just took about 15 seconds. ugh. At least it's finally solved but come on parallels. This is bull.
     
  20. Daniel_Gross

    Daniel_Gross Bit Poster

    Messages:
    1
    This isn't a problem with Parallels, it's a problem with Mac OS X itself! If you're having this problem, please report it directly to Apple so that they are aware of the problem and can fix it for a future version of OS X 10.10 Yosemite.

    To report this problem to Apple:
    1. Visit https://www.apple.com/feedback/imac.html
    2. Here's a sample for the "Subject" field. Please adapt it to include your specific details: Yosemite slow on 2011 iMac - com.apple.driver.AppleACPIPlatform
    3. Here's a sample for the "Message" field. Please adapt it to include your specific details: After upgrading my iMac from Mavericks to Yosemite, there was a significant decrease in performance. The UI became less responsive and animations become much choppier, and Virtual Machines became slow to the point of no longer being usable. With the help of a Parallels article at http://kb.parallels.com/122767, I traced the issue to an excessive number of interrupts being generated by com.apple.driver.AppleACPIPlatform . The solution was to run sudo nvram boot-args="debug=0xd4e". Many people are experiencing the same problem - please see http://forum.parallels.com/threads/parallels-10-running-slow-on-yosemite.326205/page-2 and https://discussions.apple.com/thread/6621147 for example.
    If you have an Apple Developer account, you can also file a bug report for OS X at https://bugreport.apple.com/

    Please also see this issue reported on Apple forums: https://discussions.apple.com/thread/6621147
     

Share This Page