Parallels 11 Strange Internet Connection Behaviour in Browser

Discussion in 'Windows Guest OS Discussion' started by TonyK1, Aug 24, 2015.

  1. TonyK1

    TonyK1 Bit Poster

    Messages:
    1
    I have a very strange problem to report. I bought Parallels 11 to use on my MBP (I had been using the trial version of Parallels 10 beforehand), and when I try to access "google.ca" in Internet Explorer in my Windows 8.1 VM, I was redirected to "google.ca.org" (which interestingly enough, is an actual site about a very intriguing cause). If I tried doing this in Firefox, it would just give me a "page not found" error. However, I can access other sites such as "walmart.ca", "rogers.com", and "bell.ca". I just could not access Google, Yahoo, Bing, etc. I tried resetting the network adapter, resetting the hosts file back to default, verified all network settings, changing the DNS, and every other possible solution Google gave me. I disconnected from the network I was currently connected to (which happened to be a corporate network at the time), and connected to my phone's personal hotspot. All problems were gone when I did so.

    I reverted back to Parallels 10, and re-connected to the corporate network. Everything was fine again. So I'm not sure what Parallels 11 has done, but this behaviour certainly took an insane amount of time from my day just troubleshooting. I feel very disappointed that after purchasing this (which makes the first time I've purchased software in several years), this mishap occurs.

    Is there a money-back guarantee policy for Parallels? I literally bought this last night and have been very frustrated with it that I'd like a refund.
     
  2. TCLockhart

    TCLockhart Bit Poster

    Messages:
    3
    I can confirm this behavior, and I assume it has to do with some sort of double NAT and/or load-balancing situation. I see it affect multiple sites.

    UPDATE ======
    Very strange, after two days of trying to figure it out, this suddenly self-resolved right after posting. Makes no sense.

    Interestingly, I still cannot open Network and Sharing Center in Control Panels.
     
    Last edited: Sep 24, 2015
  3. JohanJ1

    JohanJ1 Bit Poster

    Messages:
    2
    Same thing happened to me. It resolved automatically
     
  4. JohanJ1

    JohanJ1 Bit Poster

    Messages:
    2
    Any solution to this?
     
  5. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    3,682
    This thread has been created at 2015, could you provide us with more details info about the issue please? Which version of Parallels Desktop are you using? When did you get this issue? Screenshot of error message if possible
     

Share This Page