Parallels 12 + Windows 10 + USB Mouse = Atrocious graphics performance (video attached) [Solved]

Discussion in 'Windows Virtual Machine' started by 667eoh, Oct 13, 2016.

  1. 667eoh

    667eoh Junior Member

    Messages:
    13
    Hi,
    I have the latest Parallels 12 Pro edition, using the latest Windows 10 on macOS Sierra.
    Even a few months after release, the graphics performance is still horrible, effectively preventing me from using my VM.
    Here is a video (I recommend watching it fullscreen on Youtube):

    It feels exactly how it looks like (graphical reactions to mouse input take up to one second). It has been like that from Day 1, subsequent updates did not change anything. Windows 10 is practically unusable.

    I tried fixing it myself, without success. In particular I tried:
    • Reinstalling Parallels Tools, several times.
    • Updating Windows 10
    • Changing all available Parallels graphics settings (in particular: scaling, DX emulation, synchronization, available video memory)
    • Hypervisor settings
    I feel I am out of options and reinstalling the VM is not one of them. I would be very grateful for any clue how to fix this.
    Thanks!
     
    Last edited: Oct 13, 2016
    ethomp likes this.
  2. 667eoh

    667eoh Junior Member

    Messages:
    13
    Best Answer
    Update 5: Support sent me this:

    1. Right-click on the virtual machine name in Control Center and click Configure...
    2. Go to Hardware tab and open Boot order menu.
    3. In this menu go to Advanced Settings and add Boot Flag in the field:

    devices.usb.mouse=0​

    This fixed my problem.
     
    ethomp and Maria@Parallels like this.
  3. Maria@Parallels

    Maria@Parallels Problem solver

    Messages:
    8,123
    Hi, if you're running the latest version of Parallels Desktop (12.0.2-41353) please create a problem report and provide us with the report ID
     
  4. JaisonG

    JaisonG Bit poster

    Messages:
    2
    Report # 121745816
     
  5. 667eoh

    667eoh Junior Member

    Messages:
    13
    Alright, I just sent my support request. As a side note, when reporting a problem you produce a confirmation that reads:

    Your support request has been submitted successfully. An email with your ticket number has been sent to your email address. Instructions on how to track your support request(s) via the Parallels Support Request Tracker, are located here

    However, the link in there is broken (points to http://kb.parallels.com/en-us/122777, which gives error 404). Also, in the mail follow-up I received I am being redirected to https://support.parallels.com, but I can't seem to log in there to follow up on my ticket. My regular login / password don't work.

    And just to clarify, the report number posted by JaisonG is obviously not from me, so his problem might or might not be related to my description and video above ...
     
  6. JeanQ

    JeanQ Bit poster

    Messages:
    6
    I have exactly the same problem, but when i connect my Thunderbolt Display, Parallels is unusable just like this.
     
  7. 667eoh

    667eoh Junior Member

    Messages:
    13
    @JeanQ, interesting. I also just noticed when I unplug all USB devices it seems to get a little bit better.

    Update: Even more, it seems to be only my Logitech mouse. Once the mouse is unplugged, the performance gets better immediately.

    Update 2: Followed the steps here regarding Mice and Logitech products (uninstalling LCC), but I didn't even have it installed, and there were no kernel extensions to remove. No luck.

    Update 3: In the file vm.log I get these error messages, like a lot (many 1000's) ... Don't know if the log is actually related, but given the performance decline has some connection to the external mouse being connected ...

    10-14 21:07:24.499 F /USB:90283:76555/ USB mouse enabled (after guest queue overflow)
    10-14 21:07:24.499 F /USB:90283:76555/ USB mouse died, switch to PS/2
    10-14 21:07:24.500 F /USB:90283:76555/ USB mouse enabled (after guest queue overflow)
    10-14 21:07:24.500 F /USB:90283:76555/ USB mouse died, switch to PS/2
    10-14 21:07:24.501 F /USB:90283:76555/ USB mouse enabled (after guest queue overflow)
    10-14 21:07:24.501 F /USB:90283:76555/ USB mouse died, switch to PS/2
    10-14 21:07:24.502 F /USB:90283:76555/ USB mouse enabled (after guest queue overflow)
    10-14 21:07:24.502 F /USB:90283:76555/ USB mouse died, switch to PS/2
    10-14 21:07:24.503 F /USB:90283:76555/ USB mouse enabled (after guest queue overflow)
     
    Last edited: Oct 14, 2016
    JeanQ likes this.
  8. JeanQ

    JeanQ Bit poster

    Messages:
    6
    :eek: Ohhhh, when i unplug my mouse (razor) happens the same the parallels get better not like before but better. wow!
     
  9. 667eoh

    667eoh Junior Member

    Messages:
    13
    Update 4: I just contacted Parallels customer support. My experience was not so nice, as the person insisted that a "graphical delay of up to 1s would be considered 'minor' and normal behavior of a VM" (his words). In other words, what you see in the video above is considered expected Parallels VM performance. Asked him to escalate the ticked, but hasn't gotten back to me so far.
     
  10. 667eoh

    667eoh Junior Member

    Messages:
    13
    Best Answer
    Update 5: Support sent me this:

    1. Right-click on the virtual machine name in Control Center and click Configure...
    2. Go to Hardware tab and open Boot order menu.
    3. In this menu go to Advanced Settings and add Boot Flag in the field:

    devices.usb.mouse=0​

    This fixed my problem.
     
    ethomp and Maria@Parallels like this.
  11. Maria@Parallels

    Maria@Parallels Problem solver

    Messages:
    8,123
    Thanks for sharing this solution!
     

Share This Page