Parallels 15 destroyed EFI partition

Discussion in 'Installation and Configuration' started by RozhkovI, Aug 14, 2019.

  1. RozhkovI

    RozhkovI Bit Poster

    Messages:
    4
    I had 3 OS on my Mac via Fefind (OS X, Win, Ubuntu) and everything worked fine with trial parallels 14 !

    After I installed Parallels 15 and first time run bootcamp-based windows 10, Parallels 15 asked me to reboot my vm after Parallels tools upgrade.
    Then vm can not start as it can not find loader!? I checked my EFI partition and found that there is no any data in it. Wow!

    So now I have no access to my bootcamp-based VMs and thanks god I decided to check EFI partition and reinstall refind. Or I would loose access even to OS X boot.
    Parallels is so parallels. After many years with VMWare I decided to try it and "welcome", "enjoy".
    How broken is 15 version if it can destroy data on Efi partition???????
     
  2. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    3,876
    @RozhkovI could you collect a tech report data and reply us back with the report's ID?
    We will investigate this issue further
     
  3. Dmitry@Parallels

    Dmitry@Parallels Staff Member

    Messages:
    526
    Hi @RozhkovI, Parallels Desktop does not have write access to EFI partition by default, read only. But, if you have System Integrity Protection disabled and you're using custom boot loader, Windows might break its structure. I repeat - Windows updates EFI partition when there is read-write access.
     
    Last edited: Aug 15, 2019
  4. RozhkovI

    RozhkovI Bit Poster

    Messages:
    4
    Dear Maria and Dmitry,
    I did some research and ready to send some info for you

    and What?
    "Parallels client-programs aka Operative systems" have it. So this is still your problem to control it if these systems operate in a differ way then usual during Parallels booting.

    1. Moreover, Parallels do it - for instance if you will try to install Ubuntu on Physical drive and choose EFI for boot loader, then you will see message from parallels that operation is not permitted (but if you will install Ubuntu from demo interface - then Parallels is ok with EFI write LOL)
    2. System Integrity Protection disabled - yes as I had before problems with both Parallels and Vmware because in was enabled - well known problem for you guys. Maybe this version is not mandatory to switch it off. I don't know.
    3. I never saw as well as I could not google info that Windows 10 delete all files from EFI without writing any data. Is it strange? I am more then sure that this is so critical issue to remove all booting data, that MS programmer... any programmers can't do it in purpose.

    Possible reason:
    The only one thing that got changed "visually" after upgrade from 14 to 15 is HardDisk --> Advanced settings --> location:
    Before upgrade I had Sata 0:1, after NVMe 1. Maybe at some step Parallels allowed Windows to make changes(delete), then disallow(update) without any notification. Example with Ubuntu installation above - we can see that Parallels blocks EFI access only sometimes! (make it always then or do backups or ask password or whatever?)

    Also, I have EFI backups. So if you are interested in problems solving, tell me how can I share these files to you:
    1. before upgrade from 14 to 15.
    2. Now (when I finally fixed the problem) and both Windows and Ubuntu worked normal way
     
  5. Dmitry@Parallels

    Dmitry@Parallels Staff Member

    Messages:
    526
    Thank you for the details, @RozhkovI. Can you please send us a technical report via Help menu > Send Technical Data... > please post the report ID here.
    Parallels Desktop does not control whether to allow Windows to write to EFI partition or not. When SIP is disabled on Mac, Windows can write to EFI partition.
     
  6. macjack

    macjack Bit Poster

    Messages:
    9
    I upgraded to 15 earlier this week. Started VM and within a split second, I got a blue screen of death. I did not have time to address right away, but that evening I called tech support. One of the first things I was asked - did I stop the VM before I upgraded? Well, that is one way to put the customer on defense, but I was pretty sure that I did. After a short time of looking at my machine, I was told that the VM was corrupt. Along the way, I was questioned as to whether I even had anything on it, as the size was similar to a raw Win10 Install. I don't keep much on the VM, as I just use it when I travel. However, I did have a Lightroom Library on it that I did not want to lose. Support did try to revert to Version 14, but no success there. End result - I had lost my VM.

    Today, I did some experimenting with a backup copy that I had. It had been sometime since I had backed up, but I had a full copy of the VM at one instant in time.

    1. The backup was approximately 96 GB. I could attempt to load it with Ver 15, and I got instant BSOD. However, after each attempt, the VM was now only 12 GB. So, basically, Version 15 destroyed the VM before much could even be loaded. I tried this 3 to 4 times, with identical results each time. I even captured a screenshot video of this happening!

    2. In the back of my mind, I wondered if I had, somehow, upgraded with the VM open or otherwise not closed down just right. So...

    3. I uninstalled 15 and reinstalled 14. Then I attempted to load the backup VM. It loaded perfectly!

    4. So, I think that I have proved to myself that my VM was closed down correctly when I upgraded. I think I have also proved to myself that it is Paralells that destroyed my VM. Sure, I can get a refund, but I have wasted many hours getting to this point.

    I will never use software from Parallels again. Agressive upgrade marketing without similar agressive quality control. I feel bad for those that lose a lot of important data. My loss was modest, and most can be recreated, but I spent 50 bucks to lose a weekend of spare time. Thanks Paralells #$X%!!
     

Share This Page