Parallels 15 sometimes freezes host system, sometimes won't start on mojave

Discussion in 'General Questions' started by RossK2, Sep 2, 2019.

  1. RossK2

    RossK2 Bit Poster

    Messages:
    1
    I am running Parallels Desktop for Mac version 15.0.0-46967 on macOS 10.14.6 (mojave).
    I have two guests installed: Windows 10 and Ubuntu 18.04, both with the latest parallels tools.
    My iMac is the 27-inch, Late 2013 model with an SSD installed in place of the original fusion drive.

    When parallels starts, it does one of three things:
    • Causes my iMac to hang while showing the spinning beachball/pinwheel and being completely unresponsive aside from mouse movement.
    • Gets stuck on the parallels splash screen, never showing the control center window.
    • Gets stuck starting one of the guests (it doesn't seem matter whether it's the Windows or Ubuntu guest).
    I have tried:
    • Uninstalling and reinstalling parallels
    • Running Disk First Aid (this shows no issues, and my hard drive is quite new).
    • Running the Apple diagnostic tool (this shows a System Management Controller issue, but this seems unrelated according to https://support.apple.com/en-gb/HT201295).
    • Switching my guest to the Apple hypervisor.
    • Restarting my mac and removing the power cable for a few minutes, then replacing my power cable and trying again.
    Occasionally after uninstalling and reinstalling, parallels will work for a few days with no issues before hitting this problem again.
    I notice that the process 'prl_disp_service' is often stuck at 100% CPU at times when the system hangs.
    I run ESET antivirus, but have disabled the firewall feature to ensure there are no issues connecting with prl_disp_service.
    My iMac often stays in standby for hours at a time with parallels running, but the issues frequently happen after a clean reboot.
    I have attached my parallels.log for your reference.

    These issues have cost me a lot of time and energy. How can I get parallels working properly on my mac?
     

    Attached Files:

  2. helpdeskl

    helpdeskl Bit Poster

    Messages:
    2
    How much RAM you are assigned to Parallels? The Checkbox Adaptative Hypervisor is marked?
     
  3. MarkH32

    MarkH32 Bit Poster

    Messages:
    2
    I'm having problems similar to RossK2 since upgrading to Parallels 15. (version 15.0.0 46967)
    Now impossible to get Parallels to run, even after multiple reboots / restarts of iMac (OS 10.14.6 on 27 inch 2017 with 64GB ram).
    Once today I was able to get to the point of resuming Windows 10 in Parallels, but it then hung with the message "Checking Disks after improper shutdown..." and I once again had to force quit parallels.

    Is there a way to roll back to ver 14 until you get this fixed?
     
  4. MarkH32

    MarkH32 Bit Poster

    Messages:
    2
    Hmmm
    That was easier than I expected: per another support article, I just re-downloaded ver 14 and ran the install program. It "downgraded" Parallels back to ver 14 and now it (and Windows 10) appears to be running fine again.
    Hoping it continues to do so.
    If it crashes again I'll come back and post to let you know, but if it continues to run fine, then I'll just wait a while to upgrade to ver 15 again (after these problems have been resolved).
     
  5. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    3,702
    Guys, is it possible to reproduce the issue, generate the tech.report right after that and post the report's ID here for the further issue investigation.
    Thanks in advance.
     
  6. Jorgen G.

    Jorgen G. Bit Poster

    Messages:
    2
    I have very similar issue, and I suspect Parallels as the it is not reproducing when Parallels is not installed.
    Can you help me with troubleshooting?
     
  7. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    3,702
    Hi, in order to troubleshoot this issue we need a tech report, that was generated right after that issue reproduced.
     

Share This Page