Parallels 15 System Requirements clarification

Discussion in 'General Questions' started by kinless, Aug 14, 2019.

  1. kinless

    kinless

    Messages:
    2
    I noticed on the new Parallels 15 product page that it lists Mojave (macOS 10.14) as the minimum host OS, but then on the Software Compatibility KB page (https://kb.parallels.com/114381) it says that Parallels 15 is supported on Sierra, High Sierra, and Mojave (10.12, 10.13, 10.14).

    So which is it? Hoping for the latter since my hardware setup is keeping me on High Sierra (10.13). Wish I could have upgraded to Parallels 14 but it looks like that ship has sailed. Parallels needs to offer the previous version for those of us who can't/won't upgrade. I can't find a 1-time perpetual license for v14 on any other authorized dealer sites (they're all subscription-based).
     
  2. kinless

    kinless

    Messages:
    2
    Sorry, meant to say I've only read articles that Parallels v15 only supports Mojave (macOS 10.14) or higher. Can you clarify?
     
  3. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    4,563
    @kinless, Parallels Desktop 15 could be installed on
    macOS Catalina 10.15 (when released)
    macOS Mojave 10.14
    macOS High Sierra 10.13
    macOS Sierra 10.12

    But please note that the DirectX 11 (new Parallels Desktop 15 feature) requires at least macOS Mojave 10.14, but works best on macOS 10.15 Catalina.
    Let us know if you have any other questions.
     
  4. totvos

    totvos Bit Poster

    Messages:
    31
    Host OS aside, does PD15 run well on older hardware? In my case I have a MBP 2011, that is currently running Sierra and PD12. I would like to upgrade to PD15 but not if I am going to open a bag of hurt. In the past PD updates have not gone that well, until at least the first point release after a major one. But I really don't want to bog down a working system just for the sake of upgrading, in the hope that some of the minor annoyances of PD12 are fixed.
     
  5. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    4,563
    @totvos, you can check Parallels Desktop 15 system requirements here and test the newest version during the trial period.
     

Share This Page