Parallels 16.5, Linux with nmap, network issue

Discussion in 'Parallels Desktop for Apple Silicon (M1) Mac' started by DominicL4, Apr 14, 2021.

  1. DominicL4

    DominicL4 Bit Poster

    Messages:
    6
    Hi,
    I have noted (and glad) that Parallels 16.5 has been released. Currently, I am
    currently under the evaluation if I should go for a purchase. But before that,
    I note that there is a major issue which I have been experiencing (actually I
    found this out since Preview 2).
    Besides Windows ARM64, I am also interested in Linux ARM64. Currently
    I could get Kali Linux ARM64, and Ubuntu 20.4 ARM64 Desktop installed
    successfully. But I note that if these VMs happen to run "nmap", say:

    % nmap some_ip

    This network would not be available until some minutes after. Is it an
    expected behaviour? Would this issue be fixed? Is it a Parallels issue
    or Linux issue under Apple M1? Here is the configuration of my MacBook:

    * Apple MacBook Pro 13" M1
    * macOS 11.2.3
    * Parallels 16.5
    * Linux tested: Ubuntu 20.4 ARM64 Desktop, Kali Linux Rolling (apt updated to latest version)
    * nic: purely MacBook wifi, without using external ethernet or wifi

    These issues are very important, so as for me to determine if I should go for a purchase.
    Thanks!
     
  2. Elric

    Elric Parallels Developers

    Messages:
    1,673
    Hi, I just tried myself the nmap. It works successfully in my environment. Could it be that router in your environemnt blocks network port when it sees suspicious activity? For me this appears to be the most likely reason. I don't see anything in Parallels that could stop networking because of nmap.
     
  3. DominicL4

    DominicL4 Bit Poster

    Messages:
    6
    Thanks for your suggestion. I instantly think of "Little Snitch". I tried to turn off the filtering of Little Snitch. However, the same issue is still here. I doubt if it is due to router issue. In fact, I also tried running nmap natively under macOS (through homebrew installation). It does not give the same network issue. In fact, after doing nmap under the Linux vm, the nic looks irresponsible under the Linux vm (the macOS host nic is still working well). NIC under Linux vm stays irresponsible for some minutes and then it works again, until another nmap...
     
  4. DominicL4

    DominicL4 Bit Poster

    Messages:
    6
    One thing which I might need to mention is that my macbook M1 also gets Docker installed (of course, M1-compatible Docker). Not sure if it matters.
     

Share This Page