Parallels 16 extremely slow on MBP

Discussion in 'Installation and Configuration' started by PatrickP9, Oct 6, 2020.

  1. watagan

    watagan Bit Poster

    Messages:
    9
    OOps, sorry, I confused Fusion with Parallels. Silly me. So I've now changed the display memory in Parallels to 512mb but without luck. Excel is still as slow as before. Apologies for the false hope.
     
  2. MatthewH11

    MatthewH11 Bit Poster

    Messages:
    14
    Changing video RAM made no difference to me, still very sluggish operation the vast majority of the time.
     
  3. JB6

    JB6 Bit Poster

    Messages:
    6
    So the video RAM change only made it so the Windows guest no longer completely locked up my host OS. The VM itself is still very slow, stuttering, and takes forever to go things. But at least now I can use the host while it's happening.
     
  4. JB6

    JB6 Bit Poster

    Messages:
    6
    Another follow up: downgrading to 15 has solved my issue. It appears to be a memory related problem, as the total RAM usage of the VM is 30% less on version 15 than version 16 with the same settings. Passing along to Parallels support today. Good luck everyone.
     
  5. watagan

    watagan Bit Poster

    Messages:
    9
    Downgrading Parallels did not help in my case.
    Same Excel spreadsheet & macros. Using all latest versions: Parallels 15 ~60 sec, Parallels 16 ~60 sec, VMWare ~16 sec, native Win 10 (6-core i7 5820) ~10 sec. Both Parallels versions slow, stuttery, was fine on Catalina but not Big Sur.
     
  6. MatthewH11

    MatthewH11 Bit Poster

    Messages:
    14
    I'm getting better performance if I set the guest to use "scaled" resolution in the VM Graphics setup. Anybody find it makes a difference?
     
    Maria@Parallels likes this.
  7. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    7,751
    Hi, could you collect the tech report once the issue reproduced and post the report's ID here please?
     
  8. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    7,751
    Are you running the latest Parallels Desktop build?
     
  9. watagan

    watagan Bit Poster

    Messages:
    9
    See my post above (p2). The report number is 361377877.
     
  10. MatthewH11

    MatthewH11 Bit Poster

    Messages:
    14
    Yes
    I'm also running the latest VMWare Fusion off an import of the VM and it's just fine there, so I think the VM itself is ok.
     
  11. sjanofsky

    sjanofsky Bit Poster

    Messages:
    3
    Has anyone tried changing the hypervisor? I was having different issues related to Visual Studio 2019 during compilation. Changing from Parallels to Apple hypervisor seemed to fix the issue.
     
  12. MatthewH11

    MatthewH11 Bit Poster

    Messages:
    14
    Yes I fiddled around with various hypervisor settings, no change. I thought in Big Sur it was a requirement to use the Apple hypervisor anyway so I'm not sure if it does anything.
     
  13. Tunik

    Tunik

    Messages:
    1
    I have the same problems. I began my Parallels Toolbox update around 8:00 this morning. It's now nearly 3:00 pm, and it's only 90% finished. Something is very wrong. My system:
    Model Name: iMac
    Model Identifier: iMac19,1
    Processor Name: 6-Core Intel Core i5
    Processor Speed: 3.1 GHz
    Number of Processors: 1
    Total Number of Cores: 6
    L2 Cache (per Core): 256 KB
    L3 Cache: 9 MB
    Memory: 16 GB
    System Firmware Version: 1554.50.2.0.0
    SMC Version (system): 2.46f12
     
  14. J.O

    J.O Bit Poster

    Messages:
    1
    The problem is Parallels, not a change in Catalina. Until last week I worked on Parallels 12 in Catalina on a MacBook Air 2012 and it worked flawlessly (can you believe it?). Now, since last weekend, I am working on a MacBook Pro Early 2015 with Parallels 16 in Big Sur and it is a nightmare: I can notice a lag in mouse response, cursor movement and even typing when working in Excel 365 (Office 365 is the only software I run on Windows); the lag is not 5 seconds, but I can see something isn't working properly.

    If, by any change, I need to be in a call on Teams (Mac version), and share my Excel screen, I am finished. Response time for clicking on a sheet tab could be anything above 30 seconds. Sharing Power BI screen in Teams is not an option for me... I am telling you, I did all this on a MacBook Air 2012, running Windows 10 in Parallels Desktop 12 in Catalina with NO issues.

    If you managed to find a solution to this issue, please, let me know.

    Thanks!
     
  15. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    7,751
    Hello, are you running the latest version of Parallels Desktop?
     
  16. koow

    koow Bit Poster

    Messages:
    2
    Yes , I also having this issue, mouse delay and everything is lag. Downgrade to parallel desktop 15 look better.
     
  17. MikeB40

    MikeB40 Bit Poster

    Messages:
    1
    Thought I'd chime in - I've been having HUGE performance issues as well, nothing I found was working. Constant lag, freezes, stuttered mouse/typing, windows blanking out for a few seconds, etc.
    I finally found a solution though... completely solved my issues. In 'control center' > 'graphics': I changed the resolution to 'Scaled'. It was set to 'Best for Retina Display', just changed it and now windows is a fast as OSX. Huge difference.
    I'm running Parallels 16.1.3, windows 10 pro on a 2018 15" i9 MBP with 32GB ram and Big Sur.

    I've spent HOURS trying to find a solution - I'm sure there are lots of different possibilities depending on your setup, but I hope this helps someone!
     
  18. MatthewH11

    MatthewH11 Bit Poster

    Messages:
    14
    Yes, a notable difference setting to scaled, but it's still got pretty laggy for me after a few days even with that change. Pretty unusable compared to the competition.
     
  19. koow

    koow Bit Poster

    Messages:
    2
    I had try your solution , set to "scaled display" , changed hypervisor to "Parallels" sand "Apple", RAM increase to 6GB , but no luck, still laggy, mouse freezed, screen laggy. End up , i downgrade to parallel desktop 15 , now everything look ok
     
  20. RobK7

    RobK7 Bit Poster

    Messages:
    3
    I am also having these issues since upgrading, particularly with the screen freezing for 5 to 10 seconds at a time before resuming. As another user mentioned these cursor still moves about the screen when this happens.

    Is there a fix for this yet?
     

Share This Page