Parallels 18, Apple keyboard and Windows 11

Discussion in 'Windows Virtual Machine' started by Peter73, Jan 27, 2023.

  1. Peter73

    Peter73 Bit poster

    hello again, I tried it since one week but I don't fin a solution :-(
    I use Ann apple keyboard an my arm iMac. within macOS it works great. now I use parallels version 18 and installed windows 11 arm.
    so i installed the parallel tools as well.
    NOW the problems I can't use the "at" sign. (I use a German keyboard as you can see in the attachment) :confused:
    in windows 11 there is an parallels apple keyboard and a German keyboard installed but it doest allowed me to use the "at" sign....
    can anybody help me please?

    Attached Files:

  2. Ami1

    Ami1 Bit poster

    You can use the On Screen Keyboard in Win11 to enter this symbol
    Click on start button and type OSK and then click on the on-screen keyboard icon.
    If you still can't see the @ symbol you can use the numeric keypad / numpad to enter the ascii code
    Type type Alt-64 and release Alt to get @ symbol (only on numeric keypad of your keyboard or the OSK, not the numbers below function keys)
    To switch on numpad click options in OSK you may have to click options and select show numpad.

    I had similar problem once so put a text / notepad file on desktop with all the needed symbols typed in (using OSK) from where i used to copy paste !
    Offcourse that doesn't work if you have a "@" symbol in your windows password !
    (Though OSK can be set to come up on login screen it usually only does that on touchscreens)
  3. Ami1

    Ami1 Bit poster

    For a more permanent solution we need to understand a few things -
    do you have @ symbol in your macbook german keyboard ?
    And is it correct that both the windows keyboards (german & parallels apple) coming up inside parallels win11 arm VM do NOT have @ symbol ?
    What happens if you add a normal US or UK keyboard inside windows 11 (click start and type language or keyboard and it should show you some settings) - you can select either keyboard from the right bottom taskbar area once installed.
    OR is it that @ symbol is shown but nothing happens on pressing that key?
    You can use if nothing else works, to reassign some key to produce the @ symbol
  4. Maxim Rasulov

    Maxim Rasulov Staff Member

    Thank you for reaching out to us.

    For German keyboards, to type in special characters, you need to use layout pre-defined key combinations.

    By default, for German(Apple) Parallels keyboard layout, "@" symbol is produced by using the "Control"+"Option"+"L" key combination.
    Note: Same combination applies to German "ABC-QWERTZ" layout in macOS.

    For default Windows, "German QWERTZ" layout, the combination for "@" symbol is "Control"+"Option"+"Q".

    For virtual machines we generally recommend using layouts that contain "(Apple) Parallels" as they have key mappings corresponding to the Apple physical keyboard layouts.

    Depending on which layout is currently active in the virtual machine, please try using one of the combinations.

    Have a nice day!
  5. Peter73

    Peter73 Bit poster

    thank you for helping. now it works with a virtual keyboard
  6. DorisB3

    DorisB3 Bit poster

    Hallo Peter, ich hoffe mal Du bist 'native German speaker'. Mein Englisch ist nicht so optimal. Ich hab Das gleiche Problem, allerdings hab ich einen iMac und kein Macbook. Ich hab also auch kein touchscreen und kann kein on-screen keyboard verwenden. Eventuell kannst Du mir ja weiterhelfen?
    Hello Peter, I hope you are a native German speaker. My English is not so good. I have the same problem, but I have an iMac and no Macbook. So I don't have a touchscreen and can't use an on-screen keyboard. Maybe you can help me?

Share This Page