Parallels 18 stuck on loading screen

Discussion in 'General Questions' started by Manuel15, Mar 13, 2023.

  1. Manuel15

    Manuel15 Bit poster

    Hi, so basically everything worked just fine like 2-3 weeks ago. Today I need again something from my old friend Windows and Parallels just loads to eternity.
    I tried to make a new VM with Windows 10 and 11, copy over my old VM which did work before, install a VM on my external drive, reinstalled Parallels and tried to revert to an old snapchat. But no matter what I do, it's just loading. Every time, just a loading screen, it looks like it's working, but even after hours, nothing happens.
    Sometimes a window pops up and says to finish the installation restart your pc. I restarted my Mac like 10 times in the last hours, nothing seems to work
    Is there something else I can try ?

    I am using a MacBook Pro 2018 with an Intel CPU and Ventura 13.2.1.
    For the Parallels part, I am using version 18.2.0 (53488) and my license is valid until the end of 2023.
  2. Tharun@P

    Tharun@P Moderator

    Hello @Manuel15 , Please open your Windows virtual machine loading screen. After opening the virtual machine if you are in the full screen mode then exit the full screen mode. Now you will see the "Actions" option appear on the Mac menu bar where the Apple icon appears on the Mac side. Now click Action > Click STOP > Do not click Shut Down, as Shut Down is different from Stop. Now check if everything is working fine by opening the virtual machine again. Please follow this link: to learn more about STOP. Thanks.

Share This Page