Parallels 3.0: After Update Activation Key is not accepted any more

Discussion in 'Installation and Configuration of Parallels Desktop' started by, Aug 12, 2007.

  1. Bit poster

    I purchased an activation key for version 3.0 that worked fine so far until I updated to the latest release.

    I used the "Help_Search for Updates" function, and automatically an update was downloaded. After installing I was asked to re-enter the activation code (which was somewhat of a surprise) just to get the message that this code does not work with this version.

    I tried going back to the old version using the download-link in my activation mail but still the same result: no valid activation key.

    Furthermore since the update Parallels is in German instead of English! I speak German but still think this is weird as my entire Computer runs in English.

    Even stranger: When I tried to send a message to SWSoft I had to log on to my account. Although User Name and Password are correct (they even re-sent them to me) I am told that the password is wrong.

    Any idea what could be going on here?
  2. danboarder

    danboarder Junior Member

    Same Problem here

    I am having the same problem, I paid for the previous version, and then was on the private beta team for 3.0. Does that provide a clue? I currently cannot access Parallels 3.0 at all, it says my activation key is expired when I try to activate with the final key (not supposed to expire).
  3. Bit poster

    Figured it out!

    I finally figured most of it out (unfortunately without any help from the Parallels Team)!

    The activation key problem was actually directly linked to the issue that Parallels suddenly had the wrong language. Activation Keys seem to be different depending on the language version. I downloaded the English version directly from the SWSoft-Homepage, and it immediately worked again!

    I still wonder why the update via the "Help_Check for Update" function AND the link in the registration mail provided me a German version although the key does not work for it. Weird!

    And the problem that I did not get access to my account was solved by using Firefox instead of Safari. Worked like a charm. I cannot believe that a company that earns money with software for Apple has a website that is not entirely Safari compatible!
  4. Mr Blue Sky

    Mr Blue Sky Bit poster

  5. Sabrina

    Sabrina Parallels Team

    Hello, danboarder! Please see your PM list. Thank you.
  6. elvedon

    elvedon Bit poster

    I am having the same problem--I upgraded to the new build of Parallels 3.0, thinking it was just an update for a bugfix or something, and now it won't accept my registration key and I can't access my disk without paying $50 for an "upgrade."

    That is seriously annoying. I just purchased a retail box of Parallels 3.0 on June 2--I'm not going to pay $50 more for a new build I didn't need or want!
  7. elvedon

    elvedon Bit poster

    Does anybody at Parallels actually answer help questions via these forums?

Share This Page