Parallels 3.0 and Boot Camp

Discussion in 'Parallels Desktop for Mac' started by Chak, Jun 7, 2007.

  1. Chak


    Hi All,
    I have just upgraded to version 3.0
    All the VM's are working fine.
    When I try to open the Bootcamp Partition i'm getting the well known error that Parallel's unable to open disk image..:(
  2. cynic


    Try to reboot your Mac. I had this error a couple of days ago. However, out of curiosity I tried it again today and it worked...
  3. Chak


    I have done few reboots en Windows restart with no success.
  4. aaron77


    I'm having the same problems. Tried rebooting several times, as well as several re-installs of parallels and still no luck.

    I've confirmed that my boot camp partiton works fine natively, so it's something with parallels. I've also tried turning off as much of everything else as I can - audio, cd, floppy, network, etc.

    i've noticed that it seems to unmount and remount the windows partition during the boot, and it fails as the partition comes back. is this normal?
  5. mpdan



    I'm pretty sure it's because Parallels only mounts the partition back once it has a successful shutdown.. If it fails, it never gets to that point.

    i've been wrong in the past...:p
  6. Chak


    I found out that my keyboard and mouse are no longer working when i start boot camp Windows XP native.

    I have also VMWare Fusion running on the same machine.
    I can start the bootcamp partition without any problem.
  7. phy5ics


    Also Duped!

    I was also duped into downloading and installing 3.0, thinking that given the quality of past releases, that this one would be alright. I definitely won't make that mistake again, as I'm now receiving the dreaded "Unable to open disk image Boot Camp!" message despite a prior install of 3188 working swimmingly with XP MCE on a 15" MBP 2.16 with Boot Camp 1.3.
  8. jvgfanatic


    I have not seen an issue. It is a 1 month old install of 10.4.9 and bootcamp 1.2 on a MacBook Pro 2.33 17" It's an upgrade to 3.0 (trial) from 2.5 which used the bootcamp partition with XP (obviously). I've booted via Boot Camp, I've booted via Parallels 3.0, I've opened the drive in both environments (3 counting OSX) all without fail.

    I'm not really pushing any boundaries here and I do run a pretty tight ship, needlessly formatting and reinstalling every six or so months (honestly I do it just so it forces me to keep on my toes with backups)

    I know it doesn't help those that are having difficulties to know of a clean scenario that's functioning but it perhaps give y'all some hope?
  9. snodman

    snodman Bit Poster

    Everything is working well for me and I've beaten on it pretty hard. I did run the Boot Camp 1.3 beta update first before then rebooting into Parallels 2.5 just to make sure nothing got broken from the Apple update. I then upgraded Parallels to 3.0 without a problem. I've rebooted several times over the past couple of days back into Boot Camp (which still works just fine), Mac OS X (which still works just fine) and run Parallels from my Boot Camp partition just fine (even experimenting with which Direct X games will and will not work). The only time the system has gone wonky was the first time I opened every game on the XP partition one after the other to see if they would work (and had to crash out of half of them). Just doing that in "real" windows is likely to blue screen you, BTW. But everything worked fine again after a reboot.
  10. eyamanak


    I had problems having Parallels tools under VMWare fusion, so I'd warn against that.

    If you're going to run Boot Camp under Fusion, I'd suggest removing Parallels tools first. It's particularly bad, because you can ONLY uninstall Parallels tools WHILE RUNNING UNDER PARALLELS. They won't uninstall when running under VMware.

    Just my experience.

  11. Chak


    Today i removed my Boot Camp Partition

    Installed Boot camp 1.3
    Created 32 Gb Windows XP partition
    Installed Windows XP pro

    Done some test every thing is working fine.

    finally created a new Vm using Boot Camp partition.

    Still getting the same error

    Unable to open disk image Boot Camp!

    This can't be a final product if you support something and many people can't use it.

    Parallels TEAM please help to solve my problem.
  12. sfbayrealtor


    I get the same error...

    I get the same error: Unable to open disk image Boot Camp!

    running parallels build 4124, trying to mount my windows xp sp2 bootcamp installation.
  13. brkirch

    brkirch Kilo Poster

    This has been posted about several times for previous versions, I just wish that Parallels could fix it or at least make a mention in the documentation. Some installs of Windows XP do not have in the /WINDOWS/Driver Cache/i386/ folder. The solution is to make a copy of the file and rename it to
    Last edited: Jun 9, 2007
  14. Chak


    Thank you for you help
    VM just starting up and installing the tools
    Why is Parallels just not giving an clear message...:S
  15. sfbayrealtor


    that fix worked for me too! :)

    Thanks brkirch ;)

Share This Page