Parallels 3.0 and game compatibility...

Discussion in 'Windows Guest OS Discussion' started by Shaun666, Feb 16, 2007.

  1. Shaun666

    Shaun666

    Messages:
    1
    Running Games

    Hi,
    I frequently use Windows for running games that I used to have for my PC so I thought I would buy Parallels and give it a go. And now I have decided to download a not so demanding poker application (PKR Poker - pkr.com) and whenever I try to start it I get "Could not initialize client - Cant create a D3D device" I have asked their support and they said that they don't know how but they have heard that users are using emulators such as this. How can I fix it so that it will work?
    Thanks

    Shaun
     
  2. Stevamundo

    Stevamundo

    Messages:
    417
    I assume that it needs 3D to run. If so, then you have to wait until Parallels 3.0 comes out.
     
  3. alzaba

    alzaba

    Messages:
    5
    Flight Simulator X and Vista

    Does FSX under Vista work in parrallels??
    I installed FSX but got a start up message saying my video driver was out of date?????

    Anybody help??
     
  4. Farsinsen

    Farsinsen

    Messages:
    2
    Did you manage to get PKR to run?

    Just installed Parallels 3188 hoping that PKR would run. Still get the same error though:

    Could not initialize client - Cant create a D3D device - -2005530516, -2005530518 (Render Init) (Render Init)

    Anyone?
     
  5. darkone

    darkone

    Messages:
    810
    again, as steve said. the current released version of parallels does not include 3d support.
     
  6. snodman

    snodman Bit Poster

    Messages:
    56
    Right. Most games require direct access to the 3D card and the current release of Parallels does not support that. Version 3.0 (due to be released Real Soon Now) has such support.
     
  7. ricka

    ricka Bit Poster

    Messages:
    13
    Hi guys,

    I thought I'd start a thread to talk about peoples experiences with Games under 3.0. I look forward to reading the responses.

    Please post, the game name, the specs on your mac and how playable the game is under normal, super hi res and minumal settings.

    Personally I want to know how half-life 2 plays.

    Thanks,

    --Rick
     
    Last edited: Jun 7, 2007
  8. Faye

    Faye

    Messages:
    4
    Well, so far I'm totally unimpressed. "Delivered in 3.0:...3d graphics, DirectX and OpenGL support" Great! I thought, I can finally play sam & max (oh yeah, I go for the hardcore stuff!)

    Sorry, Can't initialise Direct X.

    So far a waste of the upgrade fee.

    Sigh.


    Faye
     
  9. desh

    desh

    Messages:
    7
    Eve-Online

    I'm using my bootcamp XP install and had to go into the VM properties and turn on Direct X. Once done, I was able to load and launch Eve-Online. Window mode (for the game) appears to have mouse coordinate issues and there were some graphical glitches to the progress dialogs, but once I went full screen things worked great!
     
  10. Faye

    Faye

    Messages:
    4
    Thank you thank you! Why don't they enable this by default?!

    OK Sam and Max, danger beckons!

    Oh, and don't run in coherence mode, or you'll get a mostly white screen with the game in the top left corner.

    Seems to run at normal speed. Yay!

    I take back "waste of upgrade.." heh, worth every penny.


    Faye
     
  11. Mac Write

    Mac Write

    Messages:
    21
    Games I am interested in are Splinter Cell series, Rainbow Six series, RollerCoaster Tycoon 3,

    Anyone have these?
     
  12. ClunkClunk

    ClunkClunk

    Messages:
    14
    I just tried it with a few of the games I have on my Boot Camp partition.

    • X-Wing Alliance - No good. The game launches, and will let me start a mission, but the frame rate is about 0.5fps, not playable at all. Plus it seems the models are not textured, but are flat grey. It came out in 1999, so I wasn't really surprised.

    • Oblivion - No good. It reported Unknown Video Hardware, and defaulted to Medium video settings. It tried to load, then crashed, and popped up one of those "Report it to Microsoft" errors.

    • KOTOR - No good. The same error as Oblivion after it tries to load the start screen.

    • Star Trek Elite Force II - Works wonderfully. I was surprised, as I haven't played this game in months, but it loads and runs perfectly through Parallels 3.0. I'd say the framerates are about 90% of what I get while booted in to Windows. I was pleasantly surprised.
     
  13. jvgfanatic

    jvgfanatic

    Messages:
    44
    Europa Universalis III - No good. Failed to create a graphics device. Not surprising as I think the specs for this game are rather high. I will take another look and try again. I'll edit my post if I learn anything.

    It does run under boot camp, btw.

    Requires 128MB video ram, i see that Parallels only allows up to 64MB. (This as is made clear by Andrew's post below, is irrelevant).

    And yes, Andrew, I made sure the DirectX option was checked :)

    Oh, and good news is that we Mac users will be getting our own EUIII soon enough, yay!
     
    Last edited: Jun 7, 2007
  14. gideony

    gideony

    Messages:
    9
    I get the feeling that us early adopters are really getting hosed here pretty well.


    Of course, we CHOSE to be early adopters... but I know I made that decision based on Parallels not disappointing in prior tests. This round, however... they aren't bringing anything all that new to the game, and poor implementation of what they did.

    So, I'm disappointed. I've been waiting for this 3d support to actually buy Parallels, but tested the earlier versions... I'm glad I finally have it, but I feel cheated. I'm going to try a few games I have later, but I doubt any will work.
     
  15. Andrew @ Parallels

    Andrew @ Parallels Parallels Developers

    Messages:
    1,546
    DirectX checkbox in Video tab in VM config!

    Guys,

    Please don't forget to check on DirectX checkbox in Video tab in VM config for DirectX games. Video RAM size is not relevant - keep it default. Both OpenGL and DirectX support use native video RAM on your host video card. Video RAM settings is relevant only for Windows GDI resolution.
     
    Last edited: Jun 7, 2007
  16. eyamanak

    eyamanak

    Messages:
    5
    Star Wars: Empire at War, Forces of Corruption expansion starts and runs OK. It's pokey, but it's already kinda pokey under native Boot Camp on my MacBook 2GB.

    Civilization 4 crashes when you get to the Main Menu. It launches ok, opening intro video runs, but starts choking. Audio during the intro is fine.

    --Erick
     
  17. jvgfanatic

    jvgfanatic

    Messages:
    44
    Well I decided to increase the screen size for EUIII and now I'm getting the error:

    "requires 128MB of video ram"

    Ahem. well, I've got plenty more than that on my 17"MBP2.33

    I'm assuming that it's actually an incorrect error. EUIII requires DirectX 9.0c and hardware pixelshaders. It does run under Boot Camp but Parallels seems to want to choke on it (or it chokes on Parallels, hard to say :))
     
  18. spullara

    spullara

    Messages:
    29
    CounterStrike: Source failing

    Whenever it tries to start I get a:

    Engine Error:

    failed to lock vertex buffer in CMeshDX8::LockVertexBuffer

    Oh well, bootcamp remains the only solution to get my fix.
     
  19. rkadowns

    rkadowns

    Messages:
    10
    Old School

    I'm going old school here to report that Drakan, Order of the Flame appears to work fine. FWIW, the game works while in coherence mode if the game is set to run in full screen mode but not in windowed. Doesn't seem to be a problem when the VM is in full screen mode either way.

    Not that the requirements of this game are anything to worry about, I'm quite impressed at how smooth the game runs. Nice.
     
  20. AlanH

    AlanH

    Messages:
    318
    I think I detect a backward step.

    Civilization III Conquests used to run OK in version 2.5 of Parallels, but having downloaded and installed the version 3 trial it doesn't run at all. All I get is a splash screen for a few seconds, then zilch.
     

Share This Page