Parallels 3.0 and game compatibility...

Discussion in 'Windows Guest OS Discussion' started by Shaun666, Feb 16, 2007.

  1. bombastinator

    bombastinator

    Messages:
    30
    elder scrolls III: Morrowind with vista

    While the game refuses to run full screen it will start up in windowed mode.

    This is followed by an odd hang in that it says : true color 32 bit required. now the vista display settings has a 32 bit mode labeled 'highest' instead of true color.

    This looks like a minor fixable bug. Not sure if theres a handy work around though.
     
  2. Wick3d

    Wick3d

    Messages:
    3
    I d/led DirectX 9 and 10 to see what happens. 9 had some error message, but 10 didn't seem to have any problems, though Parallels most likely does not utilize it.
     
  3. mster142

    mster142

    Messages:
    5
    Im looking into play Civ City Rome, I downloaded everything and installed the directx on my VM and install seems to go fine but when I try to run the game says that it cant locate DirectX ??

    any ideas on how to fix this ?

    VGA-compatible BIOS version 2.01
    Parallel 2.5 build 3188
     
  4. draconis1

    draconis1

    Messages:
    2
    Has anyone gotten CoH to work on 3.0?

    Hello,
    While I have gotten a few games that I regularly play to start in 3.0, and they all play rather well, I have yet to be able to play City of Heroes. I can start the game, even log in a charecter; however, the game always starts at 800x600 on a fresh install. When I go to the options menu to change the resolution, not just the game, but the entire iMac freezes and must be rebooted. Has anyone been able to succussfully play this game?

    Thanks,
    Draconis
     
  5. jeroenhmg

    jeroenhmg

    Messages:
    3
    Morrowind Elder Scrolls 3 here too... crash message as follows on XP service pack 2 from Boot Camp partition:

    Render Creation Error: "Creation failed: could not match desired fullscreen mode"

    This happens no matter what, VM in windowed or fullscreen modes.
     
  6. Uhlhorn

    Uhlhorn

    Messages:
    12
    Silent Hunter III: Can not initialize 3D engine

    Silent Hunter III: Can not initialize 3D engine. Any ideas?

    Can not initialize 3D engine.PNG

    Supported OS: Windows® XP/Vista Only
    Processor: 2GHz Pentium 4 or AMD Athlon (4 3GHz Pentium or AMD Athlon recommended)
    RAM: 1 GB (2 GB recommended)
    Video Card: 128 MB RAM DirectX® 9–compliant, video card capable of rendering Pixel Shader 2.0 (256 MB RAM recommended) (see supported list*)
    Sound Card: DirectX 9 –compliant sound card
    DirectX Version: DirectX 9.0c or later (included)
    Hard Drive Space: 6 GB
    Multiplayer: 128 kbps upstream or faster (512 kbps upstream or faster needed to host online games)
     
    Last edited: Jun 12, 2007
  7. dkp

    dkp

    Messages:
    1,412
    DirectX 9 is not supported in Parallels. OpenGL 1.4 and DirectX 8.1 only. Use BootCamp.
     
  8. AlanH

    AlanH

    Messages:
    320
    XP/Parallels supports OpenGL 100% up to 2.0 on my MacPro. 1.4 may be a limit imposed by Intel GMA hardware on specific Macs, not by Parallels.
     
  9. cetuma

    cetuma

    Messages:
    40
    The good news is Battlefield 2142 should be native Mac soon.
     
  10. rooster42

    rooster42

    Messages:
    1
    I'm having the same problem. . .

    This sucks. . .I thought I heard that was one of the games that worked?

    I'm getting the same error. . .Guess it's back to boot camp!

    Any ideas anybody? :mad: :D
     
    Last edited: Jun 12, 2007
  11. Nightwolf

    Nightwolf

    Messages:
    27
  12. PrinceZordar

    PrinceZordar

    Messages:
    49
    Oblivion requires DirectX 9.0. Parallels only supports up to 8.1

    -Z
     
  13. avp

    avp

    Messages:
    1
    Parallers 3.0 and Microsoft Flight Simulator 2004

    I have question about MSFS 2004 in Parallers 3. I make correct install and run the game. Menu is loading correctly, select airport, airplane and start the game. After loading texture and game contant, i see only black screen and sound from the game. In Virtual Machine Setup i have DirectX enable. Any solution please?
     
  14. bpc101

    bpc101

    Messages:
    2
    Any luck in getting PKR to work?

    I also bought Parallels back in February not realising that this wouldn't work. I want to upgrade to 3.0 but would also like to get rid of Bootcamp, and for that I need PKR to work!
     
  15. paanta

    paanta

    Messages:
    1
    Counter-strike 1.6 & OpenGL/D3D

    CS 1.6 doesn't actually seem to be compatible. Half-Life plays fine, but the only mode that works in counter-strike is software rendering. OpenGL mode leaves off all the models' skins and doesn't show a lot of the textures. D3D is dark and choppy. Yes, I've enabled DirectX in the VM settings. This is on a new MB Pro 2.2ghz w/ 3gb of RAM, so I'm not exactly hurting for performance, either.

    Am I doing something wrong, or is Parallels _not_ actually able to give 3d acceleration to CS (as it was advertised as doing)?
     
  16. eriqthegeek

    eriqthegeek

    Messages:
    22
    Rise of Nations is _SO_ close to working well ...

    It's playable ... sort of. All the building textures are screwed up, you can kind of see parts of the outline but then the rest of it is just white blocks. There's also some graphics corruption in the upper left corner of the screen. Runs at a good speed.... even good in windowed mode.

    It's sooooo close but I can't quite bring myself to play it with some of the graphics all screwed up.
     
  17. Frank Friedlos

    Frank Friedlos

    Messages:
    17
    Drakan. Great game! Glad someone else agrees.
     
    Last edited: Jun 13, 2007
  18. Stuart.

    Stuart.

    Messages:
    16
    3D Gaming

    I know they are not 'modern' games - I don't have any recent ones to test out, but fwiw:

    I have just played 1/2 an hour or so of Unreal Tournament 2003 and about the same of Deus Ex and both work very well thank you.

    UT2003 runs with every single video option switched on without any performance degregation - in fact running with them all turned off produced no increase in performance which was curious. The game seemed a little slow (no - not a decrease in framerate, just slower than normal, which means it is running closer to my reaction time, so I'm getting great frag counts :D ), but that seemed to be corrected when I threw a bit more RAM at the VM. So good fun.

    Deus Ex - runs like a bought one, I notice a number of redraw errors- objects sitting on tables (for example) where a corner of the object seems to penetrate the table surface, but I can live with that. Otherwise, it runs as well as it ever did on a PC.

    Anyway - don't know about the rest of you, but I'm having fun.


    Oh - again fwiw, Train Simulator didn't work, as it wants hardware acceleration, but I guess I'm the only person who cares whether that one works or not. :rolleyes:
     
  19. themario3000

    themario3000

    Messages:
    4
    Run 3D Games on parallels

    Ok so I finally got parallels working but I can't play any of my games. :( I went into the cofigurations and checked the directx box. I have the machine 1000 mb (1 GB) of ram and 64 Mb of video ram. My real computer has video ram and 2 gb of ram. Please help. Some of the games I have tried to play are the following: lord of the rings returne of the king, lord of the rings battle for middle earth 1 and 2, pirates of the carabian, age of empires 2 and 3, and dungon lords. Thanks
     
  20. jeroenhmg

    jeroenhmg

    Messages:
    3
    "Elder Scrolls 3: Morrowind" again and "Far Cry"

    In addition: another error for Morrowind:

    Render Creation Error: "Unsupported desktop resolution. Change windows resolution to "True Color (32bit)"."

    This is with the desktop resolution of Windows set to 32 bit, 800x600 trying to play Morrowind in a window, 640x640 requested and shaders off.

    Far Cry:
    Set the renderer to OpenGL in the INI files, set everything to low, sound in compatibility mode to get rid of unwanted noise and resolution at 800x500. The game is not really playable on a Mac Book Pro C2D 2.33, 2GB RAM, x1600 with 256MB. Too laggy, no real rendering problems.
    This game is listed on the product information pages but should not really be there since it is unplayable.
     

Share This Page