Parallels 3.0 and game compatibility...

Discussion in 'Windows Guest OS Discussion' started by Shaun666, Feb 16, 2007.

  1. airolson

    airolson

    Messages:
    10
    The 15th Anniversary release of Another World works swimmingly!
     
  2. dailo

    dailo

    Messages:
    80
    No joke! Sure the FPS is pretty low, but it plays alright. Its good enough for a quick CS fix, but if I am going to play for a long time I'd switch to Boot Camp for sure. I also have everything set to low, but there might be some tweaks that might improve performance.
     
  3. bgose

    bgose

    Messages:
    55
    For Tomb Raider Anniversary see this thread.

    http://forum.parallels.com/thread13169.html

    Hopefully, this will help to get it running faster and more playable.
     
    Last edited: Jun 18, 2007
  4. phavelar

    phavelar

    Messages:
    2
    I haven't had luck with HL2 it does not even starts for me.
    HL1 works, but not HL2.
    Anyone experienced similar problem?
     
  5. timadlr

    timadlr

    Messages:
    18
    When I tried CS:S came up, and ran. Not that well, but it did. Haven't tried HL2 though.
     
  6. Atmosphere

    Atmosphere

    Messages:
    3
    Swat 4

    I just installed Swat4 on XP running on a Macbook C2D 2G Ram... in full screen mode it seems to run pretty good so far. In a window - it's a little slow at 1st - but then it works very well.

    My settings for parallels: 256MB, 8MB Video Ram
    I set the graphics to lowest in the game 1st... and am running in 800x600

    But so far so good :)
     
  7. ShinseiRyu

    ShinseiRyu

    Messages:
    1
    Regarding FFXI, I was initially having the same issues with the black screen in POL but POL not being frozen/locked up (sound working and you can hear the changes you make but not see). Changing the options for POL to load full screen as opposed to "Start in windowed mode" allowed me to see POL and consequently load FFXI, but once you get into FFXI the screen garbles up with half POL and half old images of the desktop.
     
  8. billin

    billin

    Messages:
    2
    Command and Conquer Generals: Zero Hour

    Hey all,

    I saw someone post about C+CG:ZH crashing on startup when run in Parallels 3.0. In my experience, I get the splash screen, then an error dialog saying that it requires DirectX 8.1 or higher, or my video card may not be compatible.

    My setup:
    MacBook Pro 2GHz Core Duo, 2GB RAM, Radeon X1600 w/ 256MB
    Running at 1440 x 900
    Parallels Desktop 3.0, build 4128
    WinXP Pro installed on a BootCamp partition
    "Enable DirectX support" checked
    Main memory set to 1028MB
    Video memory set to 64MB (I also tried it at 32MB)

    Anyone had any success running Command and Conquer Generals in Parallels?

    Bill
     
  9. wildbluyonder2000

    wildbluyonder2000

    Messages:
    1
    We got ripped off I'm afraid!!

    Well just from reading all these posts its obvious we should demand our money back and file a lawsuit against parallels for false advertising. Graphics are the only reason I got this. What a load of crap. :mad:
     
  10. tabhastal

    tabhastal

    Messages:
    4
    From a recent news release from Parallels, Inc.

    "Without leaving their Mac desktop, users can play popular Windows-only 3D games such as Quake, Half-Life 2,..."

    What were you guys smoking?

    (Full text of news release at http://www.parallels.com/en/news/id,11791)
     
  11. claud9999

    claud9999

    Messages:
    8
    Games I'd like to see supported

    Games I've tried, to no success:

    Broken Sword - The Sleeping Dragon - comes up, graphics are really f*cked up
    Sub Culture - crashes immediately (using the D3D version)

    Games I haven't tried, I would kill to be able to play, but I am not holding out hope of support for a couple more versions:

    Battlezone, Battlezone II
    System Shock 2
    Dungeon Keeper 2
    Carmageddon 2
    Hardwar

    Unsure if these older games work on more modern versions of Direct X, I wiped my BootCamp partition when I moved to a 250GB hd in my MacBook, yes! Guess I'll stick to playing my DS until this stuff gets ironed out.
     
  12. Anhaedra

    Anhaedra

    Messages:
    3
    I have tested these so far...

    Fallout 2: Runs, good speed, but the colors are wrong.
    Planescape Torment: Runs fullspeed, some mouse tracking problems but it's not a big problem.
    Deus Ex Invisible War: Runs, very, very slow, unplayable
    The Chronicles of Riddick: Does not run, gives error about OpenGL not being the correct version
    Gothic 2: Will not start
    Morrowind: Error about screen resolutions, as seen in other posts
    Oblivion: Starts, but crashes at main menu. Also tried with Oldblivion, nothing changed
    Arx Fatalis: Black screen
    Live for Speed: Screen is displayed higher than it should be, but it runs, slowly.
    Hitman 2: Runs slowly. It also runs in Crossover Office at a very nice speed, so you'd be better off doing that for now...
    Need for Speed: Porsche Unleashed: Would not run for me

    Overall I'm pretty impressed that DirectX games work at all. :)
     
  13. Ramzeska

    Ramzeska

    Messages:
    3
    Lineage c4 don`t work

    I tested some games:
    VM configuration 512 ram and 64 video ram XP SP 2;
    GTA Vice City - slow but playable;
    Max Pain 2 - works good, but in white color;
    CS 1.6 - very good in directx mode;
    3DMax 5.0 - work;
    3DMax 7.0 - work only in software mode;

    when Lineage C4 start you see warning " The game not be consistant because AGP is deactivated" , after it you see black screen and lineage`s cursor, after it if you use high acceleration level windows crash , if you use normal acceleration level lineage crash and goto windows desktop.

    P.S. Thanx for 3d
     
  14. biglar

    biglar Kilo Poster

    Messages:
    251
    Roller Coaster Tycoon 3 Platinum

    I installed and ran Roller Coaster Tycoon 3 without a problem. The game needs to be run in 800x600x32 resolution only -- high resolutions will lock up the computer. The game seemed to run at a good speed; as you increase the size of your park, the game will run slower -- however, this is true on any machine.:)
     
    Last edited: Jul 3, 2007
  15. jester

    jester

    Messages:
    2
    Guys,

    Please don't forget to check on DirectX checkbox in Video tab in VM config for DirectX games. Video RAM size is not relevant - keep it default. Both OpenGL and DirectX support use native video RAM on your host video card. Video RAM settings is relevant only for Windows GDI resolution.
    __________________
    Best Regards,
    Andrew @ Parallels


    I'm trying to play some games, Like Command and Conquer 3, BASE (parachute base jumping tha on other pc doesn't need a lot of graphic).
    I'm trying to find the configuration for the directx but I can't!
    Can u show me the procedure of it!
    I've got Macbook pro with parallels build 3188
    regards jester
     
  16. buirseach

    buirseach

    Messages:
    4
    guild wars crashes the VM


    oh, and has anyone experimented with updating direct x?
     
  17. Stevamundo

    Stevamundo

    Messages:
    412
    Bicycle Casino in XP. It played perfectly in 2.5. Last night for the first time in 3.0 I tried to play it and didn't work. I'm guessing that it's because I have DirectX enabled.
     
  18. ppawel

    ppawel

    Messages:
    2
    I just tried the demo for Operation Flashpoint, and it runs beautifully under 3.0.

    I'm quite impressed!!
     
  19. ppawel

    ppawel

    Messages:
    2
    Here's a few more I tried:

    Jagged Alliance 2 Gold -- runs flawlessly (ran ok but with probs in Parallels 2.x)
    Sid Meier's Alpha Centauri -- runs flawlessly (didn't run at all in 2.x)
    X: Beyond the Fronteir -- doesn't work
    Aces High V2 -- doesn't work
     
  20. boringo

    boringo

    Messages:
    3
    Thiefs

    My install base:

    Mac Mini Core Duo 1.6Ghz, 1Gb RAM

    VM: Windows 2000 Pro with 128Mb RAM

    I LOVE that you are trying to run the Thief series. One of my favorite games of all time. In my config, Thief 1 runs like a champ. It's a little laggy to start, but once the game is rolling it is very responsive and gameplay is terrific.

    I tried installing and running Thief II, but ran into issues. Install went great, but upon running the game, I got some error about having an incompatible video card. Not sure what that was about - anyone have any suggestions?


     

Share This Page