Parallels 3.0 and game compatibility...

Discussion in 'Windows Guest OS Discussion' started by Shaun666, Feb 16, 2007.

  1. kiw

    kiw

    Messages:
    1
    supreme commander

    hi,
    I bought yesterday supreme commander which is a very big game, for the ones who knows...
    but i tried many times by installing and desinstalling on parallels and it didn't work. the last time it said " please ensure you have the minimum requirement"just after that I saw that I could only put my video memory to 64, wich is not enoug!
    I wanted to know if evrybody has the same problem?

    if it don't work on parallels maybe on bootcamp but before installing all this stuff! I wanted to know if somebody have already play supreme commander on his mac!!???

    mine :1.83GHZ intelCD, 667mhz,aty readonX1600 128mb

    please reply before i'll be sick of it
     
  2. vijay kate

    vijay kate

    Messages:
    5
    3d games

    even with directX turned on, VM ram maxed out, my unreal 2003 plays like wading thro a bog, so does UT2004 have the same probs?
     
  3. vijay kate

    vijay kate

    Messages:
    5
    but really, i think tis largely a mac problem, most intensive 3d games run a bit sucky on mac, even thro boot camp, maybe tis to with dirX/openGL support
     
  4. slant

    slant

    Messages:
    2
    Not really sure why you'd want to do this anyway as Diablo 2 runs natively on the Mac. Just a thought.
     
  5. Eru Ithildur

    Eru Ithildur

    Messages:
    1,966
    Maybe he already bought the Windows game and doesn't want to spend the money again? Money doesn't go on trees afterall. Not that the money for two games is the end of the world for most people, but even the typical millionaire doesn't drop that kind of money needlessly.
     
  6. slant

    slant

    Messages:
    2
    lol - actually, to my knowlegde, all copies of Warcraft 1,2 & 3, Diablo 1 & 2 as well as World of Warcraft are dual-compatible with both Mac and PC. I'm willing to accept proof against this claim, but I've never seen a version of one of these games that was not.
     
  7. Falconfire

    Falconfire

    Messages:
    5
    nope your 100% correct, every Blizzard game out there comes on dual-compatible media with not only the provision to run on both systems, but the licensing to do it to. So if you bought the mac version then moved over to the PC your license is still valid and vise-versa.
     
  8. gregarios

    gregarios

    Messages:
    6
    I just finished playing Half-Life2 on my new iMac 2.8 CDE 24" machine in Parallels 3... seemed very playable, although framerates dropped once in a while down to about 5fps. There were a few issues with the mouse not tracking, or tracking right out of Parallels and into the Mac OS at points, but I played it out none-the-less and learned to just click back into the Paralles window to resume. (-;
     
  9. justmyluck61

    justmyluck61

    Messages:
    1
    I would love to have Caesar IV working. i keep getting a unhandled exception: n a
    with C4Patch\source\engine\D3DDeviceManager.cpp
    Line #348?
    anyways i would apperciate your help on this as soon as you can. I have a MacBook.
     
  10. Tomomcd

    Tomomcd

    Messages:
    1
    Would love to see city of villains/city of heroes running

    Game seems to generally run smoothly enough, just a lot of graphic glitches at the moment which make it very hard to play! Transparent characters etc

    Many thanks
     
  11. robneville73

    robneville73

    Messages:
    1
    Nope on the blizzard

    Not 100%. I'm holding my copy of Diablo II for PC in my hand right now and no mac version on the disc....
     
  12. helmishariff

    helmishariff

    Messages:
    33
    Warcraft3 run fine on my parallels.
     
  13. minimoog

    minimoog

    Messages:
    1
    Hello,

    Referring this quick report about Stalker on PD, I'd like to know if another user ran it successfully, as this game seems to run with directX 8 ?
     
  14. asmogard

    asmogard

    Messages:
    1
    Diablo II, Icewind Dale II, Baldur's Gate II

    MacBook Pro
    Mac OS X Version 10.5.2
    2.5 GHz Intel Core 2 Duo
    4 GB 667 MHz DDR2 SDRAM

    Parallels Desktop for Mac 3.0 Build 5582

    VM:
    Windows XP Professional SP 2
    1024 MB Memory
    64 MB Video Memory
    Enable DirectX Shaders

    Diablo II
    ----------
    Installs. Does not run. Spins VMs CPU to 100%. Killing Game.exe results in message indicating the Play disk could not be found.

    Icewind Dale II
    -----------------
    Installs. Runs. Horrible flickering of mouse cursor and characters. Unplayable due to seizure inducing flickering.

    Baldur's Gate II
    ------------------
    Installs. Runs. Some flickering ala IWD II above, but not nearly so bad. Playable.

    I ran all of the above games under the default, minimal, and maximal graphics settings. No noticeable differences.
     
  15. robbo007

    robbo007

    Messages:
    13
    I noticed a post regarding Sam and Max. Have you not tried the Scumm project under OSX? Works perfectly. No need to boot Windowzzz.

    http://www.scummvm.org/

    Cheers,

    Rob
     
  16. ShoutingMan

    ShoutingMan Bit Poster

    Messages:
    11
    Any more insights for Diablo II in Parallels?

    I've gotten Diablo II to run in Parallels on my MacBook Pro, but it's not good enough to be worthwhile. I installed Diablo II and the LOD upgrade, completely. LOD runs, however there are some issues. The recommended DirectDraw 2D video option works with no video glitches, but it's just a bit too sluggish to be enjoyable. DirectX 3D works and runs faster, but there are video problems; in particular the inventory chest doesn't draw correction making it very difficult to manage the character.

    So, this is really a BootCamp game for me.

    And Diablo II no longer runs on the Mac. It requires "Classic" which is not supported in OS X 10.5.
     
    Last edited: May 4, 2008
  17. andym

    andym

    Messages:
    2
  18. ShoutingMan

    ShoutingMan Bit Poster

    Messages:
    11
    Thanks! I didn't see that looking for the Diablo patches. Unfortunately, it only runs in Software mode, but that's good enough and sure beats having to reboot into Windows to play a bit of Diablo.

    Ah! StarCraft has an OS X installer now! Will try that later.
     
    Last edited: May 7, 2008
  19. Nighthawk4

    Nighthawk4

    Messages:
    1
    I am trying to run Neverwinter Nights 2.

    iMac 2.66GHz with 2Gb of RAM, latest version of Parallels (downloaded yesterday). The VM has XP SP2.

    I have enabled the 3D option in the XP VM. I also installed DirectX from the game DVD.

    It installed fine but when it runs it says 'no Direct3D devices found' and closes.

    I can't use the Mac version as I need the Mask of the Betrayer update for online use and that has not been released for the Mac. I have tried Crossover, but that cannot find the disk when it tries to run, even though the disk is in the drive and the drive is enabled in the Crossover bottle (copy protection problems).

    Anyone else have better luck with this please?
     
  20. mrlyne

    mrlyne

    Messages:
    1
    Running Morrowind on latest parallels build

    So I upgraded to the latest build of Parallels. Morrowind was throwing incompatible resolution messages before the upgrade, now it actually runs. Currently sitting at 5 fps outdoors, 20-30fps indoors.... this is without adjusting any video settings or ini tweaks, of course. I'll post agian after I've done that.
     

Share This Page