Parallels 3.0 and game compatibility...

Discussion in 'Windows Guest OS Discussion' started by Shaun666, Feb 16, 2007.

  1. DsurioN

    DsurioN

    Messages:
    11
    Here are a few games I've tried so far:

    Ballance (Marble rolling game) - Launches, but is "invisible". I can hear the menu clicks when i click in the black screen with my mouse. Had to terminate with task manager.

    Luxor 2 - Launches, but again is invisible.

    Bejeweled 2 - Runs perfectly well

    RollerCoaster Tycoon 3 - Runs relatively well, there are some graphical glitches with the lawn and such though. Menu actually seems more sluggish than the game itself...

    All in all, things work relatively well, I'm pleased to report. I don't know why some games are able to launch but not display anything.
     
  2. mpetry

    mpetry

    Messages:
    1
    Supreme Commander = no joy

    SupCom fails with a dialog box of "Minimum Vertex and Pixel Shader version 2.0 required.
    Please ensure sytem has current video drivers."

    I'll have to continue to keep work and play separate.

    Or at least until a future release.
     
    Last edited: Jun 7, 2007
  3. czenzel

    czenzel

    Messages:
    14
    Running Games on Vista?

    Has anybody tried to run any games on Vista instead of Windows XP in Parallels?
     
  4. jvgfanatic

    jvgfanatic

    Messages:
    44
    eeek. I've got some 2D strategy games that ran great in 2.5. I hope they still work in 3.0!
     
  5. stokkes

    stokkes

    Messages:
    27
    Anyone get Half-life2 running half decently?

    MBP CoreDuo 2.16Ghz, 2GB of ram ATI X1600

    Runs rather slowly.. not really playable.
     
  6. Luctus

    Luctus

    Messages:
    1
    When running Guild Wars with default settings, the graphical glitches makes it impossible to even log in. After setting DirectX 8 compitability and disabeling shaders in Guild Wars, the graphical glitches goes away, but it's still unplayable due to far too low framerate. Also, when trying to play in full-screen mode, it leaves the taskbar and the bottom part of desktop still visible.

    Tried on a MacBook@2Ghz with 1,2Gb of RAM.
     
  7. bxlewi1

    bxlewi1

    Messages:
    8
    It's unplayable on my MBP 2.33, 3GB, X1600 @ 256MB. Not native speed at all (I've played it in boot camp and it plays like butta)

     
    Last edited: Jun 7, 2007
  8. XeRXeS

    XeRXeS

    Messages:
    1
    Putting in my two cents for the slightly obscure set of games that most people won't even try :p


    System
    =====
    Computer: iMac
    CPU: 2.16 GHz Intel Core 2 Duo
    Memory: 2gb RAM (768mb assigned to VM)
    Virtual OS: Windows XP SP2


    Games tried thus far
    =============
    Half-Life (Standard install from "Half-Life Generation" box set, not Steam) - Runs perfectly smoothly with OpenGL at 1280x960, only offers up to 1024x768 in the Direct3D tab for some reason but that works fine as well.

    Hitman: Codename 47 - Installs and runs fine, works absolutely perfectly and smoothly at high resolution (I was testing 1280x1024 though it goes up to 1600x1200) with all graphics settings enabled (including Anisotropic filtering) on both OpenGL and DirectX rendering.

    Soldier of Fortune II: Double Helix - Installs and runs fine, seems fairly smooth regardless of graphics settings.

    Thief - Installs fine and runs but lags unplayably badly.

    Thief II - Same result as Thief.

    System Shock 2 - Same result as Thief and Thief II (though uses a similar engine). Particularly difficult as it isn't really compatible with Windows XP to begin with and takes some tweaking to even get running.

    (Notably Thief, Thief II and SS2 are all DirectX 7.0 games but also by the same company and with similar / same engines, so it's hard to know what is at fault for the speed.)

    No One Lives Forever 2 - Installs and runs fine, crashes out completely when you try and start a game. When patched to v1.3, renders cutscenes THEN crashes out. :p

    Dungeon Keeper - Won't run, but I don't think it does on Windows XP at the best of times, so that can't really be helped. ;)

    I'm still tinkering with a lot of random games just to try things out, so I'll post more as I find them :p
     
    Last edited: Jun 7, 2007
  9. purephase

    purephase

    Messages:
    16
    Half-life 2 will launch, but it's not really playable. Still impressed though. I could definitely see less video intensive games working just fine.
     
  10. Alex Suraci

    Alex Suraci

    Messages:
    1
    Ragnarok Online runs great, but there's one problem: Most 3D elements - buildings, and other things like lamp posts and such - don't load. The shadows and NPCs and everything else works fine, though.
     
  11. Kylew01@mac.com

    Kylew01@mac.com

    Messages:
    5
    Vista's Games

    I cannot open any of the Microsoft games that come with Windows Vista (business edition). Every game gives me the same error. I tried this on two different computers and got the same result. One computer was off of boot camp, one off of an image.

    Kyle
     
  12. stokkes

    stokkes

    Messages:
    27
    Odd you say that, HL2 runs fine in native windows on my system (through bootcamp).


     
  13. Ambival

    Ambival

    Messages:
    3
    Was waiting for the upgrade to arrive so I could play Titan's Quest without having to reboot. Installed the game and it refused to start. Applied all of the latest patches and now the screen goes completely white, the sound stutters and after a bit, Parallels crashed completely.

    I'm running a 2.66 Mac Pro w/512M ATI video and 3 gig memory. So far, it's been a complete bust.
     
  14. Falconfire

    Falconfire

    Messages:
    5
    FFXI = glitching before even getting out of POL (as in you cant see anything period in the login screen, though its there as it makes the sounds as if it where displaying properly)

    without DirectX it will show up, but then you cant log to FFXI from POL.

    Going to set autologin for my POL account and see if it changes once you get into POL.

    considering that its usually glitched when its not running in Direct X, and its not even showing up when it is I dont hold much hope for it working. Too bad too, glad I am using the trial.


    Edit: no go, auto logs in fine, but its never displays a window anywhere, back to bootcamp for me until Parallels team can fix this.
     
    Last edited: Jun 7, 2007
  15. bxlewi1

    bxlewi1

    Messages:
    8
    Yes, I was using that to compare to the VM speed. I should edit that post.

     
  16. Cyphin6

    Cyphin6

    Messages:
    12
    Supreme Commander and Civ4 doesn't run at all, the only games I really want to play in Windows :(
     
  17. Mac Write

    Mac Write

    Messages:
    21
    I try to launch SplinterCell Choas Theory and and it quits saying encountered a problem. Doesn't get past the splash screen. see attached screenshot. In the Splinter Cell config utility it says Video memory only 16MB.
     

    Attached Files:

    Last edited: Jun 7, 2007
  18. Ambival

    Ambival

    Messages:
    3
    You can change the detected amount of video memory past 16m in the VM editor, but that seems to only help you get past video checks.

    As a follow up, I've installed Neverwinter Nights 2 (my other favorite title) and the latest updates. "No Direct3D Compatible Devices found!". And yes, "Enable Direct X" was checked in the VM editor settings.
     
  19. Maize

    Maize

    Messages:
    1
    Game performance

    My system: MacBook Pro Core Duo 2.0GHz, 2GB RAM.

    Sam & Max (the new Telltale episodes): They work, but performance is poor. I wouldn't call them wildly playable. Some weird graphical glitches when switching between various modes or resolutions in the game.

    Agatha Christie's Murder on the Orient Express: Game with all options except animation effects turned on plays fine. Some textures are... quite weird. Game is very dark, main character has blanks for eyes. Very creepy! The whole screen is shifted up by some number of pixels, which can make the interface bar at the top of the screen a little harder to hit. Blue segment at the bottom of the screen in the area exposed by the upward shift of the rest.
     
  20. sandau

    sandau

    Messages:
    50
    MBP Core Duo, Windows XP

    CounterStrike:Source, running the video stress test:

    Parallels to boot camp partition: 11fps @ 1024x768 / DirectX8.1, 1024mb ram
    Boot Camp - 55.74fps @ 1280x800 / DirectX9, 2gb ram
     

Share This Page