Parallels 3.0 and game compatibility...

Discussion in 'Windows Guest OS Discussion' started by Shaun666, Feb 16, 2007.

  1. myflyertrains

    myflyertrains

    Messages:
    4
    Yes enabled Directx and tried raising the VM. No difference. Call of Duty does seem to run though.
     
  2. Deere4840

    Deere4840 Bit Poster

    Messages:
    10
    --- Microsoft Flight Sim 2002 Professional ---
    it lays a big egg. At least it worked in Parallels 2.x
    All it does is crash when I try to fly in Parallels 3.
    I can get it to run again by disabling the DirectX checkmark in the Parallels configuration menu.

    --- rFactor ---
    It also lays an egg during the configuration.
    I can't even get to the game before a crash.

    Luckily I qualify for the free update (if they will ever respond to my request for the license key).
    Thankfully I didn't get this primarily to play games on my computer or I'd be a little angry right now.

    Tested on:
    Mac 3GHz 8-Core | ATI X1900XT 256MB
     
    Last edited: Jun 8, 2007
  3. endlesszero666

    endlesszero666

    Messages:
    1
    Oblivion's not working!

    So I tried to install Elder Scrolls Oblivion hoping to see how it performs under Parallels, but after the install I recieved this error:

    Failed to initialize render.
    NiXAdapaterDesc::GetDevoceCaps() failed.

    If anybody has any ideas, let me know, I would love to try this out.
     
  4. akashra

    akashra

    Messages:
    6
    Of the games I've tried so far, none work
    Lego Star Wars II - "Failed to initialize DirectX"
    Supreme Commander - either can't find the CD or gives "This system does not meet the minimum requirements"
    Command and Conquer 3 - crashes on startup.
     
  5. sterno

    sterno

    Messages:
    2
    Yeah I have exactly the same problem and tried exactly the same things. I found that if I ran dxdiag, the video tests worked for all direct3d tests. But when it did directdraw it barfed. So perhaps it's something to do with that?
     
  6. akashra

    akashra

    Messages:
    6
    Wow. This is a huge stretch of the truth. Of the apps in the list in the readme, only four are DX/D3D.
    To say that it 'delivers 3D support' and that there are 'still some limitations' when it can't even run the DX/D3D demos, tests and samples is appalling and frankly just utterly dishonest.
     
  7. sterno

    sterno

    Messages:
    2
    Well that was fun...

    Not to be a downer, but I'm pretty disappointed. I had this great vision of running my favorite windows games on my OS X side and freeing up all that disk space bootcamp was wasting... Not so much.

    When I can play the games I want (specifically Battlefield 2142) I'll be picking up a copy. But for now I don't see any obvious benefit to the upgrade.

    :(
     
  8. perfection

    perfection

    Messages:
    14
    I Am VERY DISAPPOINTED with 3.0
    Parallels crashes when i boot up windows. Sometimes when i click Full-Screen, windows disappears and i see only my Mac OS X desktop.

    Also, i have enabled DirectX Support but when i run Counterstrike or ConditionZero the graphics sucked. Everything is white in color! What should i do?!?
    By the way, i cannot load a game when i am in Full Screen! I only can load a game when parallels is in windowed mode.

    I'm on a MBP 2.0GHZ, 2GB RAM!
     
  9. Cyphin6

    Cyphin6

    Messages:
    12
    Parallels 3.0 is waste of money for those who are looking for gaming, theres no easy way to put it, no 3DMark I have tested can even get past the load screen without a Windows Error Message, no game I have installed can even load without directX Draw errors or etc. It's UNBELIEVABLE I can't believe this feature was released, such an underwhelming release.

    But I will say I do give props to everything else, I feel Windows XP runs near native speeds, but gaming was a feature they failed on in everyway, I mean can we get a moderator to tell us what exactly they tested that even closely worked thats acceptable quality, overall I'm happy but in terms of gaming they should be persecuted for this terribly built feature.
     
  10. SolGrundy

    SolGrundy

    Messages:
    5
    SWSoft gets a big F- for this release. Or at least, their marketing department does. I kept trying older and older games to see what would work, and here are the results, on a MacPro with 3GB memory and an ATI Radeon X1900 XT with 512MB VRAM:

    Half-Life 2: Fail Screen doesn't completely update, unacceptable frame rate.
    Civ 4 Warlords: Fail Eventually gets to main title screen, shows only the eyes and teeth of the animated character in the main menu, won't let me click on menu items.
    Sam & Max Season One: Fail Section of screen cut off, frame rate too low to be playable.
    The Longest Journey: Fail Section of screen cut off, no text displayed anywhere.
    Fallout 2: Fail "Can't initialize input devices"
    FreeCell: Fail Crashes only with Microsoft's standard error-reporting dialog box. That's right, FreeCell doesn't run.

    I'm running Vista Premium. After testing all of these, I look in the release notes to see that Direct3D is only "supported" under XP, not Vista.

    Listing Direct3D support as a major feature of version 3.0: Pass
    Mentioning that Vista isn't supported BEFORE I pay money for the upgrade: Fail
    Mentioning that it's XP-only ANYWHERE in the marketing text for version 3.0: Fail
    Giving me a real list of features included in version 3.0 before charging me $40 for it and warning that time is going to run out if I don't act before buying: Fail
    Making the list of compatible games available before release, or even mentioning that the game support is a small percentage of the games available: Fail
    Advising people on the (not accessible from the main page) forums to try to circumvent other publishers' copy protection to get around compatibility issues: Double Plus Extra Fail

    I'm confident they'll be able to fix the problems eventually, since the company's track record has to make significant improvements in the software very quickly. But this release was completely botched. And the marketing and support in particular have left a really bad taste in my mouth.
     
  11. crag

    crag

    Messages:
    38
    I'm gonna report this in another thread ful of fanboys. Cause I doubt their wad through all these pages.
     
  12. Washu

    Washu

    Messages:
    5
    I just tried Pro Evolution Soccer 5 and it seems to run fairly well at default settings apart from the fact that the display is upside down. Mac Pro 2.6/4GB RAM/X1900XT.
     
  13. cynic

    cynic

    Messages:
    33
    I just tried out VMware Fusion. Sam&Max runs fine there. One can also take a look at the new Unity feature in the new beta, which in my opinion is totally great.

    Somehow I have the feeling the beta of Fusion is a bit more 'round' than the Parallels 3.0 release... :(
     
  14. AlanH

    AlanH

    Messages:
    320
    I think I missed something. Why is Fusion Unity better than Coherence? I see drop shadows, but that doesn't change my world. I don't see any other goodies.
     
  15. Farsinsen

    Farsinsen

    Messages:
    2
    Hmm,

    Just installed the 3.0 trial and still can't get PKR to run. The error message seems to be the same: "Could not initialize client - Cant create a D3D device - -2005530516, -2005530518 (Render Init) (Render Init)"

    Dosen't 3.0 have direct 3D support as expected, or am I doing something wrong?
     
  16. cynic

    cynic

    Messages:
    33
    Well... it also supports minimizing windows to the dock, which makes the taskbar unnecessary. Futhermore it also supports Expose, so that all your os x and vm windows are nicely put next to each other, insted of just putting the whole 'invisible' vm windows into expose.

    I hope to see these features soon in parallels...
     
  17. AlanH

    AlanH

    Messages:
    320
    It's repeated all over these forums, but I'll post it here again ...

    Did you enable DirectX support in the VM video properties screen?
     
  18. dippyskoodlez

    dippyskoodlez Bit Poster

    Messages:
    88

    Actually this IS enabled by default.

    However, on a clean install.

    When you do an "Upgrade" it saves your preferences.

    Of which, Direct X is not there, so it doesn't stay enabled.

    I actually did a fresh install, and direct X was on by default.


    Get your refund instead of thread crapping, troll.
     
  19. dietero

    dietero

    Messages:
    2
    Phoenix Flight Simulator

    After installing 'Phoenix' on Windows XP running in Parallels 3 it would not run at all, merely produce an error message. I had not activated DirectX.
    After enabling DirectX in 'VM configurations' "Phoenix" will start with it's Splash screen and ask me to "Begin" Controller calibration.

    The problem is that the Windows curser goes behind the Phoenix begin window making it impossible to click on any part of the "Phoenix" Screen. Has anyone run into this?

    "Phoenix" operates correctly on my 'Bootcamp' installation of Windows XP.

    What am I missing?:confused:
     
  20. Luke Dog

    Luke Dog

    Messages:
    11
    I too disappointed.

    I was eagerly awaiting this release.. and well.. lets just say I didn't pay the upgrade fee to continue to run Quicken.

    directx fails in dxdiag (yes I turned it on) and every game I attempted didn't work. This was after it crashed my 2.5 image and I had to reinstall XP. Thank god I backed up my data.

    3.0 should have been 2.6.

    I will call next week to get a refund.:(
     

Share This Page