Parallels 3.0 and game compatibility...

Discussion in 'Windows Guest OS Discussion' started by Shaun666, Feb 16, 2007.

  1. johnnykrisma

    johnnykrisma

    Messages:
    13
    No Halo for me

    I was hopeful that Halo would run well since it's older, but no dice. It launches, plays all the intro videos and then goes black as the game itself comes up. Any chance this will work in the future??
     
  2. cynic

    cynic

    Messages:
    33
    I am pretty sure it will... some day.

    3D support in virtualization is brand new and it still needs a lot of work. However, it is already working a bit. If you take a look at VMware Fusion, the 3D support is also not really 'good'. Give it some time...
     
  3. dippyskoodlez

    dippyskoodlez Bit Poster

    Messages:
    88

    Exactly.

    They can't just "patch" every game and all of the future games, because they don't know EXACTLY whats wrong.

    Its not like they can just go "oh, XXXX.dll is now included, all direct x shaders work!" They have to convert direct X into OpenGL so that OS X can render it.


    If the game -opens- now, Its(probably) likely it'll be fixed soon :) The foundation for 3d is in place, now it just needs to be built up. That takes time.

    The reason some games work, is because not all games utilize every aspect of everything made... so the stuff that is finished, works like a champ. :)

    Also take into consideration, this is their job... and this is a weekend.. so give them some time to code a fix, test it, and release it :D
     
  4. Luke Dog

    Luke Dog

    Messages:
    11
    VMWare Fusion is free right now. I'd rather be disappointed for free.
     
  5. snidley

    snidley

    Messages:
    1
    Misleading Advertising and its consequence

    I am a bit concerned about the tone of the developers here. Its a bit of an elitist attitude. Lets look at the brochure for 3.0 Hardware-Accelerated 3D Graphics: Strong support for OpenGL and DirectX brings Windows’ vast library of 3D-intensive applications to the Mac. Without leaving their Mac desktop, users can play popular Windows-only 3D games such as Quake, Half-Life 2, and World of Warcraft, as well as work with complex Windows-only 3D CAD programs.
    Do the developers believe the buyers of their program should expect that they can actually play, Halflife, Quake, World of Warcraft. Additionally the marketers used the term strong support. Would any of the reviewers here consider this strong support?
    People realize you have been misled. I say this to the developers because you do have a competitor now in VMWARE. I would strongly suggest you reconsider how you are treating the users here and misleading them. History generally doesn't bode well for companies that conduct this practice. It would have been better to simply state we are developing 3d support and have a first generation with limited game support and limited playability vs the terms used here.
    Just a thought.

    PS how to do we get a refund for 3.0 if it doesn't work as advertised?
     
  6. iFrodo

    iFrodo

    Messages:
    21
    AFAIK, and if you really mean only these games, they work. I've personnaly tested Quake 3 and it works fine.

    Indeed, the sentence is wrongly turned, as there is indeed a strong support of OpenGL (all what I tested that use OpenGL, does work and work well), but not at all of Direct X which is ony a LIMITED Direct X 8.1 support (as stated correctly in the release notes).

    EDIT: As of Direct X, at least 3D Mark 2001 (which purpose is to benchmark Direct X 8.1) works, from what I've tested... So the support of "limited" direct x 8.1 is indeed delivered ;)
    Also I played at the demo of Sam&Max Culture SHock, and it run ok without any graphics issue.
     
    Last edited: Jun 9, 2007
  7. Morgenl

    Morgenl

    Messages:
    22
    Windows 95/98 legacy puzzle games such as Myst and Dracula will now play in conversion mode in Windows XP with DirectX enabled. Sound quality varies. Motion alternates between smooth, jerky and carreening about - but games are playable.
     
  8. Kender

    Kender

    Messages:
    2
    System Specs: iMac C2D 2.33ghz - 2 gig of RAM, 256mb w/ GeForce 7600GT (256mb)

    I'll try your tweaks and see if they work. Thanks!

    DX: Checked. Yup.

    RAM is set to 1gig (out of 2) and VRAM is now at 64mb.

    CoH: "Your card or driver doesn't support GL_NV_vertex mode" (even after the tweaks. :( )
    R6 Vegas: I get the startup movie, then it just craps out. (Vegas requires 128mb of VRAM, I guess. Silly game)
    NWN2: "Could not find any compatible Direct3D devices - The Application will now exit."
     
  9. crag

    crag

    Messages:
    38
    Not what their website says. Must I cut-n-paste the copy again dippyskoodlez? I get the impression that you either work for SWSoft or someone there is blowing you. Cause you like the only defender running from thread to thread defending the company with lame excuses.

    If the software was not ready for prime time then they should've said so. Not released a piece of crap filled with promises and beta test it on us. After we paid.

    Oh and what game works? Half-life on their list doesn't. Oh sure it loads but you get like 2FPS. Not excatly playable.
     
  10. dippyskoodlez

    dippyskoodlez Bit Poster

    Messages:
    88
    [​IMG]
     
  11. crag

    crag

    Messages:
    38
    Well, you do. That much is obvious. So what games work?
     
  12. ricka

    ricka Bit Poster

    Messages:
    13
    Wow, thanks everyone for chiming in on this thead. Based on your feedback and my own issues with bootcamp I have asked for a refund of my "upgrade" fee. The link for refunds is here per Tim of Parallels.

    http://www.parallels.com/support/request/

    --Rick
     
  13. voidptr

    voidptr

    Messages:
    3
    Under XP:

    Half Life - Seems to work ok.

    Starcraft - Installs, runs, but the color palette is all screwed up and unplayable.

    Total Annihilation - Same as Starcraft. Tried enabling 256 color palette and Win 95 on the compatibilty tab, but it's still screwed up. Parallels doesn't seem to handle switching to 256 color vga modes correctly.
     
  14. dippyskoodlez

    dippyskoodlez Bit Poster

    Messages:
    88
    Games I have tested:

    C&C RA series
    AOE II
    MOHAA+Expansions
    Unreal Tournament

    Known not working:
    NFSMW (This is a hard game to play as its prettymuch full DX9 shader wise) and TBE.


    I haven't tested others yet, because I -work- and others I don't own.

    Pretty much anything Q3 based works great.

    The sign was for your endless whining and complaining you didn't get what "they promised". Stop the thread crapping, its annoying and a waste of bandwidth, noone wants to hear your crap.

    edit: also note, this is inside of windows Vista.

    Do note, most of the above games aren't even on their list. I infact, got MORE than promised. What do you have to say about that?
     
  15. buddhak0n

    buddhak0n

    Messages:
    5
    Yep I'm working on this one as well... LOTRO... Once I tweak it so it works.. I'll let you folks know.

    Ok the Lord of the Rings Online seems to want to run under Parallels it just is running into Direct X problems I guess...

    What happens is the initial login screens go fine but no matter if you set it to 640X480 or whatever resolution when it pops up a window to display the game itself you get nothing but whitespace.... however the sound is playing in the background and the game is proceeding as normal ( for instance you can enter your way thru the DVD intro and into the Character selection screen however the video is obviously not rendering so you can't see what you are selecting... I've even gotten into the game itself but obviously it's unplayable since it's only a white screen...)

    any suggestions on how to tweak it to try and get it to display some pixels... anything at all would be greatly appreciated... I'm in the process of tweaking around some the userpreferences settings to see if possibly I might stumble onto something since this is primarily the ONLY thing that I use my windoze box for and if I can get it to run on my Macbook Pro 2.33 dual 2GB etc etc...... I can say goodbye to wintel dozers for a bit.
    :D
     
    Last edited: Jun 9, 2007
  16. buddhak0n

    buddhak0n

    Messages:
    5
    Eh I CARE... Especially if I consider myself to have been defrauded <g>.

    Nobody Cares? that's ridiculous. Just like you're not allowed to come down my street and steal 100 bucks out of my car. You're not allowed to advertise a product and say it'll do one thing and then have it completely not work for what it was designed to do...

    I'm not saying I wouldn't give somebody an opportunity to fix the problem.. but let's get real...

    NOT ONLY Didn't I get something that worked... I ordered mine though the Apple store so Guess what? I got doinked for the 79 from them when they sent me build 3188 .. yeah that's right a week after release of the newest build oh and then when I get to parallels website... they charge me AGAIN for an upgrade to a software package that should've been sent to me as the correct version the FIRST time and THEN on top of that all.

    The stuff doesn't work ... Now I'm not at the point that I'm like give me MY MONEY ... give me MY MONEY... but let's get real..

    Who Cares? Well federal authorities who prevent fraud care .... LOL that's who.
     
  17. buddhak0n

    buddhak0n

    Messages:
    5
    Let's Get serious.

    And seriously guys... did you even TEST this software before you sold it...

    When I try to do something as simple as play a simple Video in VISTA under it , it says it can't... I'm not talking about some amazingly complicated 3D rendering in some state of the art cuttting edge video game that requires major resources and all kinds of technical know how on behalf of the developers at parallels.

    I'm talking about a 10 second video of a bear jumping around in a river with a couple of fish .... Hilarious... who told you guys to release this stuff?
     
  18. engyew

    engyew

    Messages:
    39
    Trying to run MapleStory (for my daughter), get the message:

    Failed in finding proper screen mode for Gr2D


    The Support FAQ for MapleStory at http://www.maplesea.com/support/technical.aspx says:


    Gr2D_Dx81.dll error

    There are 2 common causes of "Gr2d" dll errors.

    a) Gr2D_Dx81.dll
    b) "Failed in finding proper screen mode for Gr2D"

    Gr2D_Dx81.dll
    For Gr2D_Dx81.dll errors, please update your DirectX version to the latest. You can obtain the installation file from this link

    "Failed in finding proper screen mode for Gr2D"
    To fix this error, please install the video card driver that the manufacturer provides and not the default Microsoft version. ......

    --------------------------------------
    Retraction:

    OK MapleStory works well. I did not turn DirectX support on. According to my daugther MapleStory works well on my MacBook - faster than the old Dell she's using! lol! I gues thats good. Thanks Parallels.

    :D
     
    Last edited: Jun 9, 2007
  19. Wick3d

    Wick3d

    Messages:
    3
    Well first off I got off pretty lucky because I forsaw something like this happening, so I waited and d/led the trial version when 3D support came out, so I am not in a rage about money. The rest of you have a reason to be angry, but you are blowing it way out of proportion.


    I am going to laugh hysterically when everyone refunds their product, only to have a patch solve their problem a week later. Give the stupid update some time and it will work.


    As for games, I played Guild Wars on lowest quality and it was pretty much unplayable due to the fast paced nature of pvp. As this is a popular game, I fully expect that things will be ironed out in due time and that I will be able to play.

    Guys, do you really think that the producers were trying to scam you? If you are freaking out about this, put yourself in their shoes. They are not game testers, most of them probably never game at all. You cannot expect them to try every last title on the face of the earth. If you read around, you will find out that they have a list that will be UPDATED as more games become playable. So I highly recommend that you all hold back on the refunds for awhile.
     
  20. engyew

    engyew

    Messages:
    39
    dxdiag in Parallels says:

    DirectDraw Acceleration: Not Available
    Direct3D Acceleration: Not Available
    AGP Texture Acceleration: Not Available

    Notes:

    The file PrlVideo.dll is not digitally signed, which means that it has not been tested by Microsoft's Windows Hardware Quality Labs (WHQL). You may be able to get a WHQL logo'd driver from the hardware manufacturer.
    DirectDraw test results: All tests were successful.
    Direct3D functionality not available. You should verify that the driver is a final version from the hardware manufacturer.


    I guess that means Direct3D doesn't work.

    btw. I have DirectX 9.0c (4.09.0000.0904)

    ------------------------------
    Retraction: OK. It does work. I just have to turn DirectX support on (which is off by default)
    :D
     
    Last edited: Jun 9, 2007

Share This Page