Parallels 3.0 Not Working in Leopard 10.5

Discussion in 'Installation and Configuration' started by rempe00, Oct 26, 2007.

  1. Xenos

    Xenos Parallels Team

    Messages:
    1,547
    Hello Herve S.,

    The actions you are going to undertake are absolutely correct and safe.

    Best regards,
    Xenos
     
  2. Eru Ithildur

    Eru Ithildur

    Messages:
    1,954
    Yes, it is safe to go to a Beta, just be forewarned that at times the Betas have been known to cause serious headaches in day to day use.

    It sounds like you are the correct sort of person to be using a Beta, that is, you are going to keep back-ups, and you are prepared to regress on back to an earlier version.
     
  3. Father Fil

    Father Fil

    Messages:
    2
    Parellels runs fine, it's just everything else that's broken.

    My Parallels (5160) on Leopard seems to behave a little differently from most.

    I run Parallels fine with no errors. It's when I try and launch other apps on the mac after I've launched Parallels that it all goes wrong. The apps look like they launch, the icons bounce in the dock for an eternity and nothing comes to the screen.

    Any apps that were running before I started Parallels behave normally.

    I can't quit or force quit anything, nor can I shutdown/restart normally - I actually have to power off the mac completely. Which obviously isn't ideal.

    A few people have suggested disabling Spaces first and then running Parallels so I'm going to give that a go later on.
     
  4. Oriontool

    Oriontool

    Messages:
    5
    I spoke too soon!

    It worked yesterday just fine. I turned on my Macbook this morning and I am getting the "Parallels has quit unexpectedly" error.

    Any suggestions? Please!

    TIA...

    Vern
     
  5. mysticorp

    mysticorp

    Messages:
    4
    Turn off Internet Sharing

    I was having all sorts of problems after uninstalling, when I went to reinstall the installer was hanging. After a bit of troubleshooting, I discovered that the preflight script for the Installer turns on Internet Sharing. On my particular Mac, the settings were all screwy and that caused Internet Sharing to hang. I turned it off and viola! the Installer worked.

    So I might check that if you're having any problems with the Installer hanging.
     
  6. Father Fil

    Father Fil

    Messages:
    2

    Just to report back in case it helps anyone else - disabling spaces did the trick. Parallels runs alongside other applications! :)
     
  7. nosodualie

    nosodualie Bit Poster

    Messages:
    27
    I also got the error where Parallels can't allocate memory to the display. I disable my second display and it more or less fixed the problem, though Parallels is still not completely stable as it hanged when installing Tools. After a few force quits and restarts I managed to get it working again.

    MBP 2,4GHz, 4GB, WinXP, Parallels Build 5540
     
  8. Oriontool

    Oriontool

    Messages:
    5
    Spaces???

    Looks like Spaces was the culprit. I turned it off and now Parallels is working.
     
  9. tcapoccia

    tcapoccia

    Messages:
    6
    The major problems I have experience on my MacPro with Parallels in both 5160 and the new beta have been solved by turning off "Time Machine"--especially the slow performance of Parallels.

    By the way I am running the Beta right now, which works better than 5160 did.

    Tony
     
    Last edited: Oct 30, 2007
  10. MicroDev

    MicroDev

    Messages:
    122
    It seems that PWS does not like Spaces either. I experienced a CTF and subsequent launches resulted in a hung system. Later launches started to complain about "Unable to allocate memory to the virtual monitor." When PWS was shutdown and relaunched it resulted in a kernel panic. This was the reported error at reboot (partial):

    No mapping exists for frame pointer
    Backtrace terminated-invalid frame pointer 0xd5d54ef8
    Kernel loadable modules in backtrace (with dependencies):
    com.parallels.kext.vmmain(3.0)@0xb85000->0xb94fff

    BSD process name corresponding to current thread: Parallels

    Turning off Spaces (Time Machine was already off), finally allowed the VM to open again. When the VM is started in full screen mode, the problem is more prevalent. When the VM is started in a windowed mode, it seems more stable. Not a scientific conclusion to be sure, but one that clearly points to memory issues between PWS and Leopard.
     
  11. moas

    moas Bit Poster

    Messages:
    18
    Still SOL

    Looks like different people have different solutions that appear to work. I've reinstalled (after documented clean uninstall) a number of times, turned off spaces (rebooted), turned off Time Machine (rebooted) and nothing seems to work...

    Looks like a complex issue.
     
  12. mediamacros

    mediamacros

    Messages:
    2
    Spaces = Bad Mojo

    Spaces seems to be the culprit for me too. All works well without, but if I turn on spaces, any Mac OS app after parallels never opens and bounces forever. No force quit, etc. You have to hard reboot to get everything back. Spaces is one of the main reasons I upgraded to Leopard, so I personally would love to see a fix for this as soon as possible!
     
  13. Xenos

    Xenos Parallels Team

    Messages:
    1,547
    Dear all, please look at the list of the known issues and workarounds for the current builds of Parallels Desktop with Leopard.

    Spaces issue is under serious investigation. Thank you for your reports.

    Moas, we are analyzing your problem. It’s not similar to others. I’ll let you know as soon as I get the information from our developers.

    Best regards,
    Xenos
     
  14. jkajfes

    jkajfes

    Messages:
    7
    I had the same problem this morning with this.... bouncing icons... wouldn't quite. I'm very new to Macs... so I really don't know much on how to trouble shoot them. I know if you don't shut things down properly in windows it causes a shit storm with closing files and a bunch of other things.. so I just didn't want to power it down.

    all I did was eject TimeMachine and then Mac then started shutting down?

    If I elect to install the beta... is the Timemachine thing enough of a backup thing to really restore things if something goes haywire?
     
  15. jkajfes

    jkajfes

    Messages:
    7
    I forgot to add it's nice to see some of the Parallels tech folks participating here. I bought the program about a week ago and it never dawned on me to wait until after Leopard was released. I just had heard a lotta folks talking about how you could run windows inside of the Mac o/s... heck I haven't been able to run it properly outside it for ten years so I thought maybe....

    I bought an external bootable firewire hd, copied the Tiger and Boot Camped windows that has been running perfectly for a few months and then installed the Leopard after making sure I really could boot the Tiger on the external drive...

    I find the macs seriously interesting... you'll get no noise from me as an x windows user... the only reason I'm running anything windows wise is because I'm new and the cost to replace some software... most of the time now I'm discovering I didn't need half that crap in there in the first place...
     
  16. kmacard

    kmacard Bit Poster

    Messages:
    50
    Parallels now working OK in Leopard

    Parallels was NOT working well for me in Leopard and crashed my computer so I needed to reinstall the OS.

    At any rate, I followed the instructions given here and at this link: http://forum.parallels.com/showthread.php?p=87017#post87017

    1) I uninstalled Parallels using the Terminal commands given.
    2) After rebooting, I installed MacFuse: http://code.google.com/p/macfuse/downloads/list
    3) After rebooting again, I reinstalled Parallels Build 5160
    4) I also disabled Leopard's Spaces.....Too bad! I love that feature!

    So far, anyway, it all seems to be working just fine with no slow down in Parallels and no problems with my Mac apps. I'll keep my fingers crossed it continues until Parallels can get this fixed.

    Thanks to the Parallels folks for being on top of it and monitoring this forum!

    Kathy
     
    Last edited: Nov 1, 2007
  17. Xenos

    Xenos Parallels Team

    Messages:
    1,547
    jkajfes, you can save your 5160 VM folder on any data storage and come back to it when you wish.

    Thank you everybody for understanding and support. The free update with the bugs fixed is coming soon.

    Best regards,
    Xenos
     
  18. moas

    moas Bit Poster

    Messages:
    18
    Beta 5540 - no luck

    I tried to upgrade to 5540 beta. Same issue.. "The application Parallels Desktop quit unexpectedly."

    System Config follows: (can't attached the problem details - too big for upload limit)

    Model: MacPro2,1, BootROM MP21.007F.B06, 8 processors, Quad-Core Intel Xeon, 3 GHz, 10 GB
    Graphics: kHW_NVidiaGeForce7300GTItem, NVIDIA GeForce 7300 GT, spdisplays_pcie_device, 256 MB
    Graphics: kHW_NVidiaGeForce7300GTItem, NVIDIA GeForce 7300 GT, spdisplays_pcie_device, 256 MB
    Memory Module: DIMM Riser A/DIMM 1, 512 MB, DDR2 FB-DIMM, 667 MHz
    Memory Module: DIMM Riser A/DIMM 2, 512 MB, DDR2 FB-DIMM, 667 MHz
    Memory Module: DIMM Riser B/DIMM 1, 512 MB, DDR2 FB-DIMM, 667 MHz
    Memory Module: DIMM Riser B/DIMM 2, 512 MB, DDR2 FB-DIMM, 667 MHz
    Memory Module: DIMM Riser A/DIMM 3, 2 GB, DDR2 FB-DIMM, 667 MHz
    Memory Module: DIMM Riser A/DIMM 4, 2 GB, DDR2 FB-DIMM, 667 MHz
    Memory Module: DIMM Riser B/DIMM 3, 2 GB, DDR2 FB-DIMM, 667 MHz
    Memory Module: DIMM Riser B/DIMM 4, 2 GB, DDR2 FB-DIMM, 667 MHz
    AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x87), Broadcom BCM43xx 1.0 (4.170.25.8)
    Bluetooth: Version 2.0.0f20, 2 service, 1 devices, 1 incoming serial ports
    Network Service: Parallels NAT, Ethernet, en4
    Network Service: Parallels Host-Guest, Ethernet, en3
    Network Service: Ethernet 1, Ethernet, en0
    PCI Card: NVIDIA GeForce 7300 GT, display, Slot-4
    PCI Card: NVIDIA GeForce 7300 GT, display, Slot-1
    Serial ATA Device: ST3500630AS P, 465.76 GB
    Serial ATA Device: ST3500630AS, 465.76 GB
    Parallel ATA Device: PIONEER DVD-RW DVR-112D
    USB Device: hub_device, high_speed, 500 mA
    USB Device: Griffin PowerMate, Griffin Technology, Inc., low_speed, 500 mA
    USB Device: Apple Cinema HD Display, Apple Computer, Inc., full_speed, 500 mA
    USB Device: hub_device, high_speed, 500 mA
    USB Device: Microsoft Trackball Explorer®, Microsoft, low_speed, 500 mA
    USB Device: Apple Cinema HD Display, Apple Computer, Inc., full_speed, 500 mA
    USB Device: Bluetooth USB Host Controller, Apple, Inc., full_speed, 500 mA
    FireWire Device: built-in_hub, unknown_value, unknown_speed
    FireWire Device: unknown_device, unknown_value, unknown_speed
     
  19. txmac

    txmac

    Messages:
    1
    Parallels 3.0 Not working in Leopard

    I too had issues getting parallels 3.0 build 5160 to work after upgrading to Leopard. I tried installing a new version of MacFuse that was mentioned, but that did not work. I also tried re-installing Parallels but no luck. I uninstalled MacFuse and decided to wait for a fix from Parallels. While reading more posts on this thread, there was one that stated that turning off spaces fixed his problem. I had spaces running and turned it off and lo and behold my parallels started working again. I had also turned off file sharing too. I have not had any issues with using my parallels since. I'm running an Imac 20in 2.16 gzh with ati 256 video ram and 2 gig of memory. Hope this helps someone. I don't remember seeing turning off spaces in the parallels post that list all of the possible work arounds.
     
  20. kevinvh@mac.com

    kevinvh@mac.com

    Messages:
    61

Share This Page