Parallels 4 almost worked -- but I downgraded to 3.0 (5608)

Discussion in 'Installation and Configuration' started by MartinBear, Nov 12, 2008.

  1. MartinBear

    MartinBear

    Messages:
    26
    What a strange and time-wasting experience.

    1. I backed up my Parallels VM (I used Disk Utility to image the Parallels folder), and made sure I had my old v3.0 activation code standing by.

    2. Started the upgrade to Parallels 4.
    a. successfully converted the VM to the new format
    b. mid-way through step 2, something went wrong that left a brief message that the upgrade couldn't continue.

    3. What the hell: nothing to lose so I shutdown the VM, rebooted the Mac, and re-started Parallels. To my surprise it continued to install for a while, then ran out of steam. So, shutdown VM and reboot. Continued to the point of loading the "Irish Meadow" background and finally gave me some mouse control inside the VM window.

    4. Read through all the "troubleshooting" web pages, but my situation isn't covered. In the meantime, installer finished step 4 (install Parallels Tools) and said it was now configuring the VM.

    5. I left the install process to do its thing overnight (Activity Monitor clearly showed lots of work, and every now and then the Windows cursor would change shape, or a message like "Found new hardware" would appear and disappear. In the morning, still not done. But, enough of WinXP was up that I could my desktop icons, use them to run a few programs (like a mapping package), but all in a small window, with no "Start" menu, and other weird effects.

    6. Finally, I ran out of patience and needed to get some work done. Stopped the VM. Deleted the *.pvm file. Uninstalled Parallels 4. Rebooted. Copied saved v3 VM files back to the Parallels folder. Installed Parallels 3 (5608). Rebooted. And, hey presto, we're back to a working version of Windows.

    My conclusion: this product is ready for a "public beta" (which is what is happening out there, even if that isn't what Parallels intended), but it isn't ready for release as a working product.
     
  2. BerbBrown

    BerbBrown

    Messages:
    7
    I experienced exactly the same and I am bitterly disappointed. I remember this happening from version 2.x to version 3. It is as if Parallels are rushing the release out before fully testing the product.

    I rely on Parallels because I developed Windows based .NET apps as well as Mac stuff. I don't have the time to spend fault finding.

    Not impressed.
     
  3. robatl

    robatl

    Messages:
    2
    Same Problem

    I had exactly the same problem.. It failed while converting my XP image.. I restarted it and it ran overnight (with no apparent progress)...

    Am reverting to the old version now...
     
  4. hmatos

    hmatos

    Messages:
    1
    While I was able to upgrade ... the minute I try to use my keyboard in ANY windows application, it locks up the VM. What a total waste of time.
     
  5. rbdamm

    rbdamm

    Messages:
    12
    Sorry to hear that... I upgraded both XP and Vista on mine... Vista required the original CD in order to continue the upgrade... Seems all is working well. Not sure what people are doing wrong really...
     
  6. how do you get back to parallels 3? i dont see an uninstall option or revert option so im assuming i have to delete parallels altogether and then reinstall 3 with my original CD? how would i do this?
     
  7. mkstevo

    mkstevo

    Messages:
    40
    I opened the .dmg package for Parallels V4, this had an 'uninstall' icon. Clicked this and (to its credit) V4 was gone! Reloaded V3 and clearly the uninstaller had been able to restore my Windows XP disk and setup files to the correct locations as they worked immediately. Only had to load Parallels Tools for V3 once XP had started and I was back in business.

    Best bit of V4 was the uninstall. It made me smile after all my anger, I almost felt guilty for calling it rude names...
     
  8. Humboldt

    Humboldt

    Messages:
    4
    I, too, have this problem. Any touch of the keyboard and Parallels 4 locks up (spinning beach ball of death). Further, it takes about 4 times longer to boot Windows XP in version 4 than in version 3. There's also a performance hit on my host machine, a Macbook Pro, which takes far longer to start up and shut down for some mysterious reason. The long phone queues for support are ridiculous.

    I've downgraded to Version 3 and, once again, have good performance of both the host machine and the virtual machine.

    I will wait until there's another release of version 4 before trying to upgrade again.
     
  9. where was the .dmg file i cannot find that part?
     
    Last edited: Nov 13, 2008
  10. mkstevo

    mkstevo

    Messages:
    40
    Sorry, perhaps I wasn't accurate, I opened my downloaded file (in my case Parallels-Desktop-4.0.3522.205912.dmg) and that was where I found the undelete icon.
     
  11. yoavhacohen

    yoavhacohen

    Messages:
    5
    I also downgrade to parallels 3. Parallels 4 is not tested enough.
     
  12. John@Parallels

    John@Parallels

    Messages:
    6,343
    Update was published , which is right now available at http://forum.parallels.com/showthread.php?t=31764
    The most of problem were fixed.
    Please navigate to that link, and download build 3540
    In post there are various instructions, how to fix problems.
     

Share This Page