Parallels 4 Team Fortress 2 Works Nicely

Discussion in 'Installation and Configuration' started by RedHerring, Nov 12, 2008.

  1. RedHerring

    RedHerring

    Messages:
    10
    I have tried a few steam games, Penny Arcade 1, Team Fortress 2, Left 4 Dead Demo.

    PA1, and TF2 works great.


    L4D however does not. The screen size is set to 640x480 and displays nothing, but the mouseover sounds work when you mouse around and wander over a button. The lead in video works, but after that you have to force quit.

    I am impressed with the team fortress 2 performance, seems as good as crossover games. I will "test" some more...

    I downloaded some DirectX 9.0c Shader 2 screensavers to exercise Parallels 4, and they work, but when they run, they reduce the size of the screen to 640x480 from whatever it was ( I usually run 1280x800 ) just like L4D does.

    strange.

    MacBookPro early 2k8 2.5ghz C2D 15.4" 4GB - Parallels 4 Clean XP Pro sp3 2GB 2 cores 256MB video shared net, Upgraded from Parallels 3. Seems to be working to spec.
     
    Last edited: Nov 12, 2008
  2. HappyPappy

    HappyPappy

    Messages:
    2
    Yeah, I tried counter-strike and it gives a "failure to lock" something or other.

    Can you share your TF2 settings since I tried it on mine and it's been choppy even at 640x480.

    I have a Mac Pro Quad with 2.66 CPUs and an NVIDIA 6880 so I would expect somewhat better performance.

    Thanks.
     
  3. HappyPappy

    HappyPappy

    Messages:
    2
    640x480 and even 800x600 appears to work well as long as I dumbed the settings way down (no details, no anti aliasing, etc...)
     
  4. Trevor Harmon

    Trevor Harmon Bit Poster

    Messages:
    2
    How were you able to achieve this? My setup and hardware are similar to yours, but Team Fortress 2 is substantially slower in Parallels 4 than in CrossOver Games. I also have problems running it with Parallels in full screen mode.

    Did you tweak any settings in Parallels or TF2? And what about antialiasing support? I couldn't get antialiasing turned on in Parallels. (Can't turn it on in CrossOver Games either.)
     

Share This Page