Parallels 4124 broke Cisco VPN 4.9

Discussion in 'Parallels Desktop for Mac' started by eyamanak, Jun 7, 2007.

  1. charp07

    charp07

    Messages:
    2
    Paralles upgrade-ver 4124 and Cisco VPN 4.9

    I am having the same problems... I tried reinstalling the Mac Cisco VPN 4.9 and ran into the same problems... please provide a solution... :(
     
  2. atodedeus

    atodedeus

    Messages:
    1
    fw0 down works

    Well, after trying nearly every permutation mentioned on this and other threads, taking the fw0 interface down finally solved my problem with the Cisco VPN client. Can anyone explain why this interface (and not the others) is the culprit?
     
  3. suhr

    suhr

    Messages:
    5
    This is exactly the same thing I did to fix my problem. Worked for me as well.
     
  4. freakymac

    freakymac

    Messages:
    17
    I tried every thing that has been listed in this thread and the only thing that worked for me is:

     
  5. MicroDev

    MicroDev

    Messages:
    122
    Confirmed 4124 breaks Cisco VPN but VMWare does not

    Bottom line, installing 4124 will break most existing Cisco VPN installations. At the very least, it is a crap shoot if it will continue to work or not.

    Re-installing the Cisco software did not fix the problem in my case. I also tried the old fixes but it appears they are already in place in the /Library/StartupItems/Parallels/Parallels configuration file and it made no difference anyway. Restarting the interface also did not work, and disabling the Parallels host adapter did not work either.

    To be extra sure, I rebooted in between each install and re-install and I tried installing Parallels 4124 and then Cisco after removing both - still no joy - error 51.

    What does work flawlessly is the VMWare installation and Cisco VPN regardless of install order. Having thrown my hands up in desperation with PWS over this ongoing issue (since pre-beta2) VMWare seems to be a valid alternative for the interim.
     
  6. gounu19

    gounu19

    Messages:
    1
    Works for me as well

    sudo ifconfig fw0 down

    Added this to my VPN startup script (as instructed above) and now it works great.

    Here's what I did....

    #!/bin/sh

    . /etc/rc.common

    # No arguemnts, print usage
    case $# in
    0)
    echo "Usage: $0 {start|stop|restart}"
    exit 1
    ;;
    esac


    CISCO_VPN_DIR=/System/Library/Extensions/CiscoVPN.kext

    StartService ()
    {
    sudo ifconfig fw0 down
    if [ -d $CISCO_VPN_DIR ]; then
    ConsoleMessage "Starting Cisco Systems VPN Driver"
    kextload $CISCO_VPN_DIR
    fi
    }

    StopService ()
    {
    if [ -d $CISCO_VPN_DIR ]; then
    ConsoleMessage "Stopping Cisco Systems VPN Driver"
    kextunload $CISCO_VPN_DIR
    fi
    }

    RestartService () { StopService; StartService; }

    #
    # Load the VPN Driver here
    #

    if [ -f /var/run/resolv.conf.vpnbackup ]; then
    mv /var/run/resolv.conf.vpnbackup /var/run/resolv.conf
    fi

    # OS X 10.2 has /etc/rc.common:RunService() for this, but 10.1 does not
    case $1 in
    start) StartService ;;
    stop) StopService ;;
    restart) RestartService ;;
    *) echo "Usage: $0 {start|stop|restart}" ;;
    esac
     
  7. rjgebis

    rjgebis Kilo Poster

    Messages:
    186
    I have same problem. I can connect for few sec than I get that my connection was terminated locally. Any ideas? I am on version 3 Parallels
     
  8. martinm

    martinm

    Messages:
    8
    same issue here. Bringing down fw0 and adding the required line to the vpn_startup script fixes the issue for me.
     
  9. moraga695

    moraga695

    Messages:
    1
    My Cisco VPN Works Again!

    Version 4124 broke my Cisco VPN too. Thanks to SPUD (post #34) who found the FW0 problem and Barber199 (post #37) who provided the entry for the Cisco VPN startup script, all is well again!

    I've downloaded the update version 4128 but can't find what's changed from 4124. Does anybody know if it stops breaking the Cisco VPN client?

    Thanks.
     
  10. iduff

    iduff Product Expert

    Messages:
    235
    I have 4128 running, along with 4.9.0.1 (0030) in OS X, and now I can get to hosts inside the VPN from within the XP VM. Pretty cool. No need for a VPN client in the VM, as the OS X side now supplies VPN functionality to the VM. Didn't used to be able to do this.
     

Share This Page