Parallels 6: BSOD with Window 7 64

Discussion in 'Windows Guest OS Discussion' started by Stephen Blaising, Sep 13, 2010.

  1. StephenA

    StephenA

    Messages:
    36
    Problem report: 6811874

    My memory dmp file is over 280MB, how do you want me to get this to you?
     
  2. STim

    STim Super Moderator

    Messages:
    945
    Thank you.

    Can you try setting your virtual machine vCPU number to 1 and work this way for some time? Please tell us if it will decrease the frequency of BSODs.

    Can you associate BSOD with some specific action that you do? Say, it mostly happens when you start Windows, or start some program, or perform a specific action? Or is it just random?

    I will send upload instructions as a private message shortly.
     
    Last edited: Oct 5, 2010
  3. StephenA

    StephenA

    Messages:
    36
    Update: it has been about 6 days since changing from 2 CPUs to 1 CPU, and so far no BSOD! Yay :) Now just need a fix for the mouse scrolling issue...
     
    Last edited by a moderator: Oct 12, 2010
  4. Dave Wells

    Dave Wells

    Messages:
    14
    problem started with Windows 7

    I was running Windows XP with no problems, then recently created a new container and installed Windows 7 and all my applications, then migrated all my data and settings. So far, it seems that I only get the BSOD when I have Kaspersky running, since I changed the setting so it doesn't start automatically.
     
  5. DHKaplan@mac.com

    DHKaplan@mac.com

    Messages:
    9
    I am periodically getting the same error on Win XP SP3 and have created a problem report (sorry I don't have the number).
     
  6. Robert Sutter

    Robert Sutter Bit Poster

    Messages:
    6
    Solution that seems to work!

    It seems that my situation was likely due to using Kaspersky and it creating a conflict with Parallels tools drivers.
    Here's what I did:

    0. BACKUP VM
    1. Deleted Kaspersky using Windows uninstaller
    2. Reboot
    3. Had to manually delete the Kaspersky application folders by searching for "kaspersky" and manually deleted and trashing the folders
    4. Reboot
    5. Deleted Parallels tools using Windows uninstaller
    6. Reboot
    7. Had to manually delete the Parallels tools application folders by searching
    8. Reboot
    9. Windows came up with errors and ran scandisk...... found .dll issues and corrected
    10. Reboot
    11. All of the above was while using the ORIGINAL build of Parallels desktop 6 NOT build 11822.
    12. Install Parallels desktop 6 build 11822 on the mac side
    13. Set to 1 cpu
    14. Boot up VM and install new parallels tools
    15. Use ONLY the Kaspersky version that came with build 11822 (KIS 11.0.1.410). Note: The standard Kaspersky upgrade from their website gives you 11.0.1.401 which CRASHED the VM and I had to re-do everything above (steps 1-14) using my backup VM.

    It's been 3 days and no blue screen or freeze and the VM works MUCH faster than before.... exceptionally faster and more responsive.

    Good luck to all of you that are still having issues!
     
  7. megavolt17

    megavolt17 Product Expert

    Messages:
    367
    I get BSODs and an equal number of "Windows Failed to Start" errors - really frustrating. When Windows 7 does not start Windows offers to restore from a previous point, then scans for errors, and finally when it can't find anything that it can fix it shuts down Windows 7. I can then restart Parallels 6 and it will boot with no problem, then pop up something stating that Windows did not start the last time and and asking if I want to look for a solution (which it can not find).

    I can run Windows 7 from Boot Camp fine, and have started doing that more than running Parallels 6. I've posted several reports using the Parallels menu but nobody has asked for additional information (7108716 was my latest submission). This started happening more frequently after the most recent Parallels 6 and Windows update.

    Windows 7 Professional, 64 bit. MacBook Pro i7 with 8GB ram.
     
  8. adanguspf

    adanguspf Bit Poster

    Messages:
    29
    In other threads, I've mentioned a similar problem that I've had. Since I use Mcafee instead of Kaspersky, I'm not sure that Kaspersky is the source of the issue. I am running Parallels 6 and Win7. My first experience was with the just previous build of v6. The guest OS crashed hard during the installation of Parallels Tools. It blue screened, and also failed to start up. In this case, the native Win7 start-repair functions seemed to work. However, I could not get Tools consistent with that version to install; the process consistently died just after getting to the time synchronization functions and would then back out.

    I paid for a tech support call, and after a couple of hours, uninstalling and reinstalling, disabling and then uninstalling Mcafee, regedits galore, and downloads of the Tools files from obscure locations, the support guy simply had me fall back to the previous version. Now, when the latest build came out, I went ahead and did the install, got a blue screen along the way, but the machine came back up OK and Tools installed fine. I thought things were cool for a few days. The latest build appeared to work very well under OS 10.6.5, with Aero now functional, and an issue I'd had with Shared Folders also suddenly cleaned up.

    Then, I began to get obscure problems with various applications and system functions. For example, the Task Manager's performance functions would report invalid DLLs. Acrobat Distiller could not find its ICC profiles. A print utility called Quad Tone RIP began to fail. I ran a chkdsk function, and it reported problems with index $I30. Chkdsk ran, but file corruption reports continued. I tried uninstalling and reinstalling Acrobat about 5 times (really) and no matter how I executed the reinstall it would always report not finding ICC profiles. To some extent, this is a known problem if you don't install Acrobat as Admin, but I was aware of this and did the accepted procedure.

    Finally, I gave up and went back to an HDD image of my Win7 machine that I'd saved last September. In redoing my VM with this starting point, I got a working system without any problems installing the latest version of Tools with the latest build of v6. Of course, this older starting point was behind times in Windows updates. As it went through the process of bringing itself up to date, it crashed hard during the install of the most recent 8 or so Win7 security updates. This crash killed the guest OS and the host OS as well (Mac OS X 10.6.5 on a dual core iMac). After the host OS restarted, the guest OS was completely destroyed, and the internal boot repair functions could not recover it.

    Now, I'm lucky enough to have decent backups and at least one version of the VM that I can recover all my Documents from. Consistent with others in this thread, I have been running with the hypervisor enabled and 2 CPUs allocated to the VM. I haven't tried starting over with my September back up and hypervisor disabled, but based on what I've read here, I'm going to try that today.

    My expectation, given my own experience and what I've read here, is that there is some incompatibility between one of the recent Win7 security updates and the last two builds of v6, perhaps if and only if hypervisor is enabled. If starting over with my September build and hypervisor disabled seems to work (or not) I'll report this here.
     
  9. adanguspf

    adanguspf Bit Poster

    Messages:
    29
    OK, so I re-ran the update process on that saved HDD image. This time I disabled Hypervisor and set the VM to use only 1 CPU before and during the update process. This time everything ran OK. I got all of the Windows updates, all 20 or so. After getting the machine updated and stable, I then shut it down and re-enabled the Hypervisor and set the VM to 2 CPUs.

    As soon as I rebooted, I got a black screen saying that the file system had issues and that chkdsk had to run. I immediately stopped the machine, and set the VM back to 1 CPU and no hypervisor. I restarted and let chkdsk execute. As before, the complaint was with index $I30. I should point out that in every instance that I've been required to run a chkdsk in any configuration that I've played around with that the problem has always been reported at index $I30. However, the specific file number and files listed have differed.

    I've attached a screenshot of the chkdsk result. Clearly, the messed up files are critical items.

    My conclusion is that the problem is something to do with hypervisor/multiple CPUs, the last two v6 builds, and one or more of the recent Win7 updates. This saved HDD in question runs perfectly well with the latest v6 build and with hypervisor enabled and 2 CPUs. I can install the latest version of Tools with no issues. It is only when I bring it completely up to date with the Win7 security updates that I have issues, if hypervisor and 2 CPUs are enabled. I might note that I have not enabled the optional Windows Live update.
     
  10. Brian Spolarich

    Brian Spolarich

    Messages:
    4
    Similar problems here. Running the latest build of Parallels (6.0.11828) on OSX 10.6.5 with a Win 7 x64 Ultimate guest. 2CPUs and Adaptive Hypervisor enabled. I get regular BSODs (usually for a "memory management" fault), and sometimes just black screens that force me to reset.

    Based on this post, I've disabled adaptive hypervisor. We'll see if that helps. I'd hate to go down to 1 virtual CPU.

    This started a few weeks ago. Prior to that, the config was quite stable. I thought it was the 11828 release, so I downgraded one step, but I let 10.6.5 install, so I'm committed to 11828 now.
     
  11. James Rome

    James Rome Kilo Poster

    Messages:
    107
    1 CPU makes it too slow to use, so I hope this gets fixed. I have 8 cpus. I should be able to use at least 2. And 4GB out of my 16GB of memory. 6.0.11990 is no better either.
     

    Attached Files:

  12. Marktrapeze

    Marktrapeze

    Messages:
    2
    BSOD on Windows 7 - Parallels V6

    I have been having the same problem, frequent BSOD with memory Management Error. I was originally running 64bit and thought HP drivers were the culprit. I completely started from scratch with a new installation of Windows 7 32 bit and after 3 days of thinking I was home free, another memory management BSOD! My Xp VM never had this problem. After a paid service with Parallels they simply told me to run Windows diagnostics, then pestered me to close the ticket, then a few days later, more BSOD's. It's obviously a flaw with Parallels V6, I really hope they fix this, it's making work very difficult.
     
  13. adanguspf

    adanguspf Bit Poster

    Messages:
    29
    It seems that anything after build 11822 has issues. I eventually cured most of my problems by going back to that disk image and reinstalling Parallels. I also had to go back to a stored virtual HDD as well. Unfortunately, that HDD image had been run under several subsequent builds of Parallels v6, and become corrupted in subtle ways. For example, I continuously get an error that colorui.dll is not designed to run on Windows; and of course, that's a built in file. I even went to the lengths of doing a reinstall of Windows; but, probably because it wasn't a new clean install, not all of the issues were corrected. I got Registry Booster, and discovered nearly 2,000 registry errors; but even repairing all of those hasn't completely addressed my issues.

    My next step will either be an attempt to do a clean install of Win7 32-bit on a new VM, or just forget about Parallels v6 altogether. I'm not sure which right now. I have spent more time over the last couple of weeks with this than I can possibly afford.

    Of course, the sole reason for me bothering with any of this at all is that I use Win7 to run Intuit Quickbooks and TurboTax for my business. I cannot afford to have these systems destroyed, and that's what Parallels seems to be doing. Right now, I would gladly trade some performance for stability.

    To quote Ebeneezer Scrooge, "Bah, humbug!"
     
  14. James Rome

    James Rome Kilo Poster

    Messages:
    107
    Its a bug

    Parallels Level 2 says this is a bug and they are working on it. In the meanwhile, use 1 CPU :-(
     
  15. Marktrapeze

    Marktrapeze

    Messages:
    2
    I get multiple BSOD's a day running Windows 7, some are PFN list errors, others are memory management. I've created a new virtual machine from scratch in both 32 and 64 bit modes and still get the same issues. It's obvious to me from my experiences over the past few months and these posts that Parallels 6 has a serious problem with Windows 7. I've paid money for a support call with parallels and they told me to run Windows start disk recovery but it found no errors.I want to get a new mac laptop but now I'm hesitating as i need a stable Windows VR on it to justify. I'm on client calls and it crashes, I'm really really disappointed.
     
  16. adanguspf

    adanguspf Bit Poster

    Messages:
    29
    More of the same...

    I finally went back to v6.0.11822, for which I had the DMG from last September when I upgraded. After trying numerous reinstalls and rebuilds of Win7, to no avail, even with this version, I did a clean install of Win7 over my earlier HDD image. By this point, my HDD was subject to so much corruption that almost no application would run without failure. The straw that broke the camel's back for me was when I could no longer print PDFs of invoices out of Quickbooks. That destroyed my revenue stream for my small business.

    In any case, as I say, I did a clean install of Win7 and completely through away all vestiges of my old Win7 platform. This meant, naturally, having to reinstall every important application. In spite of this, which took a couple of days to completely bootstrap back to my essential applications (Quickbooks, TurboTax, Office 2010, Acrobat Pro Extended...) I continue to get CHKDSKs at start up. Last evening, I had put this rebuilt VM into suspend mode; and this morning, I found that Parallels was locked up and needed to be force quit. It is as if suspend doesn't mean suspend; maybe Parallels, so long as it is live, tries to do something to the VM image??? Anyway, yet another CHKDSK at reboot time.

    Invariably, CHKDSK complains about index $I30 in my case. I've attached a few images of the CHKDSK operation at boot time for reference. A clip might be more instructive, but you get the basic idea.

    Perhaps if I through the entire HDD away and started from scratch, as you you did, I might get better results. For me, this would involve going back all the way to XP, since my Vista and Win7 disks are just upgrades. I imagine that sooner or later, I'll attract the attention of Microsoft for how many times I've reactivated my stupid Win7 license.

    Meanwhile, I have another VM running XP on a laptop with Parallels v5.0.9376, and it has no issues at all. Imagine how likely I am to upgrade it to Parallels v6? Go on, guess. In spite of the poorer performance of that computer, I'm about ready to move all my bookkeeping over to it since v6 is a complete and utter nightmare of biblical proportions.
     

    Attached Files:

  17. DMiles

    DMiles Bit Poster

    Messages:
    25
    There might be a couple of different issues going on here. There was a serious data corruption bug between the last couple of builds (11990 and 11992 I think?) that would corrupt the VM when running Mac OS X 10.6.5 or 10.6.6. That's been fixed in build 11994, but I'm still getting an occasional BSOD every few days, and that's been a constant since Parallels 6 shipped. I'll try switching to 1 CPU to fix that, but come on Parallels... Since v6 came out, I've suffered 2-3 BSODs a week and two trashed VMs that required a complete rebuild thanks to the last two builds' corruption issues. A LITTLE quality control would be nice!
     
  18. Chri12345

    Chri12345

    Messages:
    12
    I've been running Win7 x64 since P6 came out; this is a new install - I was on XP/P5 previously. I have also upgraded to Win7 SP1 and P6 1194. At no point have I experienced any BSODs.

    Just dropping this note as a data point. There is something slightly different about the OP's setup, because for a fresh install, everything works out of the box (sans an assortment of bugs that you will find on these forums).

    I am almost afraid to post this message because maybe BSODs are infectious via forum usage! knocking on wood...
     
  19. DMiles

    DMiles Bit Poster

    Messages:
    25
    How many CPUs do you have the VM set for? From what I've seen Parallels post and from my own experience, I think the blue screens (and some kernel panics) are related to having a VM running with more than one CPU.

    I set mine to 1 CPU when I posted that Feb 23, and I haven't had a blue screen since. Of course, that also means I've had to run my VM on 1 CPU, which is far from ideal. But at least the thing doesn't crash a few times a week.

    I hope they fix the CPU thing sooner than later.
     
  20. Robertv

    Robertv

    Messages:
    3
    This is definitely very disappointing and obviously a huge problem for those of us who rely on these Windows machines. I had Windows7 64-bit and Parallels 6 running for quite some time. I even worked on it all day yesterday. However, last night I did the latest iTunes and today I have had only BSODs on boot. I cannot get into Windows at all, not even in Safe Mode. I have tried the aforementioned settings but have had no success.

    I have had no choice but to dig into the Windows drive, copy my important files out, and do my work on a computer at work. This is VERY frustrating...

    Mac OS X, Version 10.6.6
    2.4 GHz Intel Core 2 Duo
    4 GB 667 MHz DDR2 SDRAM

    Parallels 6, Build 6.0.11994
     

Share This Page