Parallels 6 - XP "upgrade" stuck at step 1 of 4

Discussion in 'Installation and Configuration' started by mrblog, Oct 2, 2010.

  1. mrblog

    mrblog

    Messages:
    11
    This may relate to the "Install Parallels Tools" problem, but it seems different.

    I'm converting an XP VM from PD 3.0 to PD 6.

    First problem is I tried to do a "back up and convert" and it said the disk didn't have space, even though it said it needed 105GB and the drive had about 800GB free. Tried several times. F-it. I went ahead and clicked "convert" without the backup.

    Seemed to be going well, then got to the point where it said I needed to login to continue the "upgrade". Ok, that worked, it got errors on the "Found new Hardware" screens and ultimately a "failed to install" window flashed on the screen, but then the XP VM was there (in VGA mode).

    It didn't really tell me what to do next, but I assumed it wanted the Parallels Tools. When I use the Virtual Machine -> Install Parallels Tools... menu, nothing happens. There is nothing attached to the CD/DVD drive, which is drive E: on this VM system. I manually uninstalled the old Parallels Tools. Then manually uninstalled AVG virus as per KB 8969 - no change. The CDROM just continues to show "Disconnected" and if I dry to open Drive E: in Windows XP, it says "please insert a disk into drive E:"

    This seems to be different than what KB 8969 is talking about, as the installation has not "failed" per se, it simply cannot start because the VM will not attach to the Parallels Tools windows installation CD image.

    So can I download the Parallels Tools CD image from somewhere or manually mount it?

    As it is now, the VM works, or seems to. I was able to change resolutions to what I wanted - it just doesn't have the shared drives etc from Tools and every time I boot it, Parallels says it is "upgrading" the VM step 1 of 4.

    I paid the $50 for the upgrade because I hoped it would be EASIER than just converting my Parallels VMs over to (free) VirtualBox VMs. I should have just done that instead of wasting the $50 on Parallels Desktop 6 - and of course wasting countless hours trying to get it working. What a huge mistake.
     
  2. joevt

    joevt Kilo Poster

    Messages:
    1,202
    You could backup manually by duplicating the Parallels 3 virtual machine file in the Finder.

    Parallels Tools is on the prl-tools-win.iso image file stored at /Library/Parallels/Tools/
     
  3. mrblog

    mrblog

    Messages:
    11
    No Windows Tools disk image in /Library/Parallels/Tools/

    The only file in that directory is prl-tools-lin.iso which looks like a Linux version (I did PD 6 to successfully upgrade a separate Linux VM).

    So why isn't the Windows Parallels Tools disk image there and where can I find it?
     
  4. joevt

    joevt Kilo Poster

    Messages:
    1,202
    Maybe check your logs for an installer failure. /Library/Parallels/Tools/ should contain at least the following:

    drivers.fdd
    prl-tools-lin.iso
    prl-tools-mac.iso
    prl-tools-os2.fdd
    prl-tools-other.iso
    prl-tools-win.iso

    If they're not there, then you need to reinstall Parallels Desktop 6.

    You can look at the contents of the Parallels installer by using Pacifist to open the invisible Install.mpkg file on the Parallels Desktop 6 installer disk image .dmg. The .mpkg is made of several .pkg installers. The Parallels Tools for Linux, Windows, and Mac are in different .pkg's. Maybe the Linux one succeeded and the other did not. I don't know how that's possible though unless the installer crashed or you ran out of disk space.
     

Share This Page