Parallels 8 / windows XP - can't delete my snapshots

Discussion in 'Mac OS X Guest OS Discussion' started by yazz123, Jul 8, 2013.

  1. yazz123

    yazz123

    Messages:
    2
    Parallels 8 / windows XP - can't convert from expanding to fix disk

    I'm running out of disk space on my macbook air, and noticed that my Parallels hdd file is 48GB even though the XP disk is only 28 GB.

    Inside the .hdd file there seems to be a number of ".hds" files. The parallels disk is configured as an "expanding disk".

    I'm basically trying to work out a way of getting the extra 20G back.

    I tried to convert the expanding disk to a fixed disk, but when I tried to uncheck the expanding disk option, I got a "Unable to edit the hard disk properties because it has one or more snapshots" message even though I don't have any snapshots.

    Does anyone know a way around this problem?

    ss.png
     

    Attached Files:

    Last edited: Jul 8, 2013
  2. yazz123

    yazz123

    Messages:
    2
    Managed to fix the problem by merging the .hdd file.

    Used the OSX terminal....

    prl_disk_tool merge --hdd filename.hdd

    File size dropped from 48G to 31G and I'm now able to "edit" the hd image without getting snapshot error messages.


    merge.png
     

Share This Page