Parallels 9 "Human Interface Devices" constant device disconnect/rediscovery

Discussion in 'Windows Virtual Machine' started by MrT0ad, Aug 29, 2013.

  1. bohannjn

    bohannjn Bit poster

    The issue seems to be with upgraded VM's. Apparently new VM's don't have this problem but seems like it should have been caught in testing.
  2. IljaDoert

    IljaDoert Bit poster

    Hi there,
    have the same issue here: Constant reconnect of some USB-Device on a converted VM (Windows 8).
    The mentioned Boot-Flag helped, but i hope they will fix it soon ...

    I also installed a fresh Windows 8 VM - No problems there. Clearly it has something to do with converted VM's ...
  3. guys, this problem is a sort of race in USB 2.0 implementation. It can happen on different kind of computers with different speed on different VM types. We are working on the problem and hope that the fix will be ready very soon.
  4. sgnewman

    sgnewman Bit poster

    Gracias. For the record, I too am having this issue.
  5. lukejr

    lukejr Bit poster

    I know QA isn't easy, but Mac QA is much easier as the base system hardware is tiny, no random hardware surprises. I'm disappointed this got through your QA for general release. I need to use my Virtual Machine this afternoon so I assume my only option is to roll back to v8? Is very soon within hours, or days? With Memorial Day weekend approaching will this issue be fixed today?
  6. Greenwood Digital

    Greenwood Digital Member

    I submitted report #28124522 for the same issue.
  7. arhoads76

    arhoads76 Bit poster

    Thanks for the quick attention and the boot flag temp-fix.
  8. Fafaxx

    Fafaxx Bit poster

    The boot flag also fixed it in my case. iMac 27" late 2012
  9. Priller

    Priller Bit poster

    Well, at least I got mouse control back. But, photo camera won't connect with this workaround in place. Grr!

    I really need a permanent fix by the start of next week.
  10. PiotrM

    PiotrM Bit poster

    Hi PArallels,

    First of all I upgraded to 9 only because issues with USB under Mavericks DP6 :)
    I've been trying your workaround - hardwer stoped to cennect / disconnect constantly however I cant use USB devices - I've got information (from Windows) that device can perform faster. Does it mean that I can use only USB 3.0 compatible devices right now?

    Best Regards
  11. lukejr

    lukejr Bit poster

    My Report ID: 28136264
  12. GradyV

    GradyV Bit poster

    The boot flag worked for me.. It was driving me nuts. It only did it on my win8 vm. My 2012 is fine. Caused problems today as I had to configure a USB/Serial for a cisco console cable.. It did work on my 2012.. Kinda a bummer on an upgrade but I guess its what I get for jumping in..
  13. NBW2011

    NBW2011 Bit poster

    I have the same problem after upgrading from 8 -> 9.

    I started up a Windows 7 Ultimate x64 VM that I used in 8 and I get the constant beeping every 6 seconds. It looks like "Virtual Keyboard", "Virtual Mouse", and "Virtual Bluetooth" are disconnecting/connecting at intervals which is triggering the beeps.

    Pretty much makes this VM unusable for any applications where I need to hear sound from (which is most every one).

    My host is a rMBP running 10.8.4.

  14. robotfo0d

    robotfo0d Bit poster

    upgraded from parallels 8 to 9 on my rMBP 13 (ML 10.8.4/Win7 x64 bootcamp partition). Boot flag resolved the issue.
  15. Superded

    Superded Bit poster

    I am not a happy camper...

    I have the same issue and the boot flag is a patch that at best stops the annoying sounds but creates other problems with usb 2.0 devices...

    I have submitted a support ticket#1713494 but the guy trying to help me is referring me to the following knowledge base:

    He did so even after I explicitly explained the problem in details and referred to this forum thread...

    Naturally the kb is useless in this case...

    You'd expect a product upgrade this expensive would add more functions and not break something that was working perfectly...


    I was refered to the following new kb :

    Basically it means in my case do not work until a patch comes out... (need sound and usb2.0 devices working at full speed)...

    I'll revert to v8 and restore my vm from time machine...

    Please issue that patch as soon as possible!
    Last edited: Aug 31, 2013
  16. Fabio deDO

    Fabio deDO Bit poster

    Hello, I have the same problem
    It seems that windows continuously "loose" and "find" mouse and keyboard
    looking in Windows Control Panel/Hardware, Virtual Bluetooth controller, virtual keyboard, and printer continuously appear and disappear
    Never happened with first version of Parallels 9 downloaded, problem appeared with first version update
  17. JosephLake

    JosephLake Bit poster

    Same here as well on a 2013 MacBook Pro Retna with just-upgraded Parallels 9. Constant device discovery/disconnection. Mac OS 10.8.4 and Windows 7 SP1 64-bit. Please help!
  18. Mixolydian

    Mixolydian Bit poster

    Unable to add boot flag, as I'm running Parallels with a Boot Camp partition (No write support to NTFS in OS X).

    Very disappointed by this. Hoping a fix comes ASAP.
  19. GeoffS

    GeoffS Bit poster

    Windows 8

    Windows 8.1 seemed to convert ok.
  20. Wolfje

    Wolfje Bit poster

    Thank heavens for this thread. It was driving me absolutely insane, and I didn't even have any idea on what exactly to google. Getting the same issue as everyone else and a little disappointed that this made it into release quality software. So glad this isn't an isolated one though.

Share This Page