Parallels Build 1884 and Mac Pro?

Discussion in 'Parallels Desktop for Mac' started by firebird2k, Sep 7, 2006.

  1. firebird2k

    firebird2k Bit poster

    Can we assume that this latest build supports the Mac Pro?

    Thought there would be postings in the forums with an announcement :) ..

    Saw it on Versiontracker first...
  2. Spunkmeyer

    Spunkmeyer Junior Member


    I'm running it right now...
  3. firebird2k

    firebird2k Bit poster

    Guess I posted too soon ;) .. apparently Ben posted on his blog first... hehe..

    Now what does he mean by 3.5Gb of Ram....

    Oh.. forgot to mention -> "Great Job Parallels!"
    Last edited: Sep 7, 2006
  4. groovyjason

    groovyjason Junior Member

    Build 1884 and mac pro with 5gb of memory

    Parallels build 1884 installed beautifully, I configured a VM, then when attempting to start the VM, kernel panic. :-(

    mac pro 2.66
    OS X 10.4.7
    5gb of Ram.

    Any ideas or workaround welcome. I really hate to have to remove ram to run a product. :confused:
  5. rinconj

    rinconj Member

    Great Job. Now it's time to buy a Mac Pro. several online stores are offering rebates to purchase Parallels along with a Mac. It'll be my 2nd Intel Mac and my 2nd copy of Parallels.
  6. FikseGTS

    FikseGTS Junior Member

    same here, Mac Pro 3.0GHz and 1884 causes a kernal panic..... :(
  7. Spunkmeyer

    Spunkmeyer Junior Member

  8. MacProUser

    MacProUser Junior Member

    Still Have Network issues...

    The new build works great for me. I have 6GB of ram, I got a message when I ran parallels that I'd have to reduce the ram to 4GB through boot-args setting, which I then did, no longer using the -legacy option. It works great for me, except for network access.

    I still have to toggle the OS X mtu to Jumbo frames, then back to regular frame size, then it works. Hope that this will get fixed soon, but it is certainly very very usable, even when I had to use the -legacy boot option.

  9. rinconj

    rinconj Member

    bummer. Hope it's fixed soon. I know I'll put at least 4GB of RAM into the babe if I do get one.
  10. groovyjason

    groovyjason Junior Member

    work around that worked for me!!!

    in terminal type:

    sudo nvram boot-args="maxmem=4000"

    reboot your mac

    now parallels works! System profiler only shows 3.91gb of mem instead of 5, but I can always script this to turn itself off and reboot

    to remove maxmem setting type in terminal:

    sudo nvram boot-args=""

    Reboot your mac

    you should see full mem again.
  11. groovyjason

    groovyjason Junior Member

    Major bummer!

    Ok Windows XP pro sp2 installed ok, then kernel panic on the reboot of that vm.

    Suse linux 9.2 installed beautifully, then upon reboot of that vm caused a kernel panic.

    Anyone have any thoughts??
  12. phantasm10

    phantasm10 Bit poster

    No go here either. Mac Pro 2.66 with 4gb (1gbx4) Crucial memory. Tried loading XP Pro Corp SP1 and XP Pro Corp SP2 slipstreamed and after the windows installer reboots I get the kernal panic. I used

    sudo nvram boot-args="maxmem=4000"

    and also tried

    sudo nvram boot-args="maxmem=3500"
  13. controller

    controller Member

    I also get Kernel Panics as soon as the VM starts up. I have a Mac Pro 3.0 with 4gb (8X512).

    I used both maxmem settings.

    I think it is great that Parallels saw fit to release an update and press release about it, but as per the Mac Pro... this release seems not only half-baked but the oven wasn't even turned on.

    :) I know it's a beta.. but it's more like pre-alpha. I do applaud Parallels for working on it though.
  14. artpease

    artpease Bit poster

    No go also...

    Mac Pro 2.66 3gb mem.
    WinXP SP2 installed to first boot which crashed the Mac Pro
    After restart when I start the VM it shows the black Windows boot screen and then returns to Parallels property page. Repeats all the same.
    Just an FYI for Paralles Team...
    Last edited: Sep 8, 2006
  15. amin

    amin Member

    I'm installing now on the Mac Pro (2.66GHz, 2GB RAM) - I hope I don't get a KP! Just installed on my Core 2 Duo iMac, and that was smooth sailing.
    Last edited: Sep 7, 2006
  16. zzzachi

    zzzachi Junior Member

    1884 Does not work ! Mac Pro 2.66, 3GB Ram

    Here Build 1884 does not work at all !

    It starts until the windows logo comes up, then suddenly stops.
    no kernel panic but i'm back to the parallels app window.

    setting maxmem to 4000 makes no difference and i dont
    see why it would because i have only 3gb ram.


    could the parallels settings (memory etc) make a difference?
    should i set up a new pc? (i'm running windows xp pro)


    btw... starting in safe mode seems to work... but i didnt install
    a lot of things in this vm... hmm. trying to make a new vm now.

    okay, this ended in a kernel panic... hey great, what a progress!

    i don't know what to say. i can't see why this was posted as a
    fix for the mac pro. ???
    Last edited: Sep 8, 2006
  17. fhx1274

    fhx1274 Bit poster

    Also No Go

    Worked until this morning with build 1862 and the "-legacy maxmem=2000" without too much problems. Ran NT4 and Solaris 10 just about fine.

    After upgrading this morning to 1884 things just started to fall appart :
    - of course, without any maxmem settings, Parallels tells me that there is an issue with PAE addressing and that I hae to set maxmem to 4000
    - but in fact you have to set it to 3500 unless it won't work stating it can't find the hypervisor
    - I started to have the "vt-x locked by firmware" message, never had it before 1884
    - had so far two consecutive Kernel crashes when the NT4 VM rebooted
    Edit: Forgot to mention that the last crash caused the Mac to refuse to boot, even after 2 power down... had finally to zap the pram to get it up again.
    But then, I had to reboot one more time because of course, zapping the pram clean the boot-args and thus I had to re-set the maxmem to 3500.. Duh...

    I really hope they fix this soon.. at the moment it is very much frustrating
    Last edited: Sep 8, 2006

Share This Page