Parallels build 5600 and DHCP problems

Discussion in 'Windows Guest OS Discussion' started by Softfailur, May 9, 2008.

  1. Softfailur

    Softfailur Bit Poster

    Messages:
    3
    Hi all,

    After upgrading to the newest build I have encountered weird problem with DHCP. It tries to get 192.168.1.1 address which is already assigned to other machine.
    This behavior occurs only when using bridged networking. After choosing 'shared networking' the problem disappears and I can use network connection under Win XP. Although I would really prefer going with "Bridged Connection" as I've done until now. I haven't changed anything in my Windows configuration and reinstalled Parallels Tools right after upgrade to build 5600 was finished.
    Anyone has any idea what can be done to overcome this? Any help will be appreciated.
     
  2. Olivier

    Olivier Kilo Poster

    Messages:
    610
    I have no solution for now, but wanted to confirm seeing the exact same problem here. Bridged networking had always been working perfectly for me.
    In my case, it's not that it tries to get 192.168.1.1 (which would be my router), it somehow gets the same IP as the mac book host itself. A warning pops up on the Mac OS X side and the macbook change its IP.... to see Vista do the same seconds afterwards and the story starts again...

    Wait a minute... I think the bug only shows when your VM comes back from suspend. It looks like if I shutdown vista completely and then start it, I'm okay.
     
  3. fortuna

    fortuna

    Messages:
    14
    I have the same problem. The workaround above does not work for me. Shutting down, closing the VM, exiting Parallels, & restarting also does not solve it for me.
     
  4. fortuna

    fortuna

    Messages:
    14
    Sorry, first-post foolishness. I should have added that I am running XP SP2 and have experienced exactly the same as the first poster i.e the problem appeared after doing nothing except upgrading to Build 5600 and reinstalling Parallels Tools. Parallels VM then grabs same IP as Mac host. I would rather not use static IPs and I need to use Bridged mode which has worked perfectly ever since I started using Parallels a little over a year ago.
     
  5. bi11

    bi11

    Messages:
    115
    It's not DHCP thats broken, it is Bridged that is broken

    Build 5600 is broken with respect to Bridged Networking.

    I thought I would be smart and force DHCP off and instead assign the specific IP address I want it to use. Nada, what I want doesn't matter, Parallels network adapter still steals the host IP address. Thats just stupid! Eventually, I tried telling bridge network to use a specific interface instead of default. That seemed to resolve my problems. Now the Vm uses the IP I set in the network properties. (thankyou very much)

    I'm not prone to bash a vendor as I work in the Software Industry and know how difficult it is to ship quality software, but some things are basic tests and should be either automated regression suites or you have a friken large QA workforce of monkeys running through a manual check list.

    I'll just add that I have submitted a few incident reports in the past via the email interface where by you get a incident number and nice reply on the webpage that a support engineer will get back to you/reply/resolve in 3 days. I guess a *ignore* on all of them is the standard 3 day response.


    To Parallels Management, get with the program. You advertise a million users (http://www.parallels.com/en/products/desktop/) and if that is true, I can't believe you haven't gotten more heated complaints already.
     
    Last edited: May 10, 2008
  6. jasonw

    jasonw

    Messages:
    90
    I am getting the same problem with #5600. Time to downgrade to #5584.
     
  7. fortuna

    fortuna

    Messages:
    14
    I have to say that I submitted a report yesterday and received a response a few minutes ago. The engineer rehearsed the usual workarounds which doesn't really address the broken Bridged networking issue directly but it is at least a fast response and on a Sunday too. I've restated my request for a fix but in the meantime I'm using the workaround you outlined. Thanks.
     
  8. mloskot

    mloskot

    Messages:
    4
    I confirm the problem exists.

    I'm using Shared Networking on WinXP SP2 guest, and I'm experiencing problems - DHCP does not assign valid IP for the guest OS.

    However, when I switch to Bridged Networking, valid IP is assigned and network connection from guest OS works.

    Nice, but it would be nicer if you post the workaround here to the forum, so we don't have to submit support requests individually.

    --
    Mateusz Loskot
     
  9. fortuna

    fortuna

    Messages:
    14
    If you look at my message, you'll see that I quoted from the message of bi11 above, and then addressed him. In other words, the workaround to which I referred is the one that bi11 outlined above. If you scroll up three messages and read his message you'll see it, but I've quoted it below for your convenience. Hope this helps.

    Also, if you read my message you'll see that I'm not asking tech support for a workaround, I'm asking for a fix. The workarounds they suggested are to use Host-only or Shared networking. These alternatives are explained in the Parallels documentation which you can access directly from Parallels > Parallels Desktop Help.
     
  10. mloskot

    mloskot

    Messages:
    4
    Yes, I apparently misunderstood you. I thought you have submit a request of support.
    Anyway, thanks for the clarification!

    Cheers
     
  11. fortuna

    fortuna

    Messages:
    14
    No problem.

    I have submitted a report. It's been escalated, and I'll report back any useful info.
     
  12. manfredell

    manfredell

    Messages:
    109
    I had the same problem and couldn't explain it. Until I found this thread.
    I have reverted to the previous build and the problems have gone.

    Why do they publish such a buggy version, this is not a small bug but a big one.
     
  13. gfs

    gfs

    Messages:
    2
    Same problem here with Bridged networking. I'm getting an error from Windows that the IP address is already in use by another computer. Had no problem before the most recent upgrade. This is a bug that has to be fixed FAST...amazed they released update with such a significant bug.
     
  14. akidd

    akidd

    Messages:
    34
    A million users and no one tests Bridged networking before a release? ahem.

    Where can I get 5582 so I can downgrade? I've purchased 3 licenses. Why does every release have such obvious issues.
     
  15. manfredell

    manfredell

    Messages:
    109
    I really have to wonder why nobody from Parallels says something here....
    BUT THEN, their support has always been, well......
     
  16. Eru Ithildur

    Eru Ithildur

    Messages:
    1,966
    I've got 5582 backed-up on my server somewhere, drop me a PM if you can't find the DL link. I really need to get my site re-launched with the Parallels section of my site up.
     
  17. mavidal

    mavidal Product Expert

    Messages:
    122
    Hello:

    May I suggest that y'all reboot your routers to see if that clears up the issue? I ran into the same problem on my MBP and that was how I cured it.

    MV
     
  18. manfredell

    manfredell

    Messages:
    109
    This has nothing to do with routers....

    We cant reboot our Windows servers because of this, can we....
    This IS a Parallels problem
     
  19. John@Parallels

    John@Parallels

    Messages:
    6,450
    Hello guys,


    Can you please reply with this information

    * Parallels Desktop version and build: Parallels Desktop- -> About Parallels Desktop
    * an XML file with a copy of system profile: Applications --> Utilities --> System Profiler --> File --> Save
    * Guest OS full version with SP included (if they are);
    * a copy of /home/<username>/Documents/Parallels/<VM name>/<GuestVM>.pvs
    * Archive of /Library/Parallels/bugreports/ (right click on folder --> Create Archive)
    or ~/Library/Parallels/bugreports/

    * /Library/Logs/panic.log
    or ~/Library/Logs/CrashReporter/Parallels.crash.log from the Mac side;

    and additional information about network


    1. Please tell me if you have Keyspan programs installed on Mac.

    2. Do you have Firewall enabled on Mac and Windows sides?

    3. Do you have VPN?
     
  20. manfredell

    manfredell

    Messages:
    109
    So, and who are you to request that many info??
     

Share This Page