Parallels Desktop 16 and Windows 10. Windows is extremely slow with 100% processor load

Discussion in 'Windows Guest OS Discussion' started by MHofmann1965, Sep 21, 2020.

  1. MHofmann1965

    MHofmann1965 Bit Poster

    Messages:
    4
    My Windows 10 Pro 2004 in the 64-bit version under Parallels Desktop 16 is extremely slow and the resource monitor shows a processor load of 100%.
    I installed Windows 10 with an ISO DVD.
    When booting into Windows, it takes 10 minutes before you can work at all.
    When you click on the Windows symbol, it takes 30 seconds for the shutdown menu to open and another 10 minutes for it to shut down.
    This is not a useful condition.
    I've read through here in the forum and tried everything: Without success.
    Now, through many tests, I have found the right setting where Windows runs quickly and smoothly (at least for normal Office applications).
    Boot time until you can work: 20 seconds.
    Time-consuming operations such as Windows 10 cumulative update: 5-10 minutes.
    Open Word 2016: 20 seconds. That's enough !
    My hardware:

    Apple Mac Pro Early 2008 (3.1) w. 2 Intel Xeon 2.9 GHz (= 8 cores with 2.9 GHz)
    16 GB of RAM
    Graphics card Nvidia GeForce GT 630 with 2 GB RAM (metal-capable)
    1 TB SSD (Samsung 860 EVO)
    macOS Catalina 10.15.6 with patch for use with unsupported Macs
    Parallels Desktop 16
    Windows 10 Pro 2004 in the 64 bit version (installation from original ISO DVD)

    Catalina runs very quickly and without problems. I use Photoshop and video editing software and it all goes super fast. With 8 cores with 2.9 GHz, no wonder.
    The default setting is activated at Parallels:
    Windows 10:
    Processors used: 2
    Storage: 3.5 GB
    Adaptive hypervisor: On
    Graphics card: memory automatically

    Result: As described above, Windows 10 is extremely slow.
    Now I thought: more processors = faster.
    Processors used: 4
    Boot time now: 30 minutes. Click on the Windows symbol: something happens after 2 minutes.
    Shutdown: approx. 30 minutes.

    So again 2 processors but adaptive hypervisor: off
    No improvement. Boot time just under 10 minutes.

    So more RAM allocated:
    4 GB: no improvement
    6 GB: no improvement
    8 GB: no improvement

    Graphic card:
    a lot of RAM (2 GB): no improvement
    little RAM (64 MB): no improvement.

    I was at the end of my game !!

    Now one last act of desperation (although illogical):
    Processors: 1

    Lo and behold: Windows is super fast!

    Now after a few tries my final setting:
    Processors used: 1
    Memory 4 GB (4096 MB)
    Adaptive hypervisor: Off
    Graphics card: memory automatically.

    Windows 10 is now fast and usable.

    And now the hit, where I let myself be misled:
    It is still displayed on the Resource Monitor:
    Windows 10: CPU 100% and RAM 4.1 GB
    And in the system tray it says CPU usage between 30 and 100%
    Significant CPU is used: Windows Services
    And even if the CPU is red (100%), Windows runs quickly and smoothly.

    These tips are meant to be of help to anyone who has a similar problem!
    greeting
    Michael Hofmann
     
    TimB19, KevinM44, RomiR and 2 others like this.
  2. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    8,224
    Hello Michael,
    Thanks a lot for sharing your detailed experience with us and other users.
    We have one question to you, did you perform any steps on the Windows side? Did you try the clean boot for example?
     
  3. MHofmann1965

    MHofmann1965 Bit Poster

    Messages:
    4
    No. I haven't taken any steps on the Windows side. I haven't tried a clean boot either.
    I only made all the settings described in Parallels Desktop. Windows was installed as normal via an ISO DVD.
    I haven't made any adjustments in Windows.
    Apparently there is only the performance brake if you set more than one processor for Windows, although my Mac have 8 cores.
    greeting
    Michael Hofmann
    Germany
     
  4. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    8,224
    Thank you for your reply, Michael
    May we ask you to try the clean boot and check the issue?
     
  5. MHofmann1965

    MHofmann1965 Bit Poster

    Messages:
    4
    I have now started Windows 10 via a clean boot. All third party processes are disabled. A virus scanner is not installed. With 1 assigned processor in Parallels Desktop, Windows 10 is normally fast (approx. 10 seconds boot time). With 2 or more processors, Windows 10 is extremely slow even with clean boot (up to 10 minutes boot time and up to 1-2 minutes waiting time when you click something). So, a clean boot does not bring any improvement !
    greeting
    Michael Hofmann
    Germany
     
  6. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    8,224
    Does your Windows work ok with 1 CPU? Am I right?
     
  7. MHofmann1965

    MHofmann1965 Bit Poster

    Messages:
    4
    Yes. My Windows 10 works perfectly with 1 CPU. But my Mac has 8 CPU cores and when I run Windows 10 with Parallels Desktop with more than 1 CPU, Windows 10 is extremely slow.
    The standard setting in Parallels Desktop is 2 CPU cores for Windows 10. Windows is extremely slow then.
    greeting
    Michael Hofmann
    Germany
     
  8. WesleyR2

    WesleyR2 Bit Poster

    Messages:
    1
    I can confirm this behavior. I am up-to-date on both Mac OS and Windows and Parallels. I have 16 cores available on my Mac Mini. I have 6 devoted to my windows VM. When i boot up, CPU utilization is at 600% for the first 10 minutes then drops to nothing. Windows is unusable for those first 10 minutes. This has been an issue since July of last year and persisted through all new versions of both OSX and Parallels. Please advise.
     
  9. ryderpat

    ryderpat Bit Poster

    Messages:
    2
    me too in Mac Pro 3.1
    One 1 CPU will be fast in Parallels, do not more than 1 .
    what ever in Parallels latest version 16
     
  10. LarsB5

    LarsB5 Bit Poster

    Messages:
    1
    Same here on two XEON (Mac Pro) machines.
    As soon as more than one CPU is configured for use in the VM, everything slows down to unbearable performance. We have tested this on Win7 (32bit and 64bit), Windoes 10 (64bit) and even Linux. This is clearly a long standing bug in Parallels Desktop - we even tried older versions back to PD10 and PD11! Always same outcome.
    Now the strange thing: If you run the same setup with more cores on an old Core2Duo machine (with 2 cores enabled for the VM) or Core i7 (i.e. 4 cores enabled), everything is fine and system performance is good while not hogging up resources (CPU load).
    So - I think it boils down to some XEON related bug in PD.
    How about doing something about this, Parallels, instead of throwing frequent upgrades at us users that do not fix it but instead claim to be compatible to the latest macOS versions (while the old ones still run fine on those newer OS)?
     
  11. mkertzman

    mkertzman Bit Poster

    Messages:
    5
    Thank you SO much! I have been dealing with this issue for months and just ran across your one-processor soluition and it fixed my performance problem! I would never have thought of trying that! Thanks again!
     
  12. koppah

    koppah Bit Poster

    Messages:
    63
    Wow, I'm on an M1 MacBook Pro. Just switched my VM over to only use 1 CPU and it is a WHOLE LOT FASTER (ironically).
     
  13. DanielK74

    DanielK74 Bit Poster

    Messages:
    2
    Im not sure if its related but my win10 guest OS was so slow I couldnt use it anymore, this on a MBP 16 corei9 with 8 cpus and 24GB Memory given to the virtual environment. Today I disabled spotlight (settings - spotlight in mac os) on both Machintosh HD and also on my windows bootcamp (bootcamp partition was not used by parallels so it probobly didn't matter.) I also unclicked adaptive hypervisor. Now this really hit the spot. My parallels is again usable, such a difference, haven't tested which of the two that made the difference but my bet is on disabling spotlight.
     
  14. DaveD8

    DaveD8 Bit Poster

    Messages:
    1
    Does parallels have any estimate about when this terrible problem will be resolved? been using parallels for many years and this is the worst problem I've ever seen.
     
  15. TimB19

    TimB19 Bit Poster

    Messages:
    1
    Thank you so much for sharing this. I'd gotten to the point where I'd decided to ditch Parallels and just by a Windows machine instead. Glad I won't have to. Maybe Parallels can be persuaded to do some more testing before they make us buy their next, umm, "upgrade"?
     
  16. HenrikJ2

    HenrikJ2 Bit Poster

    Messages:
    2
    Same problem, same solution (1 CPU). Tx.
     
  17. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    8,224
    Hi, did you check this KB article?
     
  18. HenrikJ2

    HenrikJ2 Bit Poster

    Messages:
    2
    Yes, thank you! I did check that, but nevertheless the solution that solved the problem was to assign 1 CPU and nothing more. I thank both MHofmann1965 for posting the solution/workaround and Parallels for giving me the possibility to use my (needed!) Windows programs on my Mac. Thanks to both!
     

Share This Page