Parallels Desktop 17.1 (51516) seems to have broken USB on Windows 11 ARM

Discussion in 'Parallels Desktop for Apple Silicon (M1) Mac' started by ChrisP28, Oct 20, 2021.

  1. RoderickL

    RoderickL Bit Poster

    Messages:
    13
    Yes that is identical to my experience. I have received a reply from Support, who have advised to try all the things that I have done already, and if that does not work then to reinstall Parallels. Reinstallation is perhaps not as bad as it sounds because you do not lose the virtual machine. Might look into this at some point, however for the time being I have actually been finding that using my MacBook Pro 16 inch M1 Pro without a USB microphone is actually pretty good. The built-in microphone is of studio quality and I have been getting very accurate results. I have used voice recognition for over 20 years , and we have always been told that we must use an external microphone, but perhaps for the sake of reliability this is the way to go. Certainly makes the set up much more portable. I fully appreciate that if you use an external monitor, this might complicate things a little bit although perhaps not to be a dealbreaker.
     
  2. wjjw73

    wjjw73 Bit Poster

    Messages:
    1
    Version 7.1.4-51567 - still USB issue not fixed -> again back to 17.0.1 (which is still the only stable version).
     
    JoachimV likes this.
  3. HC_3

    HC_3 Kilo Poster

    Messages:
    104
    I can't get out of my astonishment and I can't hold on to myself any longer:

     
    JoachimV likes this.
  4. RoderickL

    RoderickL Bit Poster

    Messages:
    13
    I couldn't agree more. I have given up with this issue after 2 months of my time wasted. Now using Dragon Anywhere on an M1 iPad Pro to completely circumvent the need for W11 on a MacBook. Never lets me down and the 5 studio microphones on the iPad are superb.
     
    HC_3 likes this.
  5. JerryG

    JerryG Bit Poster

    Messages:
    30
    When I first switched to Parallels from VMWare, I was so excited and impressed that my Philips SpeedMike worked so well with v7, Windows 11, and my M1 computer.

    When 7.1 came out, I upgraded and immediately noted that my microphone choice was no longer indicated with a check mark under USB and Bluetooth under the Devices. And sure enough, USB microphone input became and remains very difficult to maintain integrity. It fails while I'm using it. Input volume drops to near nothing. It usually takes me a few minutes of choosing the device in the menu and rebooting, often multiple times to get it to remain stable.

    Given how many complaints there have been over this issue, I'm also astonished that the problem seems to be entirely ignored my Parallels. I moved up from my M1 MacMini to the Studio Ultra based upon my confidence in Parallels and my being able to do productive work on Parallels. Wow, was I wrong.

    My disenchantment with Parallels runs very deep. If VMWare can get their M1 Windows sh*t together, I'll go back to them.
     
    HC_3 and JoachimV like this.
  6. RoderickL

    RoderickL Bit Poster

    Messages:
    13
    Yep, my experience. I can't rely on such unreliable software, so won't be subscribing again.
     
  7. RoderickL

    RoderickL Bit Poster

    Messages:
    13
    Update...I didn't get the crucial check mark with Philips SpeechMike or Buddy 6G USB external sound card. However, I am consistently getting it with an Andrea USB sound card and my Sennheiser ME3 mk 1 microphone. Results are great. It's not frozen or disconnected so far. I need to try it for a couple of days to be sure, but this seems to be an issue that can be resolved with different hardware.
     
  8. RoderickL

    RoderickL Bit Poster

    Messages:
    13
    I knew it would be too good to be true. With the above set-up, Windows 11 just stopped hearing any sound from the microphone/sound card, even though it knew it was still connected and the Parallels drop-down USB option was still checked.
     
  9. Gawied

    Gawied Bit Poster

    Messages:
    14
    Hi Parallels,
    any idea when this USB issue on Windows 11 ARM will be fixed? This is now taking quite long - please let us know what to expect.
     
    JoachimV and HC_3 like this.
  10. HC_3

    HC_3 Kilo Poster

    Messages:
    104
  11. Gawied

    Gawied Bit Poster

    Messages:
    14
    This is now getting ridiculous! Any response Parallels? Even just an acknowledgement that this an issue will also do.
     
    HC_3 and JoachimV like this.
  12. RoderickL

    RoderickL Bit Poster

    Messages:
    13
    Ok so for anyone who uses Parallels in Windows 11 with Dragon Professional Individual, I have moved things forward to a usable situation. I found I could not get the tick/check mark in devices drop-down in Parallels with my Philips SpeechMike. Also I got horrible crashes and lost work.
    However I am now using an Andrea USB-SA external sound card and I do get the check mark/tick, which is good. It works well with Dragon, with either my Sennheiser ME-3 mk 1 microphone or my new SpeechWare FlexiMike.
    But...from time to time, Dragon stops producing any text, even though everything remains connected in Parallels and Dragon even still sees the USB soundcard. A quick reboot of Dragon solves the problem with no loss of work.
    A usable solution for me. Nuance have not approved wither W11 or using Dragon with Parallels, so I can't complain too much. At least I can edit documents with Dragon on my Mac.
    P.S. I also found performance of Dragon was very laggy and slow unless I allocated 8 processors and 12 Gb of RAM to the VM, so don't use the automatic setting in Parallels.
    Hope this all helps someone out there.
     
  13. RoderickL

    RoderickL Bit Poster

    Messages:
    13
    Further update - no need to reboot Dragon, in fact that does not always work. Just closing and reopening Dragon voice profile brings the microphone back. Maybe I need to try creating a new profile and that might solve the problem.
     
  14. Gawied

    Gawied Bit Poster

    Messages:
    14
    I logged a ticket with Parallels regarding this issue and see below for their final response:

    Our development team is working on fixing the issue with usb devices, since different devices require tests, we need more time to fix this issue.
    We recommend that you install Parallels Desktop 17.0.1:
    1. Uninstall Parallels Desktop 17.1.4 as described in the article: https://kb.parallels.com/en/124255
    2. Download and install Parallels Desktop 17.0.1 : https://download.parallels.com/desktop/v17/17.0.1-51482/ParallelsDesktop-17.0.1-51482.dmg
    Note: When running the Parallels Desktop 17.0.1 installer, you will be prompted to update to 17.1.4 (which is the latest one). Please close that window, and then click "No, use current" to proceed with installing version 17.0.1. Once installed, it should activate automatically, using the license associated with your Parallels account.
    As soon as the issue is fixed, we will get back to you.


    At least they have acknowledged the issue and they are working on a solution. Seems like we will have to wait for them to fix this issue.
     
    JoachimV and RoderickL like this.
  15. RoderickL

    RoderickL Bit Poster

    Messages:
    13
    Ok so I'm not saying I've found a fix here, but I suddenly realised something today. I have tried both a Philips SpeechMike and a SpeechWare FlexiMike with Apple Voice Control on the Mac and was getting very bizarre results - duplication of words, insertion of new paragraphs etc. So I connected both microphones separately to my Mac with a POWERED Apple USB-A to USB-C adapter and bingo! Voice control dictation works perfectly. That is certainly a big move forward. In fact it might be good enough to replace the need for Dragon on Windows via Parallels for me, although it does make more mistakes.

    So then I tried this setup with Dragon Professional in Windows 11 in Parallels. I noticed that instantly, the Philips SpeechMike connected to the VM, WITH A CHECK MARK (tick for those in the UK). This has rarely happened reliably for me previously. Then I dictated a full page of A4 with no dropped USB connection. Also it was noticeably faster. So fast that I might try putting the resource allocation back to auto, rather than giving the VM more resources (I'm using a MacBook Pro 16" with an M1 Pro processor).

    I'm not promising this is a solution, but it's certainly a big move forward. I am running 17.0.0 after Gawied's post above BTW. I decided to go right back to basics with regard to the version number. I'll let you all know how I get on over a few days, as that's the real acid test, and I'm not keeping my hopes up, but in the meantime, if you're having problems, make sure your USB adapter is powered, and I strongly suggest you use an Apple one.
     
  16. HC_3

    HC_3 Kilo Poster

    Messages:
    104
    thank you for your interesting experience report, @RoderickL

    BUT: i do use a powerd adapter and it still does not work with a parallels version higher than 17.0.1.

    with 16.x everything worked fine. (by the way, since then nothing has changed in the configuration of my macbook pro and accessories).
     
  17. RoderickL

    RoderickL Bit Poster

    Messages:
    13
    Ok @HC_3, noted. I found my problem occured again after testing for a few hours. However, powering the USB adapter has resolved the problem that I had with the Philips SpeechMike and SpeechWare FlexiMike behaving very erratically with Apple Voice Control, and I now have a very usable speech dictation solution which is entirely MacOS-based (and offline) for dictating Word documenets and emails. Benefit of the Philips SpeechMike is that it has a motion sensor, so you can have Voice Control on constantly and the mic only turns on when you pick it up, turning off again when you put it down.

    I hope this helps someone out there, if only whilst we are waitin for a Parallels soultion.
     
  18. HC_3

    HC_3 Kilo Poster

    Messages:
    104
    @RoderickL: that makes me very happy for you!

    @parallels: but unfortunately we still don't have a solution for the usb-problem that parallels has been keeping us waiting for months :(

    sorry to say this so clearly, but it is incomprehensible to me how you can treat paying customers in such a way that you don't even communicate why it is so difficult to solve the problem ...

    @AlL: but maybe someone here in the forum has any idea what this can be?
     
  19. RoderickL

    RoderickL Bit Poster

    Messages:
    13
    So I wound back to version 17.0.1 and tried using this with my SpeechWare FlexiMike and Andrea USB-SA external sound card. I had the same problem again (random USB disconnection). I then wound back further to version 16.5.2, which is available here https://www.parallels.com/products/desktop/download/

    The problem still occurs, but I am using Dragon Professional and I have just tried a workaround when it happens by unchecking the microphone in the devices drop-down list and then checking it again and at least I was able to carry on dictating without having to close and reopen my voice profile or close and reopen Dragon. Only been able to try it once so far but it worked. This is a major improvement which only takes a few seconds to sort out. Not ideal, and it is supportive evidence that the problem is with Parallels rather than Dragon.

    Incidentally, for anyone contemplating using a Philips SpeechMike with any version of Parallels 17 at the moment, don't bother. Dragon crashes, Word crashes and you will lose your work. The SpeechMike Voice Control app update issued yesterday has not resolved the problem. At least the FlexiMike with the Andrea USB-SA external sound card seems to enable it to be more stable and you even get a check mark. The check mark disappeared for me like many others in later versions of Parallels, when using the SpeechMike. My SpeechMike works perfectly on my Surface Pro 7 running Dragon in Windows 11. However, we all want to use our Macs!

    Let's hope they get this problem sorted sooner rather than later.
     
    HC_3 likes this.
  20. RoderickL

    RoderickL Bit Poster

    Messages:
    13
    Further update in case this helps anyone. I connected my SpeechMike to Windows 11, set Parallels (I'm back to version 16 now) to automatically connect the mic to Windows (not the Mac), and the check mark was automatically applied in the devices menu. Result was 24 hours of connection and perfect function before it froze up and I had to kill Dragon Professional in task manager. I just wonder if this is a memory issue (settings were 8 processors and 8 Gb RAM on my M1 Pro MacBook, and any more than that and W11 would not start).

    So on that basis, perhaps a reboot of Dragon at least once per day but 2-3 times per day ideally, will be a workaround, until this issue is resolved (if ever!). Not having any issues with the mic disconnecting, and there was no problem with the Andrea USB-SA sound card either, in Parallels 16, so I'll be staying with that.
     

Share This Page